Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] compiling wine-staging with gallium9
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Utsuho Reiuji
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2013
Posts: 114

PostPosted: Fri Sep 29, 2017 4:55 pm    Post subject: [solved] compiling wine-staging with gallium9 Reply with quote

Hi guys, I'm having the following problem at the configure stage of compiling wine:
Code:
configure: error: Couldn't load Gallium nine module at '/usr/lib64/d3d/d3dadapter9.so.1' (found by pkg-config)

(I'm compiling WOW64, this happened at doing the 32bit part). I thought this lib is covered by mesa with the d3d9 flag, but apparently it is not (since I have it installed that way). What am I missing?


Last edited by Utsuho Reiuji on Sat Sep 30, 2017 2:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 578

PostPosted: Fri Sep 29, 2017 5:31 pm    Post subject: Re: compiling wine-staging with gallium9 Reply with quote

Utsuho Reiuji wrote:
Hi guys, I'm having the following problem at the configure stage of compiling wine:
Code:
configure: error: Couldn't load Gallium nine module at '/usr/lib64/d3d/d3dadapter9.so.1' (found by pkg-config)

(I'm compiling WOW64, this happened at doing the 32bit part). I thought this lib is covered by mesa with the d3d9 flag, but apparently it is not (since I have it installed that way). What am I missing?


What wine ebuild are you using? I suggest using wine-any with the staging and d3d9 use flags. The old wine ebuild doesn't work anymore. (due to upstream policies mostly, it's not a gentoo problem exactly, that's why the new ebuilds were made.)

Here is some info so that you know what's up.
https://wiki.gentoo.org/wiki/Wine:_New_Packaging
Back to top
View user's profile Send private message
Utsuho Reiuji
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2013
Posts: 114

PostPosted: Fri Sep 29, 2017 7:04 pm    Post subject: Reply with quote

Hi duby2291.
As much as I would like to do that, but I need at least version 2.16 of wine (afaik, the latest ebuild of wine is 2.3). So it's either layman or building it myself I guess :/

Edit: Oh my gosh, am I stupid....
When looking up versions, I looked at wine, not wine-any....
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 578

PostPosted: Fri Sep 29, 2017 7:57 pm    Post subject: Reply with quote

Utsuho Reiuji wrote:
Hi duby2291.
As much as I would like to do that, but I need at least version 2.16 of wine (afaik, the latest ebuild of wine is 2.3). So it's either layman or building it myself I guess :/

Edit: Oh my gosh, am I stupid....
When looking up versions, I looked at wine, not wine-any....


Yeah, you got it. I think wine-any will work for you. (and it's slotted which is awesome) Maybe you could report back here if you get it to work so we know for sure.
Back to top
View user's profile Send private message
Utsuho Reiuji
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2013
Posts: 114

PostPosted: Sat Sep 30, 2017 2:09 pm    Post subject: Reply with quote

It worked just fine. I will mark this as solved then.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum