Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
File-roller and xarchiver don't display soft links.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
JustAnother
n00b
n00b


Joined: 23 Sep 2016
Posts: 64

PostPosted: Thu Sep 21, 2017 9:04 pm    Post subject: File-roller and xarchiver don't display soft links. Reply with quote

I have a simple backup scheme whereby I have a tree of soft links to critical config files, both in my user account and the root account. (I gave up trying to link to /etc files from my user account -- to many permission problems.) Two commands:
Code:
zip -r --symlinks file.zip ~/path/to/links
zip -r file.zip ~/path/to/links,

do the job nicely. One captures the link files themselves, the other captures the referent files.

I have been using file-roller on debian for awhile, and am now using it on gentoo.

Last night I noticed that file-roller does not seem to display the soft links in the archive.
Code:
unzip -l file.zip

does show that the links are there.

This caused me grief because I thought I had forgotten to properly symlink my other OS installations, and couldn't find the soft links using file-roller. Now I realize that the issue is file-roller.

I installed xarchiver and to my surprise it too didn't show the soft link files either.

Is there some reason for this? One would think that a gui archive app would show what is in the archive, and not leave things out.
Is it some kind of security issue?

Also, the help menu item on both file-roller and xarchiver don't work. Xarchiver says it can't find a /usr/share/doc file.

Code:
equery uses app-arch/file-roller
equery uses app-arch/xarchiver

both say nothing about a doc use flag.

The xarchiver web page says there is a doc flag.

Ufed says that a local doc flag applies to xarchiver.

I added
Code:
app-arch/file-roller doc
app-arch/xarchiver doc

under package.use, but
Code:
emerge -uDNva @world

didn't want to change anything.
(Ufed does at this point show that the local use flag doc is set on xarchiver.)

So it appears that something is amiss. Does anybody have any ideas?

Thanks
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Sep 21, 2017 9:37 pm    Post subject: Reply with quote

Do you have the xattr useflag set for e.g. libarchive?
Back to top
View user's profile Send private message
JustAnother
n00b
n00b


Joined: 23 Sep 2016
Posts: 64

PostPosted: Thu Sep 21, 2017 11:09 pm    Post subject: Reply with quote

Ufed says that xattr is set for 6 packages, including libarchive.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Fri Sep 22, 2017 6:22 am    Post subject: Re: File-roller and xarchiver don't display soft links. Reply with quote

JustAnother wrote:
Also, the help menu item on both file-roller and xarchiver don't work. Xarchiver says it can't find a /usr/share/doc file.

    As for app-arch/xarchiver-0.5.4:
  • Help —> About worksforme
  • Help —> Contents F1 nothing happens, did you consider filing a bug for this?
Back to top
View user's profile Send private message
JustAnother
n00b
n00b


Joined: 23 Sep 2016
Posts: 64

PostPosted: Fri Sep 22, 2017 11:41 pm    Post subject: Reply with quote

For xarchiver, where should I file the bug? It looks like this doc variable is the issue, which makes it a gentoo portage issue. On the other hand the symlink issue appears to be an xarchiver issue. What the best way to deal with this?
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Sat Sep 23, 2017 4:45 am    Post subject: Reply with quote

https://bugs.gentoo.org/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum