Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba bug or something else?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1342
Location: Fayetteville, NC, USA

PostPosted: Tue Sep 19, 2017 11:27 pm    Post subject: Samba bug or something else? Reply with quote

I just did the regularly scheduled upgrade on a Gentoo domain controller at a client location and noticed an issue. The Samba service will not start correctly. This is an AD DC, and when trying to start Samba it fails and the logs essentially say you cannot start nmbd/smbd when Samba is a DC. I know that, but the script must only try to start those without checking the configured mode. This means that at each and every reboot, no matter the cause (power failure, upgrade, changes, whatever) somebody must login as root and start Samba with "samba" in the shell. This is very bad because we may not know the system died and clients may not notice issues right away.

So is there some other service I can add to the default runlevel to start and stop Samba when it is a DC?
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
brownandsticky
n00b
n00b


Joined: 19 Nov 2014
Posts: 4

PostPosted: Fri Sep 22, 2017 1:29 pm    Post subject: Try the service "samba" Reply with quote

From memory. You need the samba service in a runlevel, but not smbd, smbd or winbindd.
Back to top
View user's profile Send private message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1342
Location: Fayetteville, NC, USA

PostPosted: Fri Sep 22, 2017 2:51 pm    Post subject: Reply with quote

That's just it, there is only a Samba service. There is no service for nmbd/smb/winbindd. The service script force-calls those instead of the samba binary no matter what. That is the issue I am reporting here.
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum