Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ glsa 201709-11 ] gimps
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1976

PostPosted: Mon Sep 18, 2017 1:26 am    Post subject: [ glsa 201709-11 ] gimps Reply with quote

Gentoo Linux Security Advisory

Title: GIMPS: Root privilege escalation (GLSA 201709-11)
Severity: high
Exploitable: local
Date: 2017-09-17
Bug(s): #603408
ID: 201709-11

Synopsis

Gentoo's GIMPS ebuilds are vulnerable to privilege escalation due
to improper permissions. A local attacker could use it to gain root
privileges.


Background

GIMPS, the Great Internet Mersenne Prime Search, is a software capable
of find Mersenne Primes, which are used in cryptography. GIMPS is also
used for hardware testing.


Affected Packages

Package: sci-mathematics/gimps
Vulnerable: < 28.10-r1
Unaffected: >= 28.10-r1
Architectures: All supported architectures


Description

It was discovered that Gentoo’s default GIMPS installation suffered
from a privilege escalation vulnerability in the init script. This script
calls an unsafe “chown -R” command in checkconfig() function.


Impact

A local attacker who does not belong to the root group, but has the
ability to modify the /var/lib/gimps directory can escalate privileges to
the root group.


Workaround

There is no known workaround at this time.

Resolution

All GIMPS users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sci-mathematics/gimps-28.10-r1"
   


References

CVE-2017-14484
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum