Joined: 12 May 2004
|Posted: Sun Sep 17, 2017 11:26 pm Post subject: [ GLSA 201709-09 ] Subversion
|Gentoo Linux Security Advisory
Title: Subversion: Arbitrary code execution (GLSA 201709-09)
A command injection vulnerability in Subversion may allow remote
attackers to execute arbitrary code.
Subversion is a version control system intended to eventually replace
CVS. Like CVS, it has an optional client-server architecture (where the
server can be an Apache server running mod_svn, or an ssh program as in
CVS’s :ext: method). In addition to supporting the features found in
CVS, Subversion also provides support for moving and copying files and
Vulnerable: < 1.9.7
Unaffected: >= 1.9.7
Unaffected: > 1.8.18 < 1.8.19
Architectures: All supported architectures
Specially crafted ‘ssh://...’ URLs may allow the owner of the
repository to execute arbitrary commands on client’s machine if those
commands are already installed on the client’s system. This is
especially dangerous when the third-party repository has one or more
submodules with specially crafted ‘ssh://...’ URLs. Each time the
repository is recursively cloned or submodules are updated the payload
will be triggered.
A remote attacker, by enticing a user to clone a specially crafted
repository, could possibly execute arbitrary code with the privileges of
There are several alternative ways to fix this vulnerability. Please
refer to Subversion Team Announce for more details.
All Subversion 1.9.x users should upgrade to the latest version:
All Subversion 1.8.x users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-vcs/subversion-1.9.7"
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-vcs/subversion-1.8.18"
Subversion Team Announce