Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RESOLU] Clavier suisse, touches ö é ü è ä à
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Luh
n00b
n00b


Joined: 02 Sep 2017
Posts: 8
Location: Switzerland

PostPosted: Sun Sep 17, 2017 5:07 pm    Post subject: [RESOLU] Clavier suisse, touches ö é ü è ä à Reply with quote

Bonsoir,

J'ai un petit soucis, vraiment pas grand, mes touches éé, üè et äà sont configurées en tant que suisse-allemand et non suisse-français.
Une image pour mieux comprendre:
https://www.goodtyping.com/teclatSWIok.png

Du coup je dois faire shift + ö pour faire un é, alors que normalement c'est l'inverse.

10-keyboard.conf:
Code:
Section "InputClass"
    Identifier "keyboard"
    MatchIsKeyboard "yes"
    Option "XkbLayout" "ch"
    Option "XkbVariant" "fr"
    Option "XkbOptions" "grp:alt_shift_toggle"
EndSection


pour la configuration avec Xorg, j'ai essayé:
- Option "XkbLayout" "fr_CH"
- Option "XkbLayout" "ch(fr)"
Mais toujours le même résultat :(

/etc/conf.d/keymaps:
Code:
# Use keymap to specify the default console keymap.  There is a complete tree
# of keymaps in /usr/share/keymaps to choose from.
keymap="fr_CH"

# Should we first load the 'windowkeys' console keymap?  Most x86 users will
# say "yes" here.  Note that non-x86 users should leave it as "no".
# Loading this keymap will enable VT switching (like ALT+Left/Right)
# using the special windows keys on the linux console.
windowkeys="YES"

# The maps to load for extended keyboards.  Most users will leave this as is.
extended_keymaps=""
#extended_keymaps="backspace keypad euro2"

# Tell dumpkeys(1) to interpret character action codes to be
# from the specified character set.
# This only matters if you set unicode="yes" in /etc/rc.conf.
# For a list of valid sets, run `dumpkeys --help`
dumpkeys_charset=""

# Some fonts map AltGr-E to the currency symbol instead of the Euro.
# To fix this, set to "yes"
fix_euro="NO"


Je pense que le problème doit venir de KDE, mais je n'ai pas trouvé où configurer tout ça.

Une piste ?
_________________
- Luh

You're not bad at something, you're just better for doing other things.


Last edited by Luh on Sun Sep 17, 2017 6:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16226
Location: here

PostPosted: Sun Sep 17, 2017 6:20 pm    Post subject: Reply with quote

Si tu veux que plasma respecte la configuration du xorg, tu dois être sûr que l'option Configuration du système -> Périphérique d'entrée -> Clavier -> Dispositions -> Configurer des dispositions est désactivée, si no tu peux ajouter la disposition suisse-français (comme dans l'image)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Luh
n00b
n00b


Joined: 02 Sep 2017
Posts: 8
Location: Switzerland

PostPosted: Sun Sep 17, 2017 6:51 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Si tu veux que plasma respecte la configuration du xorg, tu dois être sûr que l'option Configuration du système -> Périphérique d'entrée -> Clavier -> Dispositions -> Configurer des dispositions est désactivée, si no tu peux ajouter la disposition suisse-français (comme dans l'image)


Super merci beaucoup !
Par contre c'est un peu tordu, il faut sélectionner "Allemand (Suisse)" comme disposition puis la variante "Français (Suisse)"
_________________
- Luh

You're not bad at something, you're just better for doing other things.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum