Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] efibootmgr -Could not delete variable: Read-only
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
tuggbuss
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2017
Posts: 116

PostPosted: Thu Sep 14, 2017 6:25 pm    Post subject: [SOLVED] efibootmgr -Could not delete variable: Read-only Reply with quote

It's been a while installing Gentoo, but tried yesterday, and restarted today.
Following the Handbook for a EFI/GPT system and everything works great until installing GRUB2

Code:
(chroot) sysresccd ~ # grub-install --target=x86_64-efi --efi-directory=/boot
Installing for x86_64-efi platform.
Could not delete variable: Read-only file system
efibootmgr: ** Warning ** : Boot0003 has same label gentoo
Could not prepare Boot variable: Read-only file system
Installation finished. No error reported.


Boot is mounted, my fstab

Code:
/dev/nvme0n1p1          /boot           vfat            rw,defaults,noatime     1 2
/dev/nvme0n1p2          none            swap            sw                      0 0
/dev/nvme0n1p3          /               ext4            rw,noatime              0 1
/dev/nvme0n1p4          /home           ext4            rw,defaults,noatime     0 2


and mount

Code:
(chroot) sysresccd /boot # mount
/dev/nvme0n1p3 on / type ext4 (rw,relatime,data=ordered)
/dev/nvme0n1p1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
/dev/nvme0n1p4 on /home type ext4 (rw,relatime,data=ordered)
/proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,nosuid,nodev,noexec,relatime)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
efivarfs on /sys/firmware/efi/efivars type efivarfs (ro,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=10240k,nr_inodes=8231582,mode=755)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
shm on /dev/shm type tmpfs (rw,nosuid,nodev,noexec,relatime)


I have disabled secure boot in UEFI on my Motherboard.
Have i missed something fundamental?

E:
As a sanity check i checked my /boot with tree

Code:
(chroot) sysresccd ~ # tree -L 2 /boot
/boot
├── EFI
│   └── gentoo
├── System.map-4.12.12-gentoo
├── config-4.12.12-gentoo
├── grub
│   ├── fonts
│   ├── grubenv
│   ├── locale
│   ├── themes
│   └── x86_64-efi
└── vmlinuz-4.12.12-gentoo


It seems pretty messy?


Well, sometimes the easiest solution is applicable. I remounted efivars with
Code:
mount -o remount,rw /sys/firmware/efi/efivars
and the same with /boot and tadaa.
Sorry for the buzz.

See you soon again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum