Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Changing font size
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
alphaomega325
n00b
n00b


Joined: 02 Jan 2017
Posts: 17

PostPosted: Thu Sep 14, 2017 10:14 am    Post subject: Changing font size Reply with quote

Currently whenever I use dmenu or use some of my applications my font size is extremely small. True I addressed that by changing my .Xresources settings to increase the font size in the terminal and most other applications, but the fact of the matter remains is that some of my applications have very small font size. How do I go about addressing that?
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1129
Location: Romania

PostPosted: Fri Sep 15, 2017 8:02 am    Post subject: Reply with quote

It depends on the toolkit they use, GTK, Qt etc. Which apps are you talking about?
Back to top
View user's profile Send private message
alphaomega325
n00b
n00b


Joined: 02 Jan 2017
Posts: 17

PostPosted: Fri Sep 15, 2017 3:16 pm    Post subject: Reply with quote

sebaro wrote:
It depends on the toolkit they use, GTK, Qt etc. Which apps are you talking about?


Dmenu, the tor-browser-bundle, and emacs whenever I create a new window within emacs.
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1129
Location: Romania

PostPosted: Fri Sep 15, 2017 7:02 pm    Post subject: Reply with quote

For X11 or ncurses add the font setting in .Xresources/.Xdefaults
Code:

Emacs.font: xft:...

For emacs you can change the font in the config file:
https://www.emacswiki.org/emacs/SetFonts

For GTK3 edit ~/.config/gtk-3.0/settings.ini
Code:

[Settings]
gtk-font-name=Noto Sans Regular 10
gtk-theme-name=Breeze
gtk-icon-theme-name=breeze
gtk-fallback-icon-theme=oxygen
gtk-cursor-theme-name=simpleandsoft
gtk-toolbar-style=GTK_TOOLBAR_ICONS
gtk-menu-images=1
gtk-button-images=1
gtk-primary-button-warps-slider=0
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Sat Sep 16, 2017 6:48 pm    Post subject: Reply with quote

Pass the font on the command line wherever you're running dmenu from, e.g. dmenu -fn 'monospace-20'
Back to top
View user's profile Send private message
alphaomega325
n00b
n00b


Joined: 02 Jan 2017
Posts: 17

PostPosted: Sat Sep 16, 2017 11:19 pm    Post subject: Reply with quote

Ant P. wrote:
Pass the font on the command line wherever you're running dmenu from, e.g. dmenu -fn 'monospace-20'


Thank you for helping me fix the dmenu problem, now I need to fix the torbrowser-bundle and I am golden.


edit: I added this to both my .Xresources file to fix my emacs fonts

Code:
Emacs.FontBackend: xft
Emacs.Font: Hack-20


And for the init.el file I added in

Code:

(set-default-font "Hack-20") ;; Make sure to change the .Xresources file and use xrdb .Xresources command whenever you want to change the fonts.


Like the comment said, I need to change both files whenever I want to change the font.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum