Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wine 64 + 32
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 854

PostPosted: Wed Sep 13, 2017 1:09 am    Post subject: Wine 64 + 32 Reply with quote

Hi All:

Does anyone know how to build wine for 64 bit and 32 bit emulation?
My current WINE install is 32 bits and works great, however, I tried to install sketchup and its a 64 bit app that aborts the install as it says my windows, WINE, is only 32 bit. Ok, I enabled these in my package.use file:
abi_x86_64 abi_x86_32

Portage doesn't complain, ok. Tried it
Code:
jserinki7 jserink # emerge -uDp world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    #] app-emulation/wine-gecko-2.47  ABI_X86="32 (64)"
[ebuild  N    #] app-emulation/wine-mono-4.7.0
[ebuild  N    #] app-emulation/wine-desktop-common-20170822
[ebuild     U  ] www-plugins/adobe-flash-27.0.0.130 [26.0.0.151]
[ebuild     U  ] gnome-base/gnome-keyring-3.20.1 [3.20.0]
[ebuild     U  ] virtual/jdk-1.8.0-r4 [1.8.0-r3]
[ebuild     U ~] app-emulation/wine-2.5-r3 [2.3] USE="-cuda% -vulkan%"


It bails at the beginning with this:
>>> Installing (1 of 1) app-emulation/wine-gecko-2.47::bobwya
 * This package will overwrite one or more files that may belong to other
 * packages (see list below). You can use a command such as `portageq
 * owners / <filename>` to identify the installed package that owns a
 * file. If portageq reports that only one package owns a file then do
 * NOT file a bug report. A bug report is only useful if it identifies at
 * least two or more packages that are known to install the same file(s).
 * If a collision occurs and you can not explain where the file came from
 * then you should simply ignore the collision since there is not enough
 * information to determine if a real problem exists. Please do NOT file
 * a bug report at https://bugs.gentoo.org/ unless you report exactly
 * which two packages install the same file(s). See
 * https://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how
 * to solve the problem. And once again, please do NOT file a bug report
 * unless you have completely understood the above message.
 *
 * Detected file collision(s):
 *
 *    /usr/share/wine/gecko/wine_gecko-2.47-x86_64.msi
 *    /usr/share/wine/gecko/wine_gecko-2.47-x86.msi


So I'm stumped. I guess when I enable for 64 and 32 WINE tried to install both of those msi packages and they want to write over each other.

Does anyone have a work around?

Cheers,
john

[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16861
Location: here

PostPosted: Wed Sep 13, 2017 5:52 am    Post subject: Reply with quote

wine 2.5 is a package of an external overlay, probably you have more chances in a solution by opening an issue in overlay site
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
jburns
l33t
l33t


Joined: 18 Jan 2007
Posts: 994
Location: Massachusetts USA

PostPosted: Wed Sep 13, 2017 6:42 am    Post subject: Reply with quote

Instead of app-emulation/wine emerge virtual/wine.

app-emulation/wine installs the same files as app-emulation/wine-gecko, app-emulation/wine-mono, and app-emulation/wine-desktop-common which results in file collisions.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16750

PostPosted: Wed Sep 13, 2017 3:52 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.

As fedeliallalinea pointed out, wine 2.5 is not currently in portage.
_________________
Ladies and gentlemen, allow me to present, Man Not Caring. -- Perry Cox
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2034
Location: Illinois, USA

PostPosted: Wed Sep 13, 2017 7:10 pm    Post subject: Reply with quote

Code:
X3 ~ # equery b /usr/share/wine/gecko/wine_gecko-2.47-x86_64.msi
 * Searching for /usr/share/wine/gecko/wine_gecko-2.47-x86_64.msi ...
app-emulation/wine-gecko-2.47 (/usr/share/wine/gecko/wine_gecko-2.47-x86_64.msi)
X3 ~ # equery b /usr/share/wine/gecko/wine_gecko-2.47-x86.msi
 * Searching for /usr/share/wine/gecko/wine_gecko-2.47-x86.msi ...
app-emulation/wine-gecko-2.47 (/usr/share/wine/gecko/wine_gecko-2.47-x86.msi)
X3 ~ # equery d app-emulation/wine-gecko
 * These packages depend on app-emulation/wine-gecko:
app-emulation/wine-staging-2.16-r1 (gecko ? app-emulation/wine-gecko:2.47[abi_x86_32?,abi_x86_64?])
app-emulation/wine-vanilla-2.0-r6 (gecko ? app-emulation/wine-gecko:2.47[abi_x86_32?,abi_x86_64?])


Have you read the news item " 2017-04-10 app-emulation/wine split and slotting" ?

Also this forum thread: https://forums.gentoo.org/viewtopic-t-1062056-postdays-0-postorder-asc-start-0.html

I believe all your problems are due to the slotting changes and deprecation of app-emulation:wine

For reference my settings (supports 64 and 32 bit)
Code:

/etc/portage/package.accept_keywords
         app-emulation/wine-gecko ~amd64
         app-emulation/wine-mono ~amd64
         <=app-emulation/wine-vanilla-2.0.1 ~amd64
          app-emulation/wine-any ~amd64
          app-emulation/wine-staging ~amd64
          app-eselect/eselect-wine ~amd64
          virtual/wine ~amd64
/etc/portage/package.mask
           app-eselect/eselect-wine::gentoo  # using bobwya overlay only
/etc/portage/package.unmask
           app-emulation/wine-desktop-common::bobwya
           app-emulation/wine-gecko::bobwya
           app-emulation/wine-mono::bobwya
           app-emulation/wine-vanilla::bobwya
           app-eselect/eselect-wine::bobwya
           virtual/wine::bobwya
           app-emulation/wine-any
/etc/portage/package.use
            app-emulation/wine gstreamer -d3d9 -realtime s3tc -samba udev vaapi
            app-emulation/wine-vanilla  gstreamer gecko mono netapi -realtime run-exes -samba udev v4l
            app-emulation/wine-staging  gstreamer -realtime s3tc staging -samba udev vaapi
Back to top
View user's profile Send private message
jburns
l33t
l33t


Joined: 18 Jan 2007
Posts: 994
Location: Massachusetts USA

PostPosted: Wed Sep 13, 2017 10:34 pm    Post subject: Reply with quote

For app-emulation/wine see https://wiki.gentoo.org/wiki/Wine and for virtual/wine see https://wiki.gentoo.org/wiki/Wine:_New_Packaging. The WINEARCH section shows how to set up for 32 bits.
Back to top
View user's profile Send private message
BobWya
Apprentice
Apprentice


Joined: 12 Aug 2012
Posts: 220
Location: Cambridge,UK

PostPosted: Sun Oct 22, 2017 11:05 pm    Post subject: Reply with quote

Sorry missed this post - when it was first posted... Still OP has been noticeably silent...

I've got a fairly detailed Wiki write-up of my Wine Overlay packages ...
Generally the gist is don't mix and match packages from the main Gentoo tree and your installed Overlays! :wink:
Mask off all the packages in your installed Overlay(s) and whitelist the specific applications you actually want to install.

The original error is because my Overlay Wine packages all use separate multislot wine-gecko and wine-mono packages - like the new multi-slot packages (both in the main Gentoo Repository and my Overlay).
The older/depreciated Gentoo tree version of app-emulation/wine:0 references direct distfiles copies of the wine-gecko and wine-mono installers.

Bob
_________________
system: G751JT (ASUS-NotebookSKU); processor: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz; memory: 32GiB System Memory; display: GM204M [GeForce GTX 970M]; disk: 2048GB Samsung SSD 850;BD-CMB UJ172 S;1024GB Samsung SSD 850
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum