Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]there are no ebuilds to satisfy <dev-python/idna-2.6
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
crocket
n00b
n00b


Joined: 29 Apr 2017
Posts: 13

PostPosted: Mon Sep 11, 2017 7:57 am    Post subject: [SOLVED]there are no ebuilds to satisfy <dev-python/idna- Reply with quote

I tried to install media-gfx/blender-2.78a-r1, but emerge says there are no ebuilds to satisfy <dev-python/idna-2.6.

How can I remove this error?

Code:
$ emerge -p =media-gfx/blender-2.78a-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by media-gfx/blender-2.78a-r1::gentoo[openexr]
# required by =media-gfx/blender-2.78a-r1 (argument)
=media-libs/openexr-2.2.0-r2 ~amd64
# required by media-gfx/blender-2.78a-r1::gentoo
# required by =media-gfx/blender-2.78a-r1 (argument)
=dev-python/numpy-1.13.1 ~amd64
# required by dev-python/setuptools-36.0.1::gentoo[python_targets_python3_5]
# required by dev-python/certifi-2017.7.27.1::gentoo
=dev-lang/python-3.5.3 ~amd64
# required by media-gfx/blender-2.78a-r1::gentoo
# required by =media-gfx/blender-2.78a-r1 (argument)
=dev-python/requests-2.18.2-r1 ~amd64
# required by =media-gfx/blender-2.78a-r1 (argument)
=media-gfx/blender-2.78a-r1 ~amd64
# required by media-gfx/blender-2.78a-r1::gentoo[openexr]
# required by =media-gfx/blender-2.78a-r1 (argument)
=media-libs/ilmbase-2.2.0 ~amd64
# required by dev-python/setuptools-36.0.1::gentoo
# required by dev-python/numpy-1.13.1::gentoo
# required by media-gfx/blender-2.78a-r1::gentoo
# required by =media-gfx/blender-2.78a-r1 (argument)
=dev-python/certifi-2017.7.27.1 ~amd64

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-gfx/blender-2.78a-r1::gentoo
# required by =media-gfx/blender-2.78a-r1 (argument)
>=dev-python/requests-2.18.2-r1 python_targets_python3_5
# required by media-gfx/blender-2.78a-r1::gentoo
# required by =media-gfx/blender-2.78a-r1 (argument)
>=dev-python/numpy-1.13.1 python_targets_python3_5
# required by dev-python/numpy-1.13.1::gentoo
# required by media-gfx/blender-2.78a-r1::gentoo
# required by =media-gfx/blender-2.78a-r1 (argument)
>=dev-python/setuptools-36.0.1 python_targets_python3_5
# required by dev-python/setuptools-36.0.1::gentoo
# required by dev-python/numpy-1.13.1::gentoo
# required by media-gfx/blender-2.78a-r1::gentoo
# required by =media-gfx/blender-2.78a-r1 (argument)
>=dev-python/certifi-2017.7.27.1 python_targets_python3_5

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

emerge: there are no ebuilds to satisfy "<dev-python/idna-2.6[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]".
(dependency required by "dev-python/requests-2.18.2-r1::gentoo" [ebuild])
(dependency required by "media-gfx/blender-2.78a-r1::gentoo" [ebuild])
(dependency required by "=media-gfx/blender-2.78a-r1" [argument])


Last edited by crocket on Tue Sep 12, 2017 7:15 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16272
Location: here

PostPosted: Mon Sep 11, 2017 8:07 am    Post subject: Reply with quote

You should unmask =dev-python/idna-2.6 package, version 2.5 has python_targets_python3_5 use flag masked
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
crocket
n00b
n00b


Joined: 29 Apr 2017
Posts: 13

PostPosted: Mon Sep 11, 2017 8:11 am    Post subject: Reply with quote

fedeliallalinea wrote:
You should unmask =dev-python/idna-2.6 package, version 2.5 has python_targets_python3_5 use flag masked


But, requests-2.18.2-r1 requires `<dev-python/idna-2.6`

Also, I didn't know version 2.5 has python_targets_python3_5 use flag masked because emerge didn't say so.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16272
Location: here

PostPosted: Mon Sep 11, 2017 8:37 am    Post subject: Reply with quote

crocket wrote:
But, requests-2.18.2-r1 requires `<dev-python/idna-2.6`

Correct only version 2.18.4 work with idna-2.6 (but not in portage)

crocket wrote:
Also, I didn't know version 2.5 has python_targets_python3_5 use flag masked because emerge didn't say so.

python3_5 is present but masked
Code:
$ emerge -pvq dev-python/idna --nodeps
[ebuild   R   ] dev-python/idna-2.5  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)"

try umask
Code:
# echo "dev-python/idna -python_targets_python3_5" >> /etc/portage/profile/package.use.mask

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3220
Location: Germany

PostPosted: Mon Sep 11, 2017 10:25 am    Post subject: Reply with quote

Yes, for the =media-gfx/blender-2.78a-r1 version is python:3.5 required
but on stable systems all python_targets_python3_5
and python_single_target_python3_5
useflags is masked.

For unmasking Python-3.5 on stable systems see please in https://wiki.gentoo.org/wiki/Project:Python/PYTHON_TARGETS
--> Section: Unmasking non-stable implementation on a stable system
Back to top
View user's profile Send private message
crocket
n00b
n00b


Joined: 29 Apr 2017
Posts: 13

PostPosted: Tue Sep 12, 2017 6:03 am    Post subject: Reply with quote

Josef.95 wrote:
For unmasking Python-3.5 on stable systems see please in https://wiki.gentoo.org/wiki/Project:Python/PYTHON_TARGETS
--> Section: Unmasking non-stable implementation on a stable system


I followed the instruction on the page, and I could install blender-2.78a-r1. Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum