Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sonata
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
FrankRizz0
Guru
Guru


Joined: 29 Nov 2006
Posts: 584

PostPosted: Fri Sep 08, 2017 11:16 pm    Post subject: Sonata Reply with quote

Good evening all!

I seem to be having difficulty with Sonata. It was running just fine and for some reason she decided to die. Here is the output when I type sonata in user terminal:

Code:
$ sonata
/usr/lib64/python2.7/site-packages/sonata/dbus_plugin.py:26: DeprecationWarning: Importing dbus.glib to use the GLib main loop with dbus-python is deprecated.
Instead, use this sequence:

    from dbus.mainloop.glib import DBusGMainLoop

    DBusGMainLoop(set_as_default=True)

  import dbus.glib
Error grabbing key 174, 0x24f8120
Traceback (most recent call last):
  File "/usr/bin/sonata", line 167, in <module>
    app = main.Base(args)
  File "/usr/lib64/python2.7/site-packages/sonata/main.py", line 759, in __init__
    self.iterate_now()
  File "/usr/lib64/python2.7/site-packages/sonata/main.py", line 1065, in iterate_now
    self.iterate()
  File "/usr/lib64/python2.7/site-packages/sonata/main.py", line 1019, in iterate
    self.handle_change_status()
  File "/usr/lib64/python2.7/site-packages/sonata/main.py", line 1628, in handle_change_status
    self.mpd_updated_db()
  File "/usr/lib64/python2.7/site-packages/sonata/main.py", line 1657, in mpd_updated_db
    self.library.library_browse(root=self.config.wd)
  File "/usr/lib64/python2.7/site-packages/sonata/library.py", line 321, in library_browse
    bd = self.library_populate_filesystem_data(self.library_get_data(self.config.wd, 'path'))
  File "/usr/lib64/python2.7/site-packages/sonata/library.py", line 487, in library_populate_filesystem_data
    bd += [('f' + unicode(mpdh.get(item, 'file')).lower(), [self.sonatapb, data, self.parse_formatting(self.config.libraryformat, item, True)])]
UnicodeDecodeError: 'utf8' codec can't decode byte 0xe9 in position 6: invalid continuation byte


Not exactly sure what this is trying to tell me :-(

Thanks in advance for any assistance!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum