Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pulseaudio only headphones or only speakers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Mapt
n00b
n00b


Joined: 04 Sep 2017
Posts: 4

PostPosted: Mon Sep 04, 2017 7:36 pm    Post subject: pulseaudio only headphones or only speakers Reply with quote

Hello all.

I have
media-sound/pulseaudio-10.0[X alsa alsa-plugin caps dbus gdbm glib orc ssl tcpd udev]

When i use
Code:

pactl set-sink-port alsa_output.pci-0000_00_1b.0.analog-stereo analog-output-lineout


all ok: speakers play, headphones no.

But when i use
Code:

pactl set-sink-port alsa_output.pci-0000_00_1b.0.analog-stereo analog-output-headphones


headphones play, but speakers play too.

What i need to fix to
Code:

pactl set-sink-port alsa_output.pci-0000_00_1b.0.analog-stereo analog-output-headphones


play only headphones, and disable speakers?

P.S. in alsamixer i can manage this with use "headphone" and "front" channels
Back to top
View user's profile Send private message
Mapt
n00b
n00b


Joined: 04 Sep 2017
Posts: 4

PostPosted: Fri Sep 08, 2017 8:50 pm    Post subject: Reply with quote

Nobody know?
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1288
Location: United Kingdom

PostPosted: Sat Sep 09, 2017 10:33 am    Post subject: Reply with quote

I don't know, but have you tried doing it the following way instead?:

https://wiki.archlinux.org/index.php/PulseAudio/Examples#Having_both_speakers_and_headphones_plugged_in_and_switching_in_software_on-the-fly
_________________
Clevo W230SS: amd64, OpenRC, nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64, OpenRC, xf86-video-ati, dual booting with Win 7 Pro 64-bit.
KDE on both laptops.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3792
Location: Austro Bavaria

PostPosted: Sun Sep 10, 2017 8:49 am    Post subject: Reply with quote

Start in a terminal alsa-mixer

switch to your hardware sound card from pulseaudio (e.g. Card: HDA Intel PCH )

Set Auto-Mute to disabled
Active Master, Headphones, Speaker, Bass Speaker
Set the volume levels to something reasonable

Works on an ASUS g75VW wiht pulseaudio, hda intel and openrc + eudev

--

Pulseaudio is just an onion layer in between. When something is the issue, you should always check the hardware sound card, the hardware itself, and the software components (media player, and such ...), and the "software mixer" pulseaudio / alsa. (for more details please check the documentation or the wikis)
Back to top
View user's profile Send private message
Mapt
n00b
n00b


Joined: 04 Sep 2017
Posts: 4

PostPosted: Tue Oct 17, 2017 10:16 am    Post subject: Reply with quote

I change settings manual with alsamixer, and save 2 varians by alsactl store.
After that i add 2 scripts in my panel (use alsactl restore) to change speckers-headphones. Its solve my problem
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum