Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]E17 without media-libs/elementary ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
2B2doG
n00b
n00b


Joined: 20 Jan 2012
Posts: 13

PostPosted: Sat Sep 02, 2017 6:30 am    Post subject: [SOLVED]E17 without media-libs/elementary ? Reply with quote

Hi all.
I have a problem that when install E17.when I emerge enlightenment:0.17 show me the BLOCK, Why is media-libs/elementary block dev-libs/EFL ?
May I have some help with this?

Code:

These are the packages that would be merged, in order:

Calculating dependencies  .... .. ... done!
[ebuild  N     ] dev-lang/luajit-2.0.4:2::gentoo  USE="-lua52compat" 0 KiB
[ebuild  N     ] media-libs/faad2-2.7-r3::gentoo  USE="-digitalradio -static-libs" 0 KiB
[ebuild  NS    ] media-libs/gstreamer-1.10.3:1.0::gentoo [0.10.36-r2:0.10::gentoo] USE="caps introspection nls orc {-test} (-unwind)" 3,709 KiB
[ebuild  N     ] dev-libs/libinput-1.7.2:0/10::gentoo  USE="{-test}" INPUT_DEVICES="-wacom" 903 KiB
[ebuild  N     ] dev-libs/fribidi-0.19.6::gentoo  USE="-static-libs" 0 KiB
[ebuild  N     ] media-libs/freeglut-3.0.0::gentoo  USE="-debug -static-libs" 0 KiB
[ebuild  NS    ] media-libs/openjpeg-1.5.2:0/5::gentoo [2.1.1_p20160922:2/7::gentoo] USE="-doc -static-libs {-test}" 0 KiB
[ebuild  N     ] sci-physics/bullet-2.83.4:0/2.83.4::gentoo  USE="bullet3 -doc -double-precision -examples -extras" 0 KiB
[ebuild  N     ] media-libs/libwebp-0.5.2:0/6::gentoo  USE="gif jpeg opengl png tiff -experimental (-neon) -static-libs -swap-16bit-csp" CPU_FLAGS_X86="sse2 sse4_1 -avx2" 0 KiB
[ebuild  NS    ] media-libs/gst-plugins-base-1.10.3:1.0::gentoo [0.10.36-r2:0.10::gentoo] USE="X alsa introspection nls ogg orc pango vorbis -ivorbis -theora" 2,989 KiB
[ebuild  N     ] media-libs/xine-lib-1.2.6-r2:1::gentoo  USE="X a52 aac alsa css dts flac gtk jpeg mad mmap mng nls opengl pulseaudio sdl truetype vorbis xcb xv -aalib (-altivec) -bluray -directfb -dvb -dxr3 -fbcon -fusionsound -imagemagick -ipv6 -jack -libav -libcaca -modplug -musepack -oss -samba -speex -theora -v4l -vaapi -vcd -vdpau -vdr -vidix (-vis) -vpx -wavpack -xinerama -xvmc" 0 KiB
[ebuild  N    *] dev-libs/efl-9999::gentoo  USE="X bmp drm eet fbcon fontconfig fribidi gif glib gstreamer ico jpeg2k nls opengl physics png ppm psd pulseaudio sdl sound ssl tga tiff webp xim xine xpm -debug -doc -egl -gles -gnutls -harfbuzz -ibus -libressl (-neon) -oldlua (-pixman) -postscript -raw -scim -systemd -tslib -unwind -v4l -valgrind -wayland" 0 KiB
[ebuild  N    *] media-libs/elementary-9999::gentoo  USE="X nls sdl -debug -doc -examples -fbcon -javascript -quicklaunch -static-libs -wayland" 0 KiB
[ebuild  N     ] x11-wm/enlightenment-0.20.5:0.17/0.20.5::gentoo  USE="nls pam spell -doc -static-libs -systemd -ukit -wayland" ENLIGHTENMENT_MODULES="appmenu backlight battery bluez4 clock conf conf-applications conf-bindings conf-dialogs conf-display conf-interaction conf-intl conf-menus conf-paths conf-performance conf-randr conf-shelves conf-theme conf-window-manipulation conf-window-remembers connman cpufreq everything fileman fileman-opinfo gadman geolocation ibar ibox lokker mixer msgbus music-control notification packagekit pager pager-plain policy-mobile quickaccess shot start syscon systray tasks teamwork temperature tiling winlist wizard wl-desktop-shell wl-drm wl-text-input wl-weekeyboard wl-wl wl-x11 xkbswitch xwayland" 0 KiB
[blocks B      ] media-libs/elementary ("media-libs/elementary" is blocking dev-libs/efl-9999)

Total: 14 packages (11 new, 3 in new slots), Size of downloads: 7,599 KiB
Conflict: 1 block (1 unsatisfied)


Last edited by 2B2doG on Fri Sep 15, 2017 8:15 am; edited 2 times in total
Back to top
View user's profile Send private message
LIsLinuxIsSogood
l33t
l33t


Joined: 13 Feb 2016
Posts: 968

PostPosted: Sun Sep 03, 2017 8:13 pm    Post subject: Reply with quote

Quote:
Total: 14 packages (11 new, 3 in new slots), Size of downloads: 7,599 KiB


Do you already have package dev-libs/efl installed on your system?

Is this a clean install or an upgrade...I've had some moderate issues with ebuilds for enlightenment based on the gentoo repositories, but this seems like something that should and could easily be handled either with some cleanup of these other installs or else by upgrading them ffirst.

I hope this help. :P
Back to top
View user's profile Send private message
2B2doG
n00b
n00b


Joined: 20 Jan 2012
Posts: 13

PostPosted: Fri Sep 15, 2017 8:27 am    Post subject: Reply with quote

Quote:


Is this a clean install or an upgrade...I've had some moderate issues with ebuilds for enlightenment based on the gentoo repositories, but this seems like something that should and could easily be handled either with some cleanup of these other installs or else by upgrading them ffirst.

I hope this help. :P



Thanks for your reply
According to this, I just delete /etc/portage/package.accept_keywords now it works. and efl-1.17.0 Looks no support latest version throught check the build.log.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum