Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Strange problem with mouse cursor for dragging
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
genterminl
Guru
Guru


Joined: 12 Feb 2005
Posts: 482
Location: Connecticut, USA

PostPosted: Thu Aug 31, 2017 10:27 pm    Post subject: Strange problem with mouse cursor for dragging Reply with quote

(I'd be very happy if someone could suggest a better Subject wording.)

For quite a while now, I have a problem that when use the mouse to drag a divider (such as between two panes) the vertical and horizontal icons seem to be switched. When I'm dragging a vertical divider right/left, the icon is two horizontal lines with up and down arrows, but when I drag a horizontal divider up/down, the icon is two vertical lines with the arrows pointing right/left.

Right now, I can't even find the actual files that contain the pointers, so I don't even know the appropriate terminology to use to describe it. Since I can't attach images, I'll attempt some ascii art
Code:
  ^      ||
  |      ||
-----  <-||->
-----    ||
  |      ||
  v   
The left one shows up when dragging right/left, and the right one shows up dragging up/down. That seems backwards to me. I'm guessing it is a switched naming on the icon/cursor files, but I can't find them.

I'm running mostly KDE, but this primarily happens in Balsa (email client) which is a Gnome app - so I don't know which themes to concentrate my looking in.

Thanks for any suggestions.

(sorry for the immediate edit - I hit submit instead of preview)
Back to top
View user's profile Send private message
PeGa!
Tux's lil' helper
Tux's lil' helper


Joined: 13 May 2005
Posts: 96
Location: Capital Federal, Buenos Aires, Argentina

PostPosted: Fri Sep 01, 2017 5:34 am    Post subject: Reply with quote

If this doesn't happen system wide, my bet is that there is some theme misconfiguration at gtk level. Try to reproduce the issue with different gtk applications, and if it's a consistent behaviour, then look for the GTK theming on KDE, and try to change the cursor theming for GTK (install a new one first if necessary).
_________________
If it moves, it needs an ebuild.

Adopt an unanswered post.
Back to top
View user's profile Send private message
genterminl
Guru
Guru


Joined: 12 Feb 2005
Posts: 482
Location: Connecticut, USA

PostPosted: Fri Sep 01, 2017 3:51 pm    Post subject: Reply with quote

Thanks for the hints, but I managed to track it down yesterday. Under /usr/share/icons/ I have 16 folders/themes. For two of them breeze_cursors and Breeze_Snow, they have split_h and split_v as symlinks to col-resize and row-resize. Note that split_h pointing to col_resize make sense, resizing a column is adjusting a split horizontally. The theme which seems to have the actual cursors I'm using (at least for Balsa) is KDE_Classic, which along with Oxygen_Black, _Blue, _White, _Yellow, and _Zion have col-resize and row-resize as symlinks to split_v and split_h, which is the opposite match from the first two. All of those are part of kde-plasma/oxygen, so I plan to file a bug for those mis-set symlinks.

[edit: bug 629550 submitted]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum