Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
spamassassin issue since upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
snIP3r
l33t
l33t


Joined: 21 May 2004
Posts: 804
Location: germany

PostPosted: Tue Aug 22, 2017 5:17 am    Post subject: spamassassin issue since upgrade Reply with quote

hi all!

since latest update of spamassassin to spamassassin-3.4.1-r13 i have an issue with my user prefs. they worked without problems till update. no config files are changed. and now i get a message like this with every mail beeing scanned:

Code:

Aug 22 07:05:02 area52 spamd[10456]: spamd: connection from localhost [::1]:49184 to port 783, fd 5
Aug 22 07:05:02 area52 spamd[10456]: spamd: creating default_prefs: /home/sniper/.spamassassin/user_prefs
Aug 22 07:05:02 area52 spamd[10456]: config: cannot create user preferences file /home/sniper/.spamassassin/user_prefs: No such file or directory
Aug 22 07:05:02 area52 spamd[10456]: spamd: failed to create readable default_prefs: /home/sniper/.spamassassin/user_prefs
 spamd: processing message <46Yi28f_RAS6jz32kPiOIg@domain.net> for sniper:112


so i deleted the .spamassassin directory in my home directory but this has no effect :(
con someone perhaps help me with this issue?

thx in advance
snIP3r
_________________
Intel G3220 on ASUS P9D-X
Gentoo Base System 2.2
Kernel 4.12.12-gentoo SMP
-----------------------------------------------
if your problem is fixed please add something like [solved] to the topic!
Back to top
View user's profile Send private message
NTU
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2015
Posts: 126

PostPosted: Wed Aug 23, 2017 5:15 am    Post subject: Reply with quote

Try this:
Code:
mkdir -p /home/sniper/.spamassassin && touch /home/sniper/.spamassassin/user_prefs
Back to top
View user's profile Send private message
figueroa
Apprentice
Apprentice


Joined: 14 Aug 2005
Posts: 289
Location: GA-USA

PostPosted: Fri Sep 01, 2017 5:23 pm    Post subject: Reply with quote

I had been running spamassassin ~x86 like forever, but the recent upgrade from spamassassin-3.4.1-r12 to spamassassin-3.4.1-r13 caused BAYES to stop working. I removed the ~x86 setting in /etc/portage/package.keywords and after the downgrade to spamassassin-3.4.1-r8 BAYES works fine again.

That never happened before.

spamassassin-3.4.1-r13 is no longer available, replaced by version r16 (which also won't use BAYES), and version r8 is stable for x86.
_________________
Andy Figueroa
andy@andyfigueroa.net Working with Unix since 1983.
Back to top
View user's profile Send private message
Philippe23
Tux's lil' helper
Tux's lil' helper


Joined: 20 Dec 2006
Posts: 113
Location: Rome, NY

PostPosted: Sun Oct 29, 2017 1:37 pm    Post subject: Reply with quote

Submitted a bug: https://bugs.gentoo.org/635790
Back to top
View user's profile Send private message
Philippe23
Tux's lil' helper
Tux's lil' helper


Joined: 20 Dec 2006
Posts: 113
Location: Rome, NY

PostPosted: Sun Oct 29, 2017 1:42 pm    Post subject: Reply with quote

If you're having this problem with -r16, can you try changing /etc/init.d/spamd to remove the --username and --groupname args from command_args:

Code:
command_args="--username=spamd
              --groupname=spamd
              --pidfile=${pidfile}
              ${SPAMD_OPTS}"


to

Code:
command_args="--pidfile=${pidfile}
              ${SPAMD_OPTS}"


and let me know if that fixes the problem for you?
Back to top
View user's profile Send private message
Philippe23
Tux's lil' helper
Tux's lil' helper


Joined: 20 Dec 2006
Posts: 113
Location: Rome, NY

PostPosted: Sun Oct 29, 2017 1:50 pm    Post subject: Reply with quote

figueroa wrote:
(which also won't use BAYES)


The bayes flag was removed because you couldn't really not have bayes support. See https://bugs.gentoo.org/617950#c3 for details.
Back to top
View user's profile Send private message
figueroa
Apprentice
Apprentice


Joined: 14 Aug 2005
Posts: 289
Location: GA-USA

PostPosted: Sun Oct 29, 2017 6:01 pm    Post subject: Reply with quote

Quote:
If you're having this problem with -r16, can you try changing /etc/init.d/spamd to remove the --username and --groupname args from command_args:


I am using -r16 since yesterday and it won't use BAYES. I did as requested and will advise after some mail arrives.

Quote:
The bayes flag was removed because you couldn't really not have bayes support.


"bayes flag" is not relevant my finding that -r16 won't use BAYES. The last versions I used that would use BAYES were -r8 and -r12.
_________________
Andy Figueroa
andy@andyfigueroa.net Working with Unix since 1983.
Back to top
View user's profile Send private message
figueroa
Apprentice
Apprentice


Joined: 14 Aug 2005
Posts: 289
Location: GA-USA

PostPosted: Sun Oct 29, 2017 6:28 pm    Post subject: Reply with quote

YES, by removing the --username and --groupname arguments from /etc/init.d/spamd BAYES is again working.

What are the implications of this situation?

ADDED: Thank you!
_________________
Andy Figueroa
andy@andyfigueroa.net Working with Unix since 1983.
Back to top
View user's profile Send private message
Philippe23
Tux's lil' helper
Tux's lil' helper


Joined: 20 Dec 2006
Posts: 113
Location: Rome, NY

PostPosted: Sun Oct 29, 2017 8:17 pm    Post subject: Reply with quote

Pre-r16 didn't have the args, so it just puts you where you were.

There's an argument to be made that having spamd run as the spamd user would allow you to reduce access of the process, but you'd have to fixup the permissions of your $HOME/.spamassassin/ folders so the spamd user would be able to read/write to the folder for all your users (as well as modifying /etc/skel so it would have the permissions right for future users).

If you've got spamassassin setup to store user_prefs & bayes in a DB instead of the file-system, there's you're better off running as the spamd user. But if you're in this post, you probably aren't setup with a DB backend. :wink:
Back to top
View user's profile Send private message
Philippe23
Tux's lil' helper
Tux's lil' helper


Joined: 20 Dec 2006
Posts: 113
Location: Rome, NY

PostPosted: Sun Nov 05, 2017 8:49 pm    Post subject: Reply with quote

Update. 3.4.1-r19 fixes the above by adding a SPAMD_RUN_AS_ROOT flag to /etc/conf.d/spamd that you can enable if you need to continue running spamd as root so it can setuid to access the files in user's home folders.

As mentioned above, if your user config & bayes are in a database, you don't need to set the flag and should leave the default which will run the spamd process as a spamd user who has minimal permissions.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum