Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KMail stürzt nach Update ab
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
sdoubleyou
n00b
n00b


Joined: 27 May 2016
Posts: 40

PostPosted: Fri Aug 18, 2017 1:11 pm    Post subject: KMail stürzt nach Update ab Reply with quote

Hallo zusammen,

in den letzten Tagen habe ich mein Plasma auf den aktuellsten stable-Stand gebracht und die kde-apps sind auf dem Release 17.04.3
Update ist auch ohne Probleme druchgelaufen.

Seit dem Update stürzt KMail nur noch gnadenlos ohne erkennbare Fehlermeldung ab. Egal ob ich eine einzelne Mail öffnen möchte oder nur den Lesebereich vergrößern möchte.

Habe mein Plasma auf default-Werte gestellt, composer abgeschaltet und 3 Kernel (mit genkernel all - aktuell 4.12.5 - arbeite aber zur Zeit mit 4.9.34) getestet - selbe Ergebnis

Ich bekomme im Terminal folgende info

Code:

kmail
Icon theme "elementary" not found.
Icon theme "gnome" not found.
Pass a valid window to KWallet::Wallet::openWallet().
org.kde.pim.webengineviewer:  It's not necessary to check database now
this does not work on a KActionCollection containing actions!
org.kde.akonadi.ETM: GEN true false false
org.kde.akonadi.ETM: collection: QVector()
org.kde.akonadi.ETM:
org.kde.akonadi.ETM: Subtree:  15 QSet(28, 31, 30, 17, 16, 19, 18, 21, 49, 20, 48, 23, 51, 50, 15, 40, 43, 42, 45, 44, 47, 46, 33, 32, 35, 34, 37, 36, 39, 38, 25, 24, 27, 26, 29)
org.kde.akonadi.ETM: collection: "INBOX"
org.kde.akonadi.ETM: Subtree:  77 QSet(80, 83, 82, 85, 84, 87, 86, 89, 88, 91, 77, 90, 92, 79, 78, 81)
org.kde.akonadi.ETM: Subtree:  4 QSet(6, 11, 13, 12, 14, 5, 4)
org.kde.akonadi.ETM: Fetch job took  663 msec
org.kde.akonadi.ETM: was collection fetch job: collections: 58
org.kde.akonadi.ETM: first fetched collection: "Local Folders"
org.kde.akonadi.ETM: collection: QVector()
org.kde.akonadi.ETM: Fetch job took  797 msec
org.kde.akonadi.ETM: was collection fetch job: collections: 13
org.kde.akonadi.ETM: first fetched collection: "Search"
org.kde.akonadi.ETM: Fetch job took  525 msec
org.kde.akonadi.ETM: was item fetch job: items: 15
org.kde.akonadi.ETM: Fetch job took  376 msec
org.kde.akonadi.ETM: was collection fetch job: collections: 0
this does not work on a KActionCollection containing actions!
this does not work on a KActionCollection containing actions!
1 : "Uncaught ReferenceError: qt is not defined"
1 : "Uncaught ReferenceError: qt is not defined"
this does not work on a KActionCollection containing actions!
nouveau: kernel rejected pushbuf: Datei oder Verzeichnis nicht gefunden
nouveau: ch20: krec 0 pushes 0 bufs 1 relocs 0
nouveau: ch20: buf 00000000 00000003 00000004 00000004 00000000
nouveau: kernel rejected pushbuf: Datei oder Verzeichnis nicht gefunden
nouveau: ch20: krec 0 pushes 0 bufs 2 relocs 0
nouveau: ch20: buf 00000000 00000003 00000004 00000004 00000000
nouveau: ch20: buf 00000001 00000006 00000004 00000000 00000004
kmail: /var/tmp/portage/x11-libs/libdrm-2.4.80/work/libdrm-2.4.80/nouveau/pushbuf.c:727: nouveau_pushbuf_data: Zusicherung »kref« nicht erfüllt.
*** KMail got signal 6 (Exiting)
*** Dead letters dumped.
[0818/125837:ERROR:gles2_cmd_decoder.cc(2109)] [.CommandBufferContext.RenderWorker-0xf27870]GL ERROR :GL_OUT_OF_MEMORY : ScopedTextureBinder::dtor: <- error from previous GL command
[0818/125837:ERROR:gles2_cmd_decoder.cc(4471)] Error: 5 for Command kCopySubTextureCHROMIUM
[0818/125837:ERROR:gles2_cmd_decoder.cc(3579)]   GLES2DecoderImpl: Trying to make lost context current.
[0818/125837:ERROR:gles2_cmd_decoder.cc(3579)]   GLES2DecoderImpl: Trying to make lost context current.
KCrash: Application 'kmail' crashing...
KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit
sock_file=/var/run/user/1000/kdeinit5__0

[1]+  Angehalten              kmail
[warn] epoll_wait: Ungültiger Dateideskriptor
[1]+  Exit 253                kmail


Meine emerge --info http://dpaste.com/3DFDG5Q

Finde keinen Ansatz um diesen segfault abzustellen. Hat jemand da einen Ansatz?

Vielen Dank im Voraus
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2028
Location: Bardowick, Germany

PostPosted: Tue Aug 22, 2017 11:46 am    Post subject: Re: KMail stürzt nach Update ab Reply with quote

Also einige deiner Meldungen in der Konsole finde ich schon sehr bedenklich:
Code:
Pass a valid window to KWallet::Wallet::openWallet().
Sowas habe ich noch nie gesehen.
Code:
this does not work on a KActionCollection containing actions!
this does not work on a KActionCollection containing actions!
1 : "Uncaught ReferenceError: qt is not defined"
1 : "Uncaught ReferenceError: qt is not defined"
this does not work on a KActionCollection containing actions!
Welche Versionen von QT hast du installiert? Ich finde "qt is not defined" höchst interessant.
Code:
nouveau: kernel rejected pushbuf: Datei oder Verzeichnis nicht gefunden
(...)
kmail: /var/tmp/portage/x11-libs/libdrm-2.4.80/work/libdrm-2.4.80/nouveau/pushbuf.c:727: nouveau_pushbuf_data: Zusicherung »kref« nicht erfüllt.
(...)
[0818/125837:ERROR:gles2_cmd_decoder.cc(3579)]   GLES2DecoderImpl: Trying to make lost context current.
Oh? Moment! Wieso denn GLES2? Das ist in deiner emerge info nicht mit drin.

Also "OpenGL for Embedded Systems" (Aka OpenGL ES oder halt kurz "GLES") sollte wirklich nur genau dort verwendet werden: Embedded Systems. Also sowas wie Android.

Deaktiviere mal alle GLES Varianten in deiner make.conf und aktualisiere @world neu mit "--changed-use".

Ich habe in meiner make.conf sicherheitshalber USE="-gles -gles1 -gles2 -gles3" drin.
_________________
elogind
(elogind) - [TRACKER] sys-auth/elogind - Integration into Gentoo
"A conservative is a man who is too cowardly to fight and too fat to run."
-- Elbert Hubbard
Back to top
View user's profile Send private message
sdoubleyou
n00b
n00b


Joined: 27 May 2016
Posts: 40

PostPosted: Tue Aug 22, 2017 4:41 pm    Post subject: Re: KMail stürzt nach Update ab Reply with quote

Hallo Yamakuzure,

vielen Dank für deine Unterstützung
Yamakuzure wrote:
Also einige deiner Meldungen in der Konsole finde ich schon sehr bedenklich:
Code:
Pass a valid window to KWallet::Wallet::openWallet().
Sowas habe ich noch nie gesehen.


Je länger ich mich mit diesem Thema beschäftige, desto mehr muss ich leider zu dieser Meldung lesen
z.B.
https://bbs.archlinux.org/viewtopic.php?id=218386
https://www.kde-neon.de/topic/kontact-bzw-kmail-laesst-sich-nicht-mehr-starten/
Naja bei google gibt es noch genug :wink:

Code:
this does not work on a KActionCollection containing actions!

auch gibt es einiges zu lesen
https://forum.chakralinux.org/viewtopic.php?id=15086
https://forum.kde.org/viewtopic.php?f=215&t=135957
https://forum.siduction.org/index.php?topic=6301.0
Quote:
Welche Versionen von QT hast du installiert? Ich finde "qt is not defined" höchst interessant.

Bei mir ist 5.7.1 sauber drin
Code:
dev-qt/qtcore-5.7.1-r3:5/5.7::gentoo  USE="icu -debug -systemd {-test}

Hierzu habe ich auch noch einen Bug-Report gefunden
https://bugs.kde.org/show_bug.cgi?id=358948
Ist zwar älter, aber spiegelt das Problem wieder

Quote:
Oh? Moment! Wieso denn GLES2? Das ist in deiner emerge info nicht mit drin.
Also "OpenGL for Embedded Systems" (Aka OpenGL ES oder halt kurz "GLES") sollte wirklich nur genau dort verwendet werden: Embedded Systems. Also sowas wie Android.
Deaktiviere mal alle GLES Varianten in deiner make.conf und aktualisiere @world neu mit "--changed-use".
Ich habe in meiner make.conf sicherheitshalber USE="-gles -gles1 -gles2 -gles3" drin.

Hierzu habe ich mal meine make.conf entsprechend abgeändert und das Ergebnis ist
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!

Nothing to merge; quitting.


Eigentlich hatte ich immer mehr den nouveau-Treiber im Verdacht, aber es scheint ja, dass bei anderen Distris ähnliche Probleme mit einigen der o.a. Fehlermeldungen auftreten :(
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2028
Location: Bardowick, Germany

PostPosted: Wed Aug 23, 2017 10:26 am    Post subject: Re: KMail stürzt nach Update ab Reply with quote

Ah! Stop! Moment!

Der Fehler ist in gles2_cmd_decoder.cc, und das gehört zu Chromium. Sagt zumindest Google. Das hat also sicher nichts mit kmail zu tun.

Oh mann, da war ich wohl auf dem Holzweg... :-(

Das ist tatsächlich ein nouveau bug, und der Buck Tracker ist hier: https://bugs.freedesktop.org/show_bug.cgi?id=98039

Spannend finde ich diesen Kommentar:
Tomasz Paweł Gajc wrote:
BTW i've applied your patches
https://github.com/OpenMandrivaAssociation/mesa/commit/5657638feb4d45e0c6be04a3326ea3a93e403bc7

Currently i'm testing this mesa build, and i must admit that qupzilla, kmail and other applications that use Qt5WebEngine or ny multi-threading OpenGL has stop crashing.
Das ist ja immerhin etwas.
_________________
elogind
(elogind) - [TRACKER] sys-auth/elogind - Integration into Gentoo
"A conservative is a man who is too cowardly to fight and too fat to run."
-- Elbert Hubbard
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum