Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
TigerVNC, cursor problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Cyker
Veteran
Veteran


Joined: 15 Jun 2006
Posts: 1746

PostPosted: Thu Aug 17, 2017 4:51 pm    Post subject: TigerVNC, cursor problem Reply with quote

Hi all,

Does anyone here use newer versions of TigerVNC with rxvt or urxvt?

I'm having a weird problem where the cursor turns black-on-black when over these windows, rendering it pretty much invisible.

It also does this over some things, e.g. hotspots that would change the cursor to a pointing hand, instead give a black silhouette of a pointing hand.

I had newer versions masked and forgot why; Just tried removing the mask and now I remember why I masked the newer ones! (i.e. because of this cursor problem)

The problem seems to occur with every tigervnc after 1.3.1 including 1.8.0.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13498

PostPosted: Fri Aug 18, 2017 1:10 am    Post subject: Reply with quote

What is the output of emerge --pretend --verbose net-misc/tigervnc? When this fails, are you using tigervnc as a client, as a headless X server, as a forward of a regular X server, or some combination? If you are using tigervnc as a client, does the failure apply to all VNC servers or only when using tigervnc also as the server?
Back to top
View user's profile Send private message
Cyker
Veteran
Veteran


Joined: 15 Jun 2006
Posts: 1746

PostPosted: Fri Aug 18, 2017 9:00 am    Post subject: Reply with quote

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] net-misc/tigervnc-1.3.1-r5::cyLocalOverlay  USE="nptl opengl pam server -gnutls -java -xorgmodule" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB



buuuut just to be clear, all versions of tigervnc from my overly'd one right up to 1.8.0 compile and emerge just fine - The problem is that once I fire it up a vncserver, I get that weird cursor silhouette glitch in newer versions over certain (But not all) windows for some reason.

Either not that many people use vnc these days or it is a very specific issue as I've not found a single post on it while googling! :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum