Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
php-fpm crashes on restart/stop
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
kutte128
Apprentice
Apprentice


Joined: 18 May 2004
Posts: 173

PostPosted: Thu Aug 10, 2017 6:44 am    Post subject: php-fpm crashes on restart/stop Reply with quote

Hi,

i noticed a strange behavior 2 weeks ago after running without a single problem for over two years:
My php-fpm crashes.

i can't manually reproduce this but every single night it crashes at the same time.
I don't even know which site is causing this, it seems to be totally random

This is from the php-fpm.log right before the crash:
Code:
[10-Aug-2017 03:10:08.535524] DEBUG: pid 24907, fpm_got_signal(), line 90: received SIGQUIT
[10-Aug-2017 03:10:08.535546] NOTICE: pid 24907, fpm_got_signal(), line 91: Finishing ...
[10-Aug-2017 03:10:08.535553] DEBUG: pid 24907, fpm_pctl(), line 231: switching to 'finishing' state
[10-Aug-2017 03:10:08.535563] DEBUG: pid 24907, fpm_pctl_kill_all(), line 159: [pool domain.one] sending signal 3 SIGQUIT to child 19645
[10-Aug-2017 03:10:08.535572] DEBUG: pid 24907, fpm_pctl_kill_all(), line 159: [pool domain.two] sending signal 3 SIGQUIT to child 19646
[10-Aug-2017 03:10:08.535579] DEBUG: pid 24907, fpm_pctl_kill_all(), line 159: [pool domain.three] sending signal 3 SIGQUIT to child 19897
[10-Aug-2017 03:10:08.535586] DEBUG: pid 24907, fpm_pctl_kill_all(), line 159: [pool domain.four] sending signal 3 SIGQUIT to child 15110
[10-Aug-2017 03:10:08.535602] DEBUG: pid 24907, fpm_pctl_kill_all(), line 159: [pool domain.four] sending signal 3 SIGQUIT to child 10212
[10-Aug-2017 03:10:08.535610] DEBUG: pid 24907, fpm_pctl_kill_all(), line 159: [pool domain.four] sending signal 3 SIGQUIT to child 8254
[10-Aug-2017 03:10:08.535615] DEBUG: pid 24907, fpm_pctl_kill_all(), line 168: 6 child(ren) still alive
[10-Aug-2017 03:10:08.535621] DEBUG: pid 24907, fpm_event_loop(), line 419: event module triggered 1 events
[10-Aug-2017 03:10:08.538820] DEBUG: pid 24907, fpm_event_loop(), line 419: event module triggered 2 events
[10-Aug-2017 03:10:08.538852] DEBUG: pid 24907, fpm_got_signal(), line 76: received SIGCHLD
[10-Aug-2017 03:10:08.538875] DEBUG: pid 24907, fpm_children_bury(), line 252: [pool domain.two] child 19646 exited with code 0 after 7.319124 seconds from start
[10-Aug-2017 03:10:08.538883] DEBUG: pid 24907, fpm_children_bury(), line 252: [pool domain.three] child 19897 exited with code 0 after 0.255650 seconds from start
[10-Aug-2017 03:10:08.538888] DEBUG: pid 24907, fpm_got_signal(), line 76: received SIGCHLD
[10-Aug-2017 03:10:08.538891] DEBUG: pid 24907, fpm_event_loop(), line 419: event module triggered 1 events
[10-Aug-2017 03:10:08.539405] DEBUG: pid 24907, fpm_event_loop(), line 419: event module triggered 2 events
[10-Aug-2017 03:10:08.539419] DEBUG: pid 24907, fpm_got_signal(), line 76: received SIGCHLD
[10-Aug-2017 03:10:08.539432] DEBUG: pid 24907, fpm_children_bury(), line 252: [pool domain.one] child 19645 exited with code 0 after 7.632154 seconds from start
[10-Aug-2017 03:10:08.539439] DEBUG: pid 24907, fpm_event_loop(), line 419: event module triggered 1 events
[10-Aug-2017 03:10:08.539896] DEBUG: pid 24907, fpm_got_signal(), line 76: received SIGCHLD
[10-Aug-2017 03:10:08.539919] DEBUG: pid 24907, fpm_children_bury(), line 252: [pool domain.four] child 10212 exited with code 0 after 5360.375029 seconds from start
[10-Aug-2017 03:10:08.539927] DEBUG: pid 24907, fpm_event_loop(), line 419: event module triggered 1 events
[10-Aug-2017 03:10:08.540186] DEBUG: pid 24907, fpm_got_signal(), line 76: received SIGCHLD
[10-Aug-2017 03:10:08.540198] DEBUG: pid 24907, fpm_children_bury(), line 252: [pool domain.four] child 15110 exited with code 0 after 2520.446140 seconds from start
[10-Aug-2017 03:10:08.540204] DEBUG: pid 24907, fpm_event_loop(), line 419: event module triggered 1 events
[10-Aug-2017 03:10:13.536777] DEBUG: pid 24907, fpm_pctl_kill_all(), line 159: [pool domain.four] sending signal 15 SIGTERM to child 8254
[10-Aug-2017 03:10:13.536814] DEBUG: pid 24907, fpm_pctl_kill_all(), line 168: 1 child(ren) still alive


domain.four was the latest addition 2 weeks ago and is a small wordpress site.

My setup:
Aache 2.4.27 with PHP 5.6.31 and PHP 7.0.21
Zend OPcache v7.0.21
APCu Version 5.1.8

Code:
listen = /var/lib/apache2/fastcgi/user-domain.four-php-fpm.socket
listen.owner = user
listen.group = user
listen.mode = 0660
user = user
group = user
pm = ondemand
pm.max_children = 34
pm.process_idle_timeout = 10
pm.max_requests = 500
request_terminate_timeout = 60s
request_slowlog_timeout = 5s
slowlog = /var/log/apache2/user-php-slow.log


Slowlog is empty, Load is low, no swapping
Anyone has an idea how i can track down this problem?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum