Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ugly (flickering) LibreOffice 5.4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 152
Location: Czech Republic

PostPosted: Wed Aug 09, 2017 12:51 pm    Post subject: Ugly (flickering) LibreOffice 5.4 Reply with quote

Hi,
I've updated libreoffice from 5.2.7.2 to 5.4.0.3. Unfortunately, this new version is unusable. Application looks ugly, menu/icons are hidden and shows only until mouse. Application flickers.

See screenshot - difference is only a mouse position:

http://kyralovi.cz/tmp/tmp/Screenshot_20170809_135119.png
http://kyralovi.cz/tmp/tmp/Screenshot_20170809_135148.png

I'm using kde5/plasma desktop with intell graphics - all is smooth, without flickering. Only new LO. I've also tried binaries from LO site, but result is the same. I have to return back to 5.2.7.2.

Any idea, what is wrong? Or what changed in LO? Did I miss something?
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2540
Location: Near Toronto

PostPosted: Wed Aug 09, 2017 12:59 pm    Post subject: Reply with quote

I find that on *some* of my intel graphics computers (the
newest in fact - HD graphics 530) I have to use UXA in
xorg to prevent artifacts such as you are experiencing.

They also exist on my intel graphics HD-520 but are much
less noticeable.

Anyway, you could try using UXA instead of default SNA
and see if things improve.
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
mike155
l33t
l33t


Joined: 17 Sep 2010
Posts: 998
Location: Frankfurt, Germany

PostPosted: Wed Aug 09, 2017 1:10 pm    Post subject: Reply with quote

1) What about LibreOffice 5.3? Does it look OK? I would like to know whether the problems come from 5.2 -> 5.3 or from 5.3 -> 5.4

2) Have you tried to switch off hardware acceleration?
Back to top
View user's profile Send private message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 152
Location: Czech Republic

PostPosted: Wed Aug 09, 2017 1:50 pm    Post subject: Reply with quote

Thanks, I'll try UXA. But probably tomorrow.

Quote:

1) What about LibreOffice 5.3? Does it look OK? I would like to know whether the problems come from 5.2 -> 5.3 or from 5.3 -> 5.4


No. I've skipped 5.3. Maybe I'll try, but you know, compilation is very long ;-)

Quote:

2) Have you tried to switch off hardware acceleration?

I've tried switch from OpenGL to Xrender - no change
Back to top
View user's profile Send private message
sdoubleyou
n00b
n00b


Joined: 27 May 2016
Posts: 42

PostPosted: Wed Aug 09, 2017 5:17 pm    Post subject: Reply with quote

You can try the following things

a) use the variable "export SAL_USE_VCLPLUGIN = kde4" before starting libreoffice.
b) LibreOffice toolbars unreadable with dark themes - to use toolbar icons compatible with dark themes, set environment variable VCL_ICONS_FOR_DARK_THEME=1 before loading libreoffice
c) Tools > options > preferences > Libreoffice > View >= graphics output: uncheck "use hardware acceleration"
Back to top
View user's profile Send private message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 152
Location: Czech Republic

PostPosted: Wed Aug 09, 2017 6:36 pm    Post subject: Reply with quote

sdoubleyou wrote:
You can try the following things

a) use the variable "export SAL_USE_VCLPLUGIN = kde4" before starting libreoffice.
b) LibreOffice toolbars unreadable with dark themes - to use toolbar icons compatible with dark themes, set environment variable VCL_ICONS_FOR_DARK_THEME=1 before loading libreoffice
c) Tools > options > preferences > Libreoffice > View >= graphics output: uncheck "use hardware acceleration"


Thanks, will try. Ad b) - I don't use dark theme on that computer.

Meanwhile, I've compiled LO 5.3 on another computer with intel, but there is also nvidia for openGL (Optimus) - no issues. Now I'm compilling LO 5.4 to check.

EDIT: LO 5.4 compilled - works OK, no issues. Have to check tomorrow on plain intel (without optimus).
Back to top
View user's profile Send private message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 152
Location: Czech Republic

PostPosted: Thu Aug 10, 2017 7:08 am    Post subject: Reply with quote

Quote:
c) Tools > options > preferences > Libreoffice > View >= graphics output: uncheck "use hardware acceleration"


So LO 5.4 installed again, after unchecking of this option, LO finally works. Only fonts looks a little bit uglier, but not big issue.
Thanks, all for help.
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 213

PostPosted: Sun Dec 17, 2017 9:36 pm    Post subject: Reply with quote

Hmm, I seem to have the same problem with libreoffice-5.4.3.2.

Is there a way to disable hardware acceleration without using the menus? Because it is flickering so badly, that the program is entirely unuseable. I see nothing except glibberish.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13509

PostPosted: Mon Dec 18, 2017 12:27 am    Post subject: Reply with quote

That setting is almost certainly stored in a file somewhere. I don't know where, but perhaps you can find it with some lucky use of recursive grep. If not, hopefully someone familiar with the program can find it for you and post it. It will be easier to find for someone who can change it through the GUI and search their files for changes than for you, since you must rely on guessing how and where it is stored. Alternately, you might be able to navigate at least some of those menus using keyboard accelerators, if you know or can guess those. The first letter of each level is often a good guess.
Back to top
View user's profile Send private message
kite14
Apprentice
Apprentice


Joined: 07 Nov 2006
Posts: 199
Location: Pordenone/Italy

PostPosted: Mon Dec 18, 2017 8:27 pm    Post subject: Reply with quote

Hi,
I would like to share my findings about this issue...

I experienced this kind of screen corruption with either Intel or AMD open-source driver (Intel core 3rd generation and 7th generation graphic controller, and Radeon HD3650 graphic controller) every time I enabled "OpenGL rendering". At the moment, I have three PCs with the following working configuration:

Tools → Options → Preferences → LibreOffice → View:

    Use Hardware acceleration checked
    Use anti-alias checked
    Use OpenGL rendering unchecked



mas- wrote:
Is there a way to disable hardware acceleration without using the menus? Because it is flickering so badly, that the program is entirely unuseable. I see nothing except glibberish.


LO config files are stored in ~/.config/libreoffice/ and sub-folders; Probably you'd better off deleting the "libreoffice" folder and start over with a new configuration.


Hope this helps...
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 213

PostPosted: Mon Dec 18, 2017 8:42 pm    Post subject: Reply with quote

Thanks, I can confirm that

Quote:
LO config files are stored in ~/.config/libreoffice/ and sub-folders; Probably you'd better off deleting the "libreoffice" folder and start over with a new configuration.


deleting these fixes the problem by unsetting

Code:
Use OpenGL rendering unchecked


and as soon as I enable it again --> all screwed up totally.

Grafic card is:
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Juniper XT [Radeon HD 5770]
Back to top
View user's profile Send private message
kite14
Apprentice
Apprentice


Joined: 07 Nov 2006
Posts: 199
Location: Pordenone/Italy

PostPosted: Mon Dec 18, 2017 9:39 pm    Post subject: Reply with quote

mas- wrote:
Thanks, I can confirm that

Quote:
LO config files are stored in ~/.config/libreoffice/ and sub-folders; Probably you'd better off deleting the "libreoffice" folder and start over with a new configuration.


deleting these fixes the problem by unsetting

Code:
Use OpenGL rendering unchecked


and as soon as I enable it again --> all screwed up totally.

Grafic card is:
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Juniper XT [Radeon HD 5770]


I'm glad to hear that you managed to fix it; it looks like there are quite a few bugs open about LO/OpenGL, some of them are even a couple of years old, but very similar to what we experienced.
Just few examples:
- https://bugs.documentfoundation.org/show_bug.cgi?id=99299
- https://bugs.documentfoundation.org/show_bug.cgi?id=108096
- https://bugs.documentfoundation.org/show_bug.cgi?id=93529

It's no accident that "OpenGL rendering" is disabled by default in Linux...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum