Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Keyboard Layout in Slim
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Solour
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2006
Posts: 106

PostPosted: Mon Aug 07, 2017 9:51 am    Post subject: Keyboard Layout in Slim Reply with quote

Hi,

I am using X/slim/xfce.
When logging in the first time after a reboot I have to type in my password as if I am using a us-keyboard layout.
Every further login (for example after locking the screen) happens with my desired german keyboard layout.

I guess there are obvious questions to ask on how I configured my system.

Code:

# cat ./xorg.conf.d/00-keyboard.conf
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "de"
        Option "XkbModel" "pc104"
        Option "XkbVariant" "qwertz"
        Option "XkbOptions" "grp:alt_shift_toggle"
EndSection

# cat ./Sessions/Xfce
startxfce4


Any ideas?
Back to top
View user's profile Send private message
sdoubleyou
n00b
n00b


Joined: 27 May 2016
Posts: 42

PostPosted: Mon Aug 07, 2017 10:27 am    Post subject: Reply with quote

What do you have in your /etc/X11/xorg.conf.d/10-evdev.conf?

You can change your keyboard-layout there

Code:
Section "InputClass"
        Identifier "evdev keyboard catchall"
        ...
        Driver "evdev"
        Option "xkb_layout" "de"
EndSection


read this https://wiki.gentoo.org/wiki/Evdev#Keyboard_layout and https://wiki.archlinux.org/index.php/SLiM#Change_Keyboard_Layout
Back to top
View user's profile Send private message
Solour
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2006
Posts: 106

PostPosted: Mon Aug 07, 2017 10:56 am    Post subject: Reply with quote

Thanks!
It worked when I also added the variant.
I am wondering whether xkb_layout or XkbLayout is better (more recent/recommended).
The documentations behind the two links do not agree.

Code:

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "de"
        Option "XkbVariant" "nodeadkeys"
EndSection
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1636
Location: United Kingdom

PostPosted: Mon Aug 07, 2017 11:10 am    Post subject: Reply with quote

I have not used SLiM for several years, but I noticed a couple of generic things straight away in the file you posted:

1. You can delete or comment-out the XkbOptions line because you do not have multiple keyboard layouts specified in the file.

2. "qwertz" is not listed in /usr/share/X11/xkb/rules/base.lst as an available XkbVariant for the "de" XkbLayout:

Code:
$ grep "de\:" /usr/share/X11/xkb/rules/base.lst
  deadacute       de: German (dead acute)
  deadgraveacute  de: German (dead grave acute)
  nodeadkeys      de: German (eliminate dead keys)
  T3              de: German (T3)
  ro              de: Romanian (Germany)
  ro_nodeadkeys   de: Romanian (Germany, eliminate dead keys)
  dvorak          de: German (Dvorak)
  sundeadkeys     de: German (Sun dead keys)
  neo             de: German (Neo 2)
  mac             de: German (Macintosh)
  mac_nodeadkeys  de: German (Macintosh, eliminate dead keys)
  dsb             de: Lower Sorbian
  dsb_qwertz      de: Lower Sorbian (qwertz)
  qwerty          de: German (qwerty)
  tr              de: Turkish (Germany)
  ru              de: Russian (Germany, phonetic)
  deadtilde       de: German (dead tilde)

so I think you could also delete or comment out the XkbVariant line in the .conf file, as the "de" XkbLayout is QWERTZ by default anyway.

If the above changes do not solve your problem, I notice that the Arch Linux Wiki page on keyboard configuration in X Windows lists the same file (albeit for mutliple, toggle-able keyboard layouts) as you have used, whereas the Arch Linux Wiki page for SLiM states:

Arch Linux Wiki - SLiM wrote:
Change Keyboard Layout

Edit /etc/X11/xorg.conf.d/10-evdev.conf, find the following section, add the two bolded lines, and replace dvorak with your preferred keymap:

Section "InputClass"
     Identifier "evdev keyboard catchall"
     MatchIsKeyboard "on"
     MatchDevicePath "/dev/input/event*"
     Driver "evdev"

     # Keyboard layouts
     Option "XkbLayout" "dvorak"

EndSection


so you could try the following /etc/X11/xorg.conf.d/10-evdev.conf instead:

Code:
Section  "InputClass"
          Identifier "evdev keyboard catchall"
          MatchIsKeyboard "on"
          MatchDevicePath "/dev/input/event*"
          Driver "evdev"
       
          # Keyboard layouts
          Option "XkbLayout" "de"
EndSection


EDIT: Oops, sdoubleyou beat me to it.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum