Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Gentoo und lua
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 334

PostPosted: Sat Aug 05, 2017 1:12 pm    Post subject: [solved] Gentoo und lua Reply with quote

Ich wollte die Tage in Darktable mal die lua Skripte testen und musste feststellen das es bei Gentoo kein lua 5.2 gibt und somit Darktable nicht mit lua support läuft. :evil:
Hat jemand von euch Erfahrungen mit einem guten Overlay welches lua in 5.2 bereitstellt, oder eine andere Distribution die mehr grafikorientiert ist und solche Sachen besser/aktueller unterstützt? Ich würde dann nach vielen Jahren Gentoo eben wechseln wenn der Support so langsam einschläft. Ich kann es leider nicht besser und bin reiner Anwender, nicht Entwickler. Also bitte kein machs doch selbst....

Danke


Last edited by deranonyme on Mon Aug 07, 2017 4:30 pm; edited 2 times in total
Back to top
View user's profile Send private message
grumblebear
n00b
n00b


Joined: 26 Feb 2008
Posts: 68

PostPosted: Sat Aug 05, 2017 1:25 pm    Post subject: Reply with quote

Vielleicht mal genau hinsehen. Ich zumindest sehe aktuell lua-5.2.3 und auch lua-5.3.3 in Portage.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3189
Location: Germany

PostPosted: Sat Aug 05, 2017 2:00 pm    Post subject: Reply with quote

Puh, das hört sich ja ziemlich deprimiert an.. :-/
Er hat in den letzten ~12 Jahren vermutlich noch nicht das fantastische app-portage/eix Tool entdeckt ;-)
Code:
# eix -e lua
[I] dev-lang/lua
     Available versions: 
     (0)    5.1.5-r4
     (5.1)  [M](~)5.1.5-r100
     (5.2)  [M](~)5.2.3 [M](~)5.2.3-r1
     (5.3)  [M](~)5.3.3
       {+deprecated emacs readline static ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  5.1.5-r4(02:16:58 PM 05/07/2017)(deprecated readline -emacs -static ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
     Homepage:            http://www.lua.org/
     Description:         A powerful light-weight programming language designed for extending applications
(hier von einem amd64 System)
Einige Versionen und 5.2 sind aber hart maskiert.

Hm, ich würde mal via "emerge -pvc dev-lang/lua" schauen ob, und wenn ja welche installierten Pakete aktuell lua benötigen, und dann danach entscheiden oder abwägen ob man für diese auch lua:5.2 nutzen könnte.

/edit: Aus dem darktable-2.2.5.ebuild
"# TODO add lua once dev-lang/lua-5.2 is unmasked"
Vermutlich müsste man dann das darktable ebuild für lua Support noch anpassen.
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 334

PostPosted: Sat Aug 05, 2017 2:09 pm    Post subject: Reply with quote

Oh, danke für den Hinweis auf eix. Der war ja sooo toll. 8O Aber deshalb bleibt lua 5.2 maskiert und genau diese Version ist mindestens nötig damit Darktable lua Sripte verwenden kann. Und ja ich verwende AMD64. Also gerne sachdienliche Hinweise....
Back to top
View user's profile Send private message
grumblebear
n00b
n00b


Joined: 26 Feb 2008
Posts: 68

PostPosted: Sat Aug 05, 2017 2:59 pm    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=618104

Da gibt es mehr sachdienliche Hinweise.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4334

PostPosted: Sat Aug 05, 2017 6:44 pm    Post subject: Reply with quote

lua ist leider in Gentoo ziemlich schlecht supported. Das größte Problem ist, dass viele Pakete nur mit lua-5.1 funktionieren. Mit lua-5.2 gab es einige grundlegende Änderungen (speziell was die Zahlen betrifft, aber auch viele C-Funktionen, die von bindings genutzt werden), sodass ein port mit Arbeit verbunden ist. Und auch 5.3 hat nochmal nachgelegt, so dass manche Pakete, die mit 5.2 funktionieren, wieder Anpassungen für 5.3 benötigen. Es sind sowohl lua-C-Module als auch reine lua-Module betroffen.
Die Lösung wäre slotten, aber die Versuche, das im main tree umzusetzen, sind bisher gescheitert.
Das lua overlay
https://cgit.gentoo.org/proj/lua.git/
funktioniert bei mir recht gut. Ich habe alle ebuilds, die ich benutze, angepasst und in einem lokalen Overlay untergebracht (awesome-wm und (g)vim). Kannst es ja mal versuchen :) Wenn es nur bei einem Paket bleibt darktable), dann ist der Aufwand natürlich nicht nötig!
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 334

PostPosted: Mon Aug 07, 2017 11:44 am    Post subject: Reply with quote

Ich habe jetzt lua 5.2 demaskiert und installiert. Lief ohne Fehler durch. Danach mussten electra und podofo neu gebaut werden. Lief auch ohne Fehler. Für Darktable noch ein lokales Ebuild erzeugt mit lua Support und man glaubt es kaum - es läuft. Vielleicht wird es doch noch was mit dem offiziellen lua Support auch unter Gentoo. 8)

Die Hoffnung stirbt zuletzt...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum