Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Unreal Engine 4]Valhalla Hills crash at launch
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Babaorheum
n00b
n00b


Joined: 30 Jul 2017
Posts: 11
Location: France

PostPosted: Thu Aug 03, 2017 8:50 pm    Post subject: [Unreal Engine 4]Valhalla Hills crash at launch Reply with quote

Hi,

I have a problem with this game bought on GoG.com because it crash at launche and i don't know where come from the issue. I add that i don't understand the crash ouput log in my console too. :oops:

This is the output console when the game crash :
Code:
./start.sh
Running Valhalla Hills
Using binned.
4.10.1-0+++depot+UE4-Releases+4.10 7038 3077 482 0
*** Error in `./ValhallaHills-Linux-Shipping': double free or corruption (!prev): 0x0000000006a14c50 ***
======= Backtrace: =========
/lib64/libc.so.6(+0x6fbcb)[0x7fd0bfa27bcb]
/lib64/libc.so.6(+0x75456)[0x7fd0bfa2d456]
/lib64/libc.so.6(+0x75c4e)[0x7fd0bfa2dc4e]
/usr/lib/llvm/4/lib64/libLLVMSelectionDAG.so.4(+0x1459ae)[0x7fd0b6a459ae]
/usr/lib/llvm/4/lib64/libLLVMSelectionDAG.so.4(_ZN4llvm16SelectionDAGISel17CodeGenAndEmitDAGEv+0x511)[0x7fd0b6acd9a1]
/usr/lib/llvm/4/lib64/libLLVMSelectionDAG.so.4(_ZN4llvm16SelectionDAGISel20SelectAllBasicBlocksERKNS_8FunctionE+0xe7e)[0x7fd0b6ad5aae]
/usr/lib/llvm/4/lib64/libLLVMSelectionDAG.so.4(_ZN4llvm16SelectionDAGISel20runOnMachineFunctionERNS_15MachineFunctionE+0x675)[0x7fd0b6ad8575]
/usr/lib/llvm/4/lib64/libLLVMCodeGen.so.4(_ZN4llvm19MachineFunctionPass13runOnFunctionERNS_8FunctionE+0x91)[0x7fd0b4f20371]
/usr/lib/llvm/4/lib64/libLLVMCore.so.4(_ZN4llvm13FPPassManager13runOnFunctionERNS_8FunctionE+0x1ad)[0x7fd0b1e9849d]
*** Error in `./ValhallaHills-Linux-Shipping': munmap_chunk(): invalid pointer: 0x0000000007254900 ***
======= Backtrace: =========
/usr/lib/llvm/4/lib64/libLLVMTarget.so.4(+0xa197)[0x7fd0b4b63197]
/lib64/libc.so.6(+0x6fbcb)[0x7fd0bfa27bcb]
/usr/lib/llvm/4/lib64/libLLVMTarget.so.4(LLVMTargetMachineEmitToMemoryBuffer+0xa8)[0x7fd0b4b63648]
/lib64/libc.so.6(+0x75456)[0x7fd0bfa2d456]
/usr/lib64/dri/radeonsi_dri.so(+0x57a674)[0x7fd0ba01d674]
/usr/lib/llvm/4/lib64/libLLVMSelectionDAG.so.4(/usr/lib64/dri/radeonsi_dri.so(+0x575946)[0x7fd0ba018946]
/usr/lib/llvm/4/lib64/libLLVMSelectionDAG.so.4(_ZN4llvm16SelectionDAGISel17CodeGenAndEmitDAGEv+0x511)[0x7fd0b6acd9a1]
/lib64/libc.so.6(clone+0x6d)[0x7fd0bfa9fa9d]
======= Memory map: ========
/usr/lib/llvm/4/lib64/libLLVMSelectionDAG.so.4(_ZN4llvm16SelectionDAGISel20SelectAllBasicBlocksERKNS_8FunctionE+0xe7e)[0x7fd0b6ad5aae]
/usr/lib/llvm/4/lib64/libLLVMSelectionDAG.so.4(_ZN4llvm16SelectionDAGISel20runOnMachineFunctionERNS_15MachineFunctionE+0x675)[0x7fd0b6ad8575]
support/gog_com.shlib : ligne 94 : 17011 Abandon                 ./"${bin_64}"


I use Mesa 17.1.5, Xorg 1.19 and llvm-4. On Debian, with the same version of these packages, the game starts correctly and without problem.
_________________
Sorry for my English, i'm French :-)
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 11434

PostPosted: Fri Aug 04, 2017 1:32 am    Post subject: Reply with quote

That output indicates there is definitely a bug. It is not yet clear whether the bug is in the game or in a supporting library. Are you sure that your Debian system has exactly the same versions of all these packages? Which Debian release did you test? How did you determine the versions of the packages on Debian? Debian is well known for being slow to update, so I find it rather unlikely that they would have all the same versions as you have on Gentoo.
Back to top
View user's profile Send private message
Babaorheum
n00b
n00b


Joined: 30 Jul 2017
Posts: 11
Location: France

PostPosted: Fri Aug 04, 2017 4:21 am    Post subject: Reply with quote

Hi Hu,

I'm sure that it's the same version for these packages between Gentoo and Debian. With Gentoo, i have a Debian Unstable installed on my Desktop.
To check if the version between packages are the same, i launch 'eix packages' for Gentoo and i go to https://www.debian.org/distrib/packages for Debian (or i check by a chroot on Debian).

Mesa Gentoo :
Code:

media-libs/mesa
[...]
     Installed versions:  17.1.5^d(22:52:52 03/08/2017)
[...]


Mesa Debian Sid :
https://packages.debian.org/sid/libgl1-mesa-glx
or
Code:
# dpkg -l | grep mesa
ii  libegl1-mesa:amd64                   17.1.5-1                          amd64        free implementation of the EGL API -- runtime
ii  libgl1-mesa-dri:amd64                17.1.5-1                          amd64        free implementation of the OpenGL API -- DRI modules
ii  libgl1-mesa-dri:i386                 17.1.5-1                          i386         free implementation of the OpenGL API -- DRI modules
ii  libgl1-mesa-glx:amd64                17.1.5-1                          amd64        free implementation of the OpenGL API -- GLX runtime
ii  libgl1-mesa-glx:i386                 17.1.5-1                          i386         free implementation of the OpenGL API -- GLX runtime
[...]


llvm Gentoo :
Code:

sys-devel/llvm
[...]
     Installed versions:  4.0.1(4)(19:23:05 01/08/2017)
[...]


llvm Debian Sid :
Code:
ii  libllvm4.0:amd64                     1:4.0.1-1                         amd64        Modular compiler and toolchain technologies, runtime library
ii  libllvm4.0:i386                      1:4.0.1-1                         i386         Modular compiler and toolchain technologies, runtime library

_________________
Sorry for my English, i'm French :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum