Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mixxx Need help cant emerge [solved ]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
sleepingsun
Guru
Guru


Joined: 03 May 2006
Posts: 345
Location: Bosnia

PostPosted: Thu Aug 03, 2017 9:39 am    Post subject: Mixxx Need help cant emerge [solved ] Reply with quote

Please help for this DJ software Mixxx

when i try to emerge i get this error:

Code:
Gui -I/usr/include/qt5/QtConcurrent -I/usr/include/qt5/QtCore -Ilib/gtest-1.7.0/                                                                             include -Ilib/fidlib-0.9.10 -I/usr/include/taglib -Ilib/hidapi-0.8.0-rc1/hidapi                                                                              -I/usr/include/libusb-1.0 -Ilib/xwax -Ilib/scratchlib -I/usr/include/opus src/li                                                                             brary/treeitemmodel.cpp
In file included from src/library/trackcollection.cpp:7:0:
/usr/include/sqlite3.h:3712:16: error: using typedef-name 'sqlite3_value' after                                                                              'struct'
 typedef struct sqlite3_value sqlite3_value;
                ^
In file included from src/library/trackcollection.cpp:4:0:
src/library/trackcollection.h:38:20: note: 'sqlite3_value' has a previous declar                                                                             ation here
 typedef struct Mem sqlite3_value;
                    ^
In file included from src/library/trackcollection.cpp:7:0:
/usr/include/sqlite3.h:3712:30: error: conflicting declaration 'typedef int sqli                                                                             te3_value'
 typedef struct sqlite3_value sqlite3_value;
                              ^
In file included from src/library/trackcollection.cpp:4:0:
src/library/trackcollection.h:38:20: note: previous declaration as 'typedef stru                                                                             ct Mem sqlite3_value'
 typedef struct Mem sqlite3_value;
                    ^
scons: *** [lin64_build/library/trackcollection.o] Error 1
scons: building terminated because of errors.
 * ERROR: media-sound/mixxx-2.0.0-r4::gentoo failed (compile phase):
 *   escons failed.
 *
 * Call stack:
 *     ebuild.sh, line  115:  Called src_compile
 *   environment, line 2616:  Called escons 'prefix=/usr' 'qtdir=/usr/lib64/qt5'                                                                              'faad=1' 'ffmpeg=1' 'hid=1' 'hifieq=1' 'm4a=1' 'mad=1' 'optimize=0' 'qdebug=1'                                                                              'qt5=1' 'shoutcast=1' 'vinylcontrol=1' 'wv=1'
 *   environment, line 1172:  Called die
 * The specific snippet of code:
 *                   die -n "escons failed."
 *
 * If you need support, post the output of `emerge --info '=media-sound/mixxx-2.                                                                             0.0-r4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-sound/mixxx-2.0                                                                             .0-r4::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-sound/mixxx-2.0.                                                                             0-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/mixxx                                                                             -2.0.0-r4/temp/environment'.
 * Working directory: '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/work/mixxx-2.                                                                             0.0'
 * S: '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/work/mixxx-2.0.0'

>>> Failed to emerge media-sound/mixxx-2.0.0-r4, Log file:

>>>  '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/temp/build.log'

 * Messages for package media-sound/mixxx-2.0.0-r4:

 * ERROR: media-sound/mixxx-2.0.0-r4::gentoo failed (compile phase):
 *   escons failed.
 *
 * Call stack:
 *     ebuild.sh, line  115:  Called src_compile
 *   environment, line 2616:  Called escons 'prefix=/usr' 'qtdir=/usr/lib64/qt5'                                                                              'faad=1' 'ffmpeg=1' 'hid=1' 'hifieq=1' 'm4a=1' 'mad=1' 'optimize=0' 'qdebug=1'                                                                              'qt5=1' 'shoutcast=1' 'vinylcontrol=1' 'wv=1'
 *   environment, line 1172:  Called die
 * The specific snippet of code:
 *                   die -n "escons failed."
 *
 * If you need support, post the output of `emerge --info '=media-sound/mixxx-2.                                                                             0.0-r4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-sound/mixxx-2.0                                                                             .0-r4::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-sound/mixxx-2.0.                                                                             0-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/mixxx                                                                             -2.0.0-r4/temp/environment'.
 * Working directory: '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/work/mixxx-2.                                                                             0.0'
 * S: '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/work/mixxx-2.0.0'


[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
_________________
Gentoo is Rocks


Last edited by sleepingsun on Tue Dec 05, 2017 11:32 pm; edited 3 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16905
Location: here

PostPosted: Thu Aug 03, 2017 9:48 am    Post subject: Reply with quote

Try the patch proposed in this bug.
For apply user patches see here
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sleepingsun
Guru
Guru


Joined: 03 May 2006
Posts: 345
Location: Bosnia

PostPosted: Thu Aug 03, 2017 1:47 pm    Post subject: Reply with quote

I just view post i try but also finish with error or if you have some time to made some post step by step for patching this ...
_________________
Gentoo is Rocks
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16905
Location: here

PostPosted: Thu Aug 03, 2017 1:51 pm    Post subject: Reply with quote

The steps for applying patch are these
Code:
# mkdir -p /etc/portage/patches/media-sound/mixxx-2.0.0-r4
# cd /etc/portage/patches/media-sound/mixxx-2.0.0-r4
# wget "https://622776.bugs.gentoo.org/attachment.cgi?id=487284" -O mixxx-sqlite.patch
# emerge media-sound/mixxx

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sleepingsun
Guru
Guru


Joined: 03 May 2006
Posts: 345
Location: Bosnia

PostPosted: Thu Aug 03, 2017 3:19 pm    Post subject: Reply with quote

Ty very much its solved my problem
_________________
Gentoo is Rocks
Back to top
View user's profile Send private message
sleepingsun
Guru
Guru


Joined: 03 May 2006
Posts: 345
Location: Bosnia

PostPosted: Tue Dec 05, 2017 10:07 am    Post subject: Reply with quote

Update system togcc-6.4.0 and get smiliar problem with mixxx try same but not working

Code:
error what i get :

>>> Emerging (1 of 1) media-sound/mixxx-2.0.0-r4::gentoo
 * mixxx-2.0.0-src.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                 [ ok ]
 * mixxx-2.0.0-ffmpeg30.patch SHA256 SHA512 WHIRLPOOL size ;-) ...                             [ ok ]
 * mixxx-2.0.0-ffmpeg31.patch SHA256 SHA512 WHIRLPOOL size ;-) ...                             [ ok ]
>>> Unpacking source...
>>> Unpacking mixxx-2.0.0-src.tar.gz to /var/tmp/portage/media-sound/mixxx-2.0.0-r4/work
>>> Unpacking mixxx-2.0.0-ffmpeg30.patch to /var/tmp/portage/media-sound/mixxx-2.0.0-r4/work
unpack mixxx-2.0.0-ffmpeg30.patch: file format not recognized. Ignoring.
>>> Unpacking mixxx-2.0.0-ffmpeg31.patch to /var/tmp/portage/media-sound/mixxx-2.0.0-r4/work
unpack mixxx-2.0.0-ffmpeg31.patch: file format not recognized. Ignoring.
>>> Source unpacked in /var/tmp/portage/media-sound/mixxx-2.0.0-r4/work
>>> Preparing source in /var/tmp/portage/media-sound/mixxx-2.0.0-r4/work/mixxx-2.0.0 ...
 * Applying mixxx-2.0.0-docs.patch ...                                                         [ ok ]
 * Applying mixxx-2.0.0-ffmpeg30.patch ...                                                     [ ok ]
 * Applying mixxx-2.0.0-ffmpeg31.patch ...                                                     [ ok ]
 * Applying mixxx-2.0.0-chromaprint-1.4.patch ...                                              [ ok ]
 * Applying mixxx-2.0.0-gcc62.patch ...                                                        [ ok ]
 * Applying mixxx-2.0.0-sqlite3.patch ...                                                      [ ok ]
 * Applying mixxx-2.0.0-fix-formatting-of-time-durations.patch ...                             [ ok ]
 * Applying mixxx-2.0.0-eliminate-unnecessary-heap-allocation-of-qtime.patch ...               [ ok ]
 * Applying mixxx-2.0.0-fix-missing-pointer-initialization.patch ...                           [ ok ]
 * Applying mixxx-2.0.0-move-definition-of-time-formatseconds-into-dot-cpp-file.patch ...      [ ok ]
 * Applying mixxx-2.0.0-fix-formatting-of-time-durations2.patch ...                            [ ok ]
 * Applying mixxx-2.0.0-rmx2-backport-controller-scripts.patch ...                             [ ok ]
 * Applying mixxx-sqlite.patch ...
1 out of 1 hunk FAILED -- saving rejects to file src/library/trackcollection.h.rej             [ !! ]
 * ERROR: media-sound/mixxx-2.0.0-r4::gentoo failed (prepare phase):
 *   patch -p1  failed with /etc/portage/patches/media-sound/mixxx-2.0.0-r4/mixxx-sqlite.patch
 *
 * Call stack:
 *               ebuild.sh, line  124:  Called src_prepare
 *             environment, line 2661:  Called default
 *      phase-functions.sh, line  853:  Called default_src_prepare
 *      phase-functions.sh, line  918:  Called __eapi6_src_prepare
 *             environment, line  287:  Called eapply_user
 *             environment, line  870:  Called eapply '/etc/portage/patches/media-sound/mixxx-2.0.0-r4/mixxx-sqlite.patch'
 *             environment, line  840:  Called _eapply_patch '/etc/portage/patches/media-sound/mixxx-2.0.0-r4/mixxx-sqlite.patch'
 *             environment, line  778:  Called __helpers_die 'patch -p1  failed with /etc/portage/patches/media-sound/mixxx-2.0.0-r4/mixxx-sqlite.patch'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *              die "$@"
 *
 * If you need support, post the output of `emerge --info '=media-sound/mixxx-2.0.0-r4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-sound/mixxx-2.0.0-r4::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/temp/environment'.
 * Working directory: '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/work/mixxx-2.0.0'
 * S: '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/work/mixxx-2.0.0'

>>> Failed to emerge media-sound/mixxx-2.0.0-r4, Log file:

>>>  '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/temp/build.log'

 * Messages for package media-sound/mixxx-2.0.0-r4:

 * ERROR: media-sound/mixxx-2.0.0-r4::gentoo failed (prepare phase):
 *   patch -p1  failed with /etc/portage/patches/media-sound/mixxx-2.0.0-r4/mixxx-sqlite.patch
 *
 * Call stack:
 *               ebuild.sh, line  124:  Called src_prepare
 *             environment, line 2661:  Called default
 *      phase-functions.sh, line  853:  Called default_src_prepare
 *      phase-functions.sh, line  918:  Called __eapi6_src_prepare
 *             environment, line  287:  Called eapply_user
 *             environment, line  870:  Called eapply '/etc/portage/patches/media-sound/mixxx-2.0.0-r4/mixxx-sqlite.patch'
 *             environment, line  840:  Called _eapply_patch '/etc/portage/patches/media-sound/mixxx-2.0.0-r4/mixxx-sqlite.patch'
 *             environment, line  778:  Called __helpers_die 'patch -p1  failed with /etc/portage/patches/media-sound/mixxx-2.0.0-r4/mixxx-sqlite.patch'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *              die "$@"
 *
 * If you need support, post the output of `emerge --info '=media-sound/mixxx-2.0.0-r4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-sound/mixxx-2.0.0-r4::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/temp/environment'.
 * Working directory: '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/work/mixxx-2.0.0'
 * S:
 * '/var/tmp/portage/media-sound/mixxx-2.0.0-r4/work/mixxx-2.0.0'


[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
_________________
Gentoo is Rocks
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5570
Location: Austria

PostPosted: Tue Dec 05, 2017 10:21 am    Post subject: Reply with quote

No, that's your own patch that is failing there. Because the patch made it into the package meanwhile.

Code:
1 out of 1 hunk FAILED -- saving rejects to file src/library/trackcollection.h.rej [ !! ]
* ERROR: media-sound/mixxx-2.0.0-r4::gentoo failed (prepare phase):
* patch -p1 failed with /etc/portage/patches/media-sound/mixxx-2.0.0-r4/mixxx-sqlite.patch

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
sleepingsun
Guru
Guru


Joined: 03 May 2006
Posts: 345
Location: Bosnia

PostPosted: Tue Dec 05, 2017 11:07 pm    Post subject: Reply with quote

Yap i delete patch but not emerge and delete media-sound folder with mixx folder in and than emerge fine ty for info

working
_________________
Gentoo is Rocks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum