Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Performance Problem - Cinnamon
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
josedb
Apprentice
Apprentice


Joined: 03 Nov 2006
Posts: 206

PostPosted: Mon Jul 31, 2017 4:37 pm    Post subject: Performance Problem - Cinnamon Reply with quote

Hi, iam having this error on .xsessionerrors
Code:
openGL version 4.5 detected (GL3 Cogl Driver)
MetaSyncRing disabled: couldn't find required GL extensions, or the minimum safe openGL version was not met


I have tried several DE (Fluxbox, openbox, plasma, and mate) apart from cinnamon , which is having a poor performance, iam not having this problem with the others. If i switch to software rendering this is even worst.
i compilled mesa with gles1 gles2 opengl opencl, and other flags and the result is the same


3d accerelation seems to work. this is the xorg log:

https://pastebin.com/MCfAWRid


any ideas? thanks
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Mon Jul 31, 2017 11:17 pm    Post subject: Reply with quote

It seems that's an OpenGL 3.3 feature, which you're video card should support on any driver.

What video card is it? What driver are you using?
Back to top
View user's profile Send private message
josedb
Apprentice
Apprentice


Joined: 03 Nov 2006
Posts: 206

PostPosted: Tue Aug 01, 2017 2:01 am    Post subject: Reply with quote

intel 620 (Kaby lake i5 7200u)

Video driver is in-kernel (i915 driver), i also build the dmc (and guc, but it says "GuC firmware load skipped" on dmesg) firmware with the same result.


Code:
dmesg |grep drm
[    0.599624] [drm] Initialized
[    0.600106] [drm] Memory usable by graphics device = 4096M
[    0.600122] [drm] VT-d active for gfx access
[    0.600137] fb: switching to inteldrmfb from EFI VGA
[    0.600216] [drm] Replacing VGA console driver
[    0.605548] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    0.605552] [drm] Driver supports precise vblank timestamp query.
[    0.607971] [drm] Finished loading i915/kbl_dmc_ver1_01.bin (v1.1)
[    0.616044] [drm] GuC firmware load skipped
[    0.621399] [drm] Initialized i915 1.6.0 20160919 for 0000:00:02.0 on minor 0
[    0.629600] fbcon: inteldrmfb (fb0) is primary device
[    1.763645] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    1.789775] [drm] RC6 on
[  415.045725] [drm] GuC firmware load skipped
[  416.768257] [drm] RC6 on
[  561.355197] [drm] GuC firmware load skipped
[  562.754514] [drm] RC6 on
[ 6288.125321] [drm] GuC firmware load skipped
[ 6289.775252] [drm] RC6 on
[10384.459928] [drm] GuC firmware load skipped
[10385.698558] [drm] RC6 on
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Tue Aug 01, 2017 3:04 am    Post subject: Reply with quote

I google searched the GuC firmware thing, but it seems that is a regular message. If it didn't work, then it would've given an error message. That is just informing you that it skipped loading it. I'm not sure if that is the root cause. But if you look at the timestamps from each they are quite a bit off. So whatever is triggering that message is happening after boot multiple times. I wonder if the GPU is resetting?
Back to top
View user's profile Send private message
josedb
Apprentice
Apprentice


Joined: 03 Nov 2006
Posts: 206

PostPosted: Tue Aug 01, 2017 3:06 am    Post subject: Reply with quote

i also read that , as far i can tell gpu if working well, i benchmarked it and it gives the same results as other intel 620´s users.
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Tue Aug 01, 2017 3:10 am    Post subject: Reply with quote

I'm not entirely certain, but this sounds a lot like the same problem.

https://github.com/linuxmint/muffin/issues/244

Even though it's a different distributions forum, you might want to get into that thread and you know like post a "me too on gentoo" type post.
Back to top
View user's profile Send private message
josedb
Apprentice
Apprentice


Joined: 03 Nov 2006
Posts: 206

PostPosted: Tue Aug 01, 2017 3:15 am    Post subject: Reply with quote

I´ll give a try. Thank you very much
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum