Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XFCE Nvidia Tearing even w/ Compton
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sjgieson
n00b
n00b


Joined: 27 Dec 2013
Posts: 12

PostPosted: Mon Jul 31, 2017 1:12 pm    Post subject: XFCE Nvidia Tearing even w/ Compton Reply with quote

Hello everyone,

I have been running XFCE and compton for tear free UI since about 2013. Sometime in about the 6-8 months I started getting bad tearing. Easy to see in a web browser window, both on Chromium and Firefox. Every time I think I have it figured it out , it's there. I about ready to just drop XFCE to see it is this cause. I am running nvidia drivers, tried several version, no help.

Anyone else with XFCE have this issue? Its obviously there when I drop Compton as well and either using built-in compositing or none at all.

Thanks.
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Mon Jul 31, 2017 11:06 pm    Post subject: Re: XFCE Nvidia Tearing even w/ Compton Reply with quote

sjgieson wrote:
Hello everyone,

I have been running XFCE and compton for tear free UI since about 2013. Sometime in about the 6-8 months I started getting bad tearing. Easy to see in a web browser window, both on Chromium and Firefox. Every time I think I have it figured it out , it's there. I about ready to just drop XFCE to see it is this cause. I am running nvidia drivers, tried several version, no help.

Anyone else with XFCE have this issue? Its obviously there when I drop Compton as well and either using built-in compositing or none at all.

Thanks.


I don't think there is anything you can do, nVidia has a really shitty DDX driver. It doesn't have any options for tearfree or vertical sync. At least with the open source DDX drivers, including the modesetting DDX, there are working options for tearfree and vertical sync and what not.

You can try other desktops, but a compositor cannot fix tearing and nVidia's drivers don't expose the configuration needed.
Back to top
View user's profile Send private message
Juippisi
Guru
Guru


Joined: 30 Sep 2005
Posts: 324
Location: /home

PostPosted: Tue Aug 01, 2017 7:35 am    Post subject: Reply with quote

Im using nvidia, proprietary drivers and have no tearing. Only time I ever saw tearing was in KDE when I was playing videos, I could never figure that out. Nowadays I use Gnome3 or openbox with compton. Ive made my xorg.conf using nvidia-settings, maybe that helps? Also I do have HW acceleration enabled in browser config.

This is my compton line that I use,
Code:

compton -b --backend glx --glx-swap-method 2 --glx-no-stencil --vsync opengl -cC -l -18 -t -18 -o 0.1 &
Back to top
View user's profile Send private message
mir3x
Guru
Guru


Joined: 02 Jun 2012
Posts: 427

PostPosted: Tue Aug 01, 2017 8:53 am    Post subject: Reply with quote

I dont use compton anymore, but i have still my conf from $HOME/.config/compton.conf
(TBH fuck compton, just use kwin5 compositor, its faster and work flawless outside kf5)

Code:
focus-exclude = ["n:a:Conky"];
backend = "glx"
vsync = "opengl-swc"
paint-on-overlay = true
unredir-if-possible = true
detect-rounded-corners = true;
detect-client-opacity = true;                                                                                         
                                                                                                                       
blur-background-exclude = [ "window_type = 'dock'", "window_type = 'desktop'" ];


# Other
#backend = "xrender"
mark-wmwin-focused = true;
mark-ovredir-focused = true;
#use-ewmh-active-win = true;
#detect-rounded-corners = true;
#detect-client-opacity = true;
refresh-rate = 60;
#vsync = "none";
dbe = false;
#paint-on-overlay = true;
# sw-opti = true;
# unredir-if-possible = true;
# unredir-if-possible-delay = 5000;
# unredir-if-possible-exclude = [ ];
#focus-exclude = [ "class_g = 'Cairo-clock'" ];
detect-transient = true;
detect-client-leader = true;
#invert-color-include = [ ];
# resize-damage = 1;

# GLX backend
glx-no-stencil = true;
glx-copy-from-front = false;
#glx-use-copysubbuffermesa = true;
glx-no-rebind-pixmap = true;
glx-swap-method = 6;
glx-use-gpushader4 = true;

# Window type settings
# wintypes:
# {
#   tooltip = { fade = true; shadow = false; opacity = 0.75; focus = true; };
# };


maybe it will work ok for u
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
i4dnf
Apprentice
Apprentice


Joined: 18 Sep 2005
Posts: 265
Location: Bucharest, Romania

PostPosted: Tue Aug 01, 2017 8:58 am    Post subject: Reply with quote

Try adding the ForceCompositionPipeline=On, ForceFullCompositionPipeline=On to a metamode option for your display in xorg.conf.
Something like:

Code:

Section Screen

   ...somestuffhere...
    Option         "metamodes" "DVI-I-0: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"

End Section

_________________
"The only difference between me and a madman is that I am not MAD" (SALVATOR DALI)
Back to top
View user's profile Send private message
sjgieson
n00b
n00b


Joined: 27 Dec 2013
Posts: 12

PostPosted: Thu Aug 03, 2017 12:26 am    Post subject: Reply with quote

Thanks everyone for the replies, and ideas to try.

As far the driver, I do think that is probably the cause. I do a world update about once every few weeks, I know compton hasn't been updated in while but nvidia drivers always are. I used the proprietary driver as I thought it brought better performance, if I get any benefit of using the open source one. I will switch to that as well.

I will try everything and report back what I find out.
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Thu Aug 03, 2017 1:16 am    Post subject: Reply with quote

sjgieson wrote:
Thanks everyone for the replies, and ideas to try.

As far the driver, I do think that is probably the cause. I do a world update about once every few weeks, I know compton hasn't been updated in while but nvidia drivers always are. I used the proprietary driver as I thought it brought better performance, if I get any benefit of using the open source one. I will switch to that as well.

I will try everything and report back what I find out.


Well, that's a tough decision to make too, because Nouveau works well for older series cards, but the last few (generations) still aren't working well due to firmware (release times) and documentation issues (reclocking and voltage). You'll definitely get a better OpenGL experience with the official drivers.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum