Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Thunderbird line wrapping causing hard line breaks. [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1376

PostPosted: Sun Jul 30, 2017 5:25 pm    Post subject: Thunderbird line wrapping causing hard line breaks. [SOLVED] Reply with quote

Help! I'm going nuts with this one. I'm running Thunderbird 52.2 on my Gentoo machine as well as on a VM running CentOS 6. The two are behaving differently and I cannot figure out why. This is a bit hard to explain:

I always use text format emails. Thunderbird on my CentOS VM is working the way I want: As I'm entering a long paragraph with no hard line breaks, the display line wraps (display ONLY), and when I save it as a draft that long paragraph is saved as one physical line.

This is NOT what's happening for me on my Gentoo machine...again same version: As I'm keying in a long paragraph, the lines wrap in the display and apperas much as above, but when I save it as a draft that wrapping gets saved as hard line breaks. This is just awful, as adding a words onto the previous saved paragraph requires totally reformatting the paragraph.

For the life of me I CANNOT figure it out or find a setting that controls this...driving me batshit.

Thanks!
Tom


Last edited by tld on Sun Jul 30, 2017 6:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Sun Jul 30, 2017 5:35 pm    Post subject: Reply with quote

Have you diffed (or vimdiffed) the ~/.thunderbird/<salted dir>/prefs.js files from both systems?
Back to top
View user's profile Send private message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1376

PostPosted: Sun Jul 30, 2017 5:39 pm    Post subject: Reply with quote

I've read several things about settings in Edit -> Preferences -> Advanced -> General -> Config Editor, but all settings there I can find related to line wrapping are the same:

mail.wrap_ling_lines true
plain_test.wrap_long_lines false

I'm gonna loose my mind with this one.

Tom
Back to top
View user's profile Send private message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1376

PostPosted: Sun Jul 30, 2017 5:50 pm    Post subject: Reply with quote

charles17 wrote:
Have you diffed (or vimdiffed) the ~/.thunderbird/<salted dir>/prefs.js files from both systems?
Maybe I'll have to try that, but I somehow have an ugly feeling this may be some ugly bug with 32 bit (my Gentoo is on x86).
I also see that on both systems the mailnews.wraplength is 72...crazy....just everything I can see related to line wrapping is identical.

Tom
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1631
Location: United Kingdom

PostPosted: Sun Jul 30, 2017 5:58 pm    Post subject: Reply with quote

I had the same problem some time ago, but can't remember how I fixed it. However, perhaps if I tell you my current settings that I think are relevant, that might be of help:

'Edit' > 'Preferences' > 'Advanced' > 'Config Editor...'

Search: wrap

Code:

Preference Name                         Status      Type        Value
devtools.scratchpad.wrapText            default     boolean     false
extensions.enigmail.wrapHtmlBeforeSend  default     boolean     true
mail.wrap_long_lines                    user set    boolean     false
mailnews.wraplength                     user set    integer     0
plain_text.wrap_long_lines              default     boolean     false
view_source.wrap_long_lines             default     boolean     false

Note: You need to change both those preferences (mail.wrap_long_lines and mailnews.wraplength), even if you don't use mailnews.

'Edit' > 'Account Settings' > 'Composition & Addressing' > tick 'Compose messages in HTML format' for each account if it is not already ticked.

'Edit' > 'Preferences' > 'Composition' > 'General' > 'Send Options...' > untick 'Send messages as plain text if possible' and select 'Ask me what to do' in the pull-down menu. Additionally, if you send e-mails to someone who uses Microsoft Outlook and uses HTML in their e-mails, you can select the 'HTML Domains' tab, click 'Add...' and enter their domain (e.g. cisco.com or whatever) in the box. Likewise, if you send e-mails to someone who uses only plain text in their e-mails, you can select the 'Plain Text Domains' tab, click 'Add...' and enter their domain (e.g. bugs.debian.org or whatever) in the box.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1376

PostPosted: Sun Jul 30, 2017 6:11 pm    Post subject: Reply with quote

Thanks for the replies. OMG...I actually found it and it was REALLY obscure. See the very last comment here regarding the Enigmail plugin (which is installed on my Gentoo version but NOT on the other):

https://bugzilla.mozilla.org/show_bug.cgi?id=155622

My CentOS version had that mailnews.send_plaintext_flowed defaulted to true. I had to change that to true on my Gentoo version to get the same behavior. Just to REALLY make that hard to find, possibly because it's a difference in the default, that setting did NOT appear in either pref.js file until I added that true override on the Gentoo version. Holy crap!

Tom
Back to top
View user's profile Send private message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1376

PostPosted: Sun Jul 30, 2017 6:31 pm    Post subject: Reply with quote

Yup...I just discovered when I disable Enigmail the default for that value changes to true. You know shit like this, changing a fairly important and EXTREMELY obscure setting...and one that makes using text email all but impossible no less...with no warning, just plain fucking pisses me off. See others griping about it here:

https://sourceforge.net/p/enigmail/bugs/53/

Also note that when I switched from thunderbird-bin to compiled thunderbird that was installed and activated by default. I hadn't proactively done any of this. I'm beginning to think everyone associated with anything related to Mozilla are just a bunch of dicks frankly.</rant>

Tom
Back to top
View user's profile Send private message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1376

PostPosted: Thu Dec 28, 2017 2:41 pm    Post subject: Reply with quote

Oh my God...Oh...my...God. After updating to Thunderbird 52.5.0 this behavior resumed. It turned out that the update had re-enabled enigmail and thus reset that mailnews.send_plaintext_flowed to false!

Again, specifically because the config setting has an obscure name that includes nothing resembling "wrap"...I just spent another hour re-investigating how to fix this all over! I literally ended up finding my own thread here on Google. This sort of shit is inexcusable. I wish someone who isn't an asshole of the highest order would fork Thunderbird much like Palemoon. No words at all.

Tom
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum