Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
glsa-check e webkit-gtk
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
oscarandrea
Apprentice
Apprentice


Joined: 27 Nov 2015
Posts: 176
Location: Italy/Cosenza

PostPosted: Sat Jul 22, 2017 8:49 am    Post subject: glsa-check e webkit-gtk Reply with quote

Salve, tramite glsa-check ho fatto un test dei pacchetti nel mio sistema e mi ritrovo questa glsa
[glsa=]201706-15[/glsa] ho provato a ad usare
Code:
glsa-check -f affected
ma mi dice:
Code:
>>> cannot fix GLSA, no unaffected packages available

mentre eix mi dice che in effetti esiste nei repo la versione aggiornata 2.16.5 (dopo la 2.16.3 non ci dovrebbero essere problemi), quindi come mai glsa non riesce ad aggiornarmi il pacchetto?
premetto che avevo già provato con:
Code:
 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/webkit-gtk-2.16.3:4"

e non aveva funzionato. Ora non so se c'erano stato problemi di compilazione o altro, in quanto il pacchetto è molto lungo da compilare avevo lasciato il pc a compilare e poi non ci ho fatto più caso andando a ricontrollare con glsa-check però mi diceva che c'era ancora il problema, ieri ho avviato la compilazine nuovamente manuale del pacchetto ma ho dovuta interromperla quindi non ho più nemmeno i log reali :roll: prima di provare di nuovo a compilare il nuovo pacchetto siccome ci mette un eternità ci sono accorgimenti da prendere?
sono su Gentoo stable con profilo e compilatore hardened
grazie :D
allego screenshot del problema:
http://i.imgur.com/RXw9faW.png
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Sat Jul 22, 2017 9:06 am    Post subject: Reply with quote

net-libs/webkit-gtk e' un pacchetto slottato, questo vuol dire che puoi avere piu' versioni del pacchetto contemporaneamente.
Infatti nel tuo sistema hai sia la versione 2.4.11-r200 che la 2.16.5. Purtroppo la versione 2.4.11 e affetta dal problema ma probabilmente e' una dipendenza richiesta che puoi controllare con il comando
Code:
$ equery d =net-libs/webkit-gtk-2.4.11-r200

Penso che quindi l'unica soluzione e' di cercare un modo per far si che la versione con il problema non sia piu' una dipendenza
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
oscarandrea
Apprentice
Apprentice


Joined: 27 Nov 2015
Posts: 176
Location: Italy/Cosenza

PostPosted: Sat Jul 22, 2017 12:56 pm    Post subject: Reply with quote

fedeliallalinea wrote:
net-libs/webkit-gtk e' un pacchetto slottato, questo vuol dire che puoi avere piu' versioni del pacchetto contemporaneamente.
Infatti nel tuo sistema hai sia la versione 2.4.11-r200 che la 2.16.5. Purtroppo la versione 2.4.11 e affetta dal problema ma probabilmente e' una dipendenza richiesta che puoi controllare con il comando
Code:
$ equery d =net-libs/webkit-gtk-2.4.11-r200

Penso che quindi l'unica soluzione e' di cercare un modo per far si che la versione con il problema non sia piu' una dipendenza

grazie della risposta, putroppo viene richiesto da questi pacchetti, non credo che il mio sistema ne possa far a meno:
Code:
➜  ~ equery d "=net-libs/webkit-gtk-2.4.11-r200"
 * These packages depend on net-libs/webkit-gtk-2.4.11-r200:
net-libs/libproxy-0.4.13-r2 (webkit ? net-libs/webkit-gtk:4)
x11-libs/wxGTK-3.0.2.0-r2 (webkit ? net-libs/webkit-gtk:2)

credo bisogni attendere che le dipendenze vengano aggiornate, che ne dici? aspetto o trovo altre soluzioni?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Sat Jul 22, 2017 4:51 pm    Post subject: Reply with quote

Bisognera' attende credo, io ho lo stesso problema con il pacchetto media-libs/gstreamer
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
oscarandrea
Apprentice
Apprentice


Joined: 27 Nov 2015
Posts: 176
Location: Italy/Cosenza

PostPosted: Sat Jul 22, 2017 6:14 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Bisognera' attende credo, io ho lo stesso problema con il pacchetto media-libs/gstreamer

va bene aspetterò, grazie :)
Back to top
View user's profile Send private message
oscarandrea
Apprentice
Apprentice


Joined: 27 Nov 2015
Posts: 176
Location: Italy/Cosenza

PostPosted: Wed Aug 09, 2017 11:26 am    Post subject: Reply with quote

sono passati tutti questi giorni ma ancora il sistema è affetto da questa glsa 201706-15
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Wed Aug 09, 2017 11:51 am    Post subject: Reply with quote

oscarandrea wrote:
sono passati tutti questi giorni ma ancora il sistema è affetto da questa glsa 201706-15

Non penso che possa migliorare finche' ci saranno programmi che dipendono da webkit-gtk:3 e webkit-gtk:2.
_________________
Questions are guaranteed in life; Answers aren't.


Last edited by fedeliallalinea on Wed Aug 09, 2017 12:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
oscarandrea
Apprentice
Apprentice


Joined: 27 Nov 2015
Posts: 176
Location: Italy/Cosenza

PostPosted: Wed Aug 09, 2017 12:03 pm    Post subject: Reply with quote

fedeliallalinea wrote:
oscarandrea wrote:
sono passati tutti questi giorni ma ancora il sistema è affetto da questa glsa 201706-15

Non penso che possa migliorare finche' non ci saranno programmi che dipendono da webkit-gtk:3 e webkit-gtk:2.

ho capito, grazie
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Wed Aug 09, 2017 12:05 pm    Post subject: Reply with quote

L'unica cosa che puoi fare e' vedere se esistono patch per quelle particolari versioni, ma dubito se non sarebbe gia' stato fatto upstream
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum