Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plasma on fresh Gentoo Installation [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Thunderfly
n00b
n00b


Joined: 11 Jul 2017
Posts: 25

PostPosted: Mon Jul 17, 2017 8:36 pm    Post subject: Plasma on fresh Gentoo Installation [SOLVED] Reply with quote

after installing Xorg i try to install Plasma-Desktop.

Code:
GentooX /mnt2/BACKUPs # emerge --ask kde-plasma/plasma-meta

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy "media-video/ffmpeg:0=" has unmet requirements.
- media-video/ffmpeg-3.2.4::gentoo USE="X alsa bzip2 encode gpl hardcoded-tables iconv mp3 network opengl postproc sdl threads truetype vorbis x264 xcb xvid zlib (-altivec) -amr -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bluray -bs2b -cdio -celt -chromaprint -cpudetection -debug -doc -ebur128 -fdk -flite -fontconfig -frei0r -fribidi -gcrypt -gme -gmp -gnutls -gsm -iec61883 -ieee1394 -jack -jpeg2k -kvazaar -ladspa -libass -libcaca -libilbc -librtmp -libsoxr -libv4l -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) (-mmal) -modplug (-neon) -nvenc -openal -openh264 -openssl -opus -oss -pic -pulseaudio -rubberband -samba -schroedinger -snappy -speex -ssh -static-libs -test -theora -twolame -v4l -vaapi -vdpau -vpx -wavpack -webp -x265 -zimg -zvbi" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx sse sse2 -3dnow -3dnowext -aes -avx -avx2 -fma3 -fma4 -mmxext -sse3 -sse4_1 -sse4_2 -ssse3 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher"

  The following REQUIRED_USE flag constraints are unsatisfied:
    cpu_flags_x86_sse? ( cpu_flags_x86_mmxext )

  The above constraints are a subset of the following complete expression:
    libv4l? ( v4l ) fftools_cws2fws? ( zlib ) test? ( encode ) postproc? ( gpl ) frei0r? ( gpl ) cdio? ( gpl ) samba? ( gpl ) encode? ( x264? ( gpl ) x265? ( gpl ) xvid? ( gpl ) X? ( !xcb? ( gpl ) ) ) cpu_flags_x86_avx2? ( cpu_flags_x86_avx ) cpu_flags_x86_fma4? ( cpu_flags_x86_avx ) cpu_flags_x86_fma3? ( cpu_flags_x86_avx ) cpu_flags_x86_xop? ( cpu_flags_x86_avx ) cpu_flags_x86_avx? ( cpu_flags_x86_sse4_2 ) cpu_flags_x86_aes? ( cpu_flags_x86_sse4_2 ) cpu_flags_x86_sse4_2? ( cpu_flags_x86_sse4_1 ) cpu_flags_x86_sse4_1? ( cpu_flags_x86_ssse3 ) cpu_flags_x86_ssse3? ( cpu_flags_x86_sse3 ) cpu_flags_x86_sse3? ( cpu_flags_x86_sse2 ) cpu_flags_x86_sse2? ( cpu_flags_x86_sse ) cpu_flags_x86_sse? ( cpu_flags_x86_mmxext ) cpu_flags_x86_mmxext? ( cpu_flags_x86_mmx ) cpu_flags_x86_3dnowext? ( cpu_flags_x86_3dnow ) cpu_flags_x86_3dnow? ( cpu_flags_x86_mmx )

(dependency required by "media-video/vlc-2.2.6::gentoo[swscale,-vdpau,avcodec,-libav,avformat]" [ebuild])
(dependency required by "media-libs/phonon-vlc-0.9.1-r1::gentoo" [ebuild])
(dependency required by "media-libs/phonon-4.9.1-r1::gentoo[vlc]" [ebuild])
(dependency required by "kde-apps/kio-extras-16.12.3-r1::gentoo[phonon]" [ebuild])
(dependency required by "kde-plasma/plasma-workspace-5.9.5.1-r2::gentoo" [ebuild])
(dependency required by "kde-plasma/plasma-desktop-5.9.5::gentoo" [ebuild])
(dependency required by "kde-plasma/plasma-desktop" [argument])
GentooX /mnt2/BACKUPs #



after I comment out "sse" in USE Flags in make.conf
Code:
GentooX /mnt2/BACKUPs # vi /etc/portage/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe"
CXXFLAGS="${CFLAGS}"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"

# These are the USE and USE_EXPAND flags that were used for
# buidling in addition to what is provided by the profile.


USE="bindist bzip2 idm ipv6 mmx -sse mmxext sse2 urandom gtk -gnome -qt4 qt5 kde dvd alsa cdr X"
#CPU_FLAGS_X86="mmx sse2"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"


MAKEOPTS="-j19"
ACCEPT_KEYWORDS="amd64"

GENTOO_MIRRORS="http://mirror.eu.oneandone.net/linux/distributions/gentoo/gentoo/"

#GENTOO_MIRRORS="http://gd.tuwien.ac.at/opsys/linux/gentoo/ ftp://gd.tuwien.ac.at/opsys/linux/gentoo/ rsync://mirror.eu.oneandone.net/gentoo/"

LINGUAS="de en"
L10N="de en"
VIDEO_CARDS="nvidia"
INPUT_DEVICES="evdev"

GRUB_PLATFORMS="efi-64"



I got now:


Code:
GentooX /mnt2/BACKUPs # emerge --ask kde-plasma/plasma-meta

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


 * IMPORTANT: config file '/etc/portage/package.use/iputils' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy "media-video/ffmpeg:0=" has unmet requirements.
- media-video/ffmpeg-3.2.4::gentoo USE="X alsa bzip2 encode gpl hardcoded-tables iconv mp3 network opengl postproc sdl threads truetype vorbis x264 xcb xvid zlib (-altivec) -amr -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bluray -bs2b -cdio -celt -chromaprint -cpudetection -debug -doc -ebur128 -fdk -flite -fontconfig -frei0r -fribidi -gcrypt -gme -gmp -gnutls -gsm -iec61883 -ieee1394 -jack -jpeg2k -kvazaar -ladspa -libass -libcaca -libilbc -librtmp -libsoxr -libv4l -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) (-mmal) -modplug (-neon) -nvenc -openal -openh264 -openssl -opus -oss -pic -pulseaudio -rubberband -samba -schroedinger -snappy -speex -ssh -static-libs -test -theora -twolame -v4l -vaapi -vdpau -vpx -wavpack -webp -x265 -zimg -zvbi" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx sse2 -3dnow -3dnowext -aes -avx -avx2 -fma3 -fma4 -mmxext -sse -sse3 -sse4_1 -sse4_2 -ssse3 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher"

  The following REQUIRED_USE flag constraints are unsatisfied:
    cpu_flags_x86_sse2? ( cpu_flags_x86_sse )

  The above constraints are a subset of the following complete expression:
    libv4l? ( v4l ) fftools_cws2fws? ( zlib ) test? ( encode ) postproc? ( gpl ) frei0r? ( gpl ) cdio? ( gpl ) samba? ( gpl ) encode? ( x264? ( gpl ) x265? ( gpl ) xvid? ( gpl ) X? ( !xcb? ( gpl ) ) ) cpu_flags_x86_avx2? ( cpu_flags_x86_avx ) cpu_flags_x86_fma4? ( cpu_flags_x86_avx ) cpu_flags_x86_fma3? ( cpu_flags_x86_avx ) cpu_flags_x86_xop? ( cpu_flags_x86_avx ) cpu_flags_x86_avx? ( cpu_flags_x86_sse4_2 ) cpu_flags_x86_aes? ( cpu_flags_x86_sse4_2 ) cpu_flags_x86_sse4_2? ( cpu_flags_x86_sse4_1 ) cpu_flags_x86_sse4_1? ( cpu_flags_x86_ssse3 ) cpu_flags_x86_ssse3? ( cpu_flags_x86_sse3 ) cpu_flags_x86_sse3? ( cpu_flags_x86_sse2 ) cpu_flags_x86_sse2? ( cpu_flags_x86_sse ) cpu_flags_x86_sse? ( cpu_flags_x86_mmxext ) cpu_flags_x86_mmxext? ( cpu_flags_x86_mmx ) cpu_flags_x86_3dnowext? ( cpu_flags_x86_3dnow ) cpu_flags_x86_3dnow? ( cpu_flags_x86_mmx )

(dependency required by "media-video/vlc-2.2.6::gentoo[-libav,avformat,swscale,avcodec,-vdpau]" [ebuild])
(dependency required by "media-libs/phonon-vlc-0.9.1-r1::gentoo" [ebuild])
(dependency required by "media-libs/phonon-4.9.1-r1::gentoo[vlc]" [ebuild])
(dependency required by "kde-frameworks/knotifications-5.34.0::gentoo" [ebuild])
(dependency required by "kde-frameworks/kio-5.34.0-r2::gentoo" [ebuild])
(dependency required by "kde-frameworks/kdeclarative-5.34.0::gentoo" [ebuild])
(dependency required by "kde-frameworks/kcmutils-5.34.0::gentoo" [ebuild])
(dependency required by "kde-plasma/breeze-5.9.5::gentoo" [ebuild])
(dependency required by "kde-plasma/plasma-meta-5.9.5::gentoo" [ebuild])
(dependency required by "kde-plasma/plasma-meta" [argument])
GentooX /mnt2/BACKUPs # vi /etc/portage/make.conf
GentooX /mnt2/BACKUPs # emerge --ask kde-plasma/plasma-meta

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


 * IMPORTANT: config file '/etc/portage/package.use/iputils' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-power/pm-quirks-20100619
[ebuild  N     ] dev-libs/libx86-1.1-r3  USE="-static-libs"
[ebuild  N     ] media-libs/libdvbpsi-1.3.0-r1  USE="-doc -static-libs"
[ebuild  N     ] dev-util/boost-build-1.62.0-r1  USE="-examples -python {-test}" PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-libs/xapian-1.4.4  USE="chert glass inmemory -doc -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse sse2"
[ebuild  N     ] dev-db/lmdb-0.9.18  USE="-static-libs"
[ebuild  N     ] sys-apps/tcp-wrappers-7.6.22-r1  USE="ipv6 -netgroups -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-libs/libutempter-1.1.6-r2  USE="-static-libs"
[ebuild  N     ] net-wireless/wireless-regdb-20170307
[ebuild  N     ] net-dialup/ppp-scripts-0
[ebuild  N     ] media-libs/libogg-1.3.2  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/libyaml-0.1.7  USE="-doc -examples -static-libs {-test}"
[ebuild  N     ] media-libs/libdvdcss-1.3.0  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/giflib-5.1.4  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-libs/libunwind-1.1-r1  USE="-debug -debug-frame -libatomic -lzma -static-libs"
[ebuild  N     ] dev-util/google-perftools-2.0-r2  USE="debug -largepages -minimal -static-libs {-test}"
[ebuild  N     ] sys-libs/mtdev-1.1.5  USE="-static-libs"
[ebuild  N     ] dev-libs/libnl-3.2.28  USE="-python -static-libs -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5)"
[ebuild  N     ] media-fonts/dejavu-2.35  USE="X -fontforge"
[ebuild  N     ] media-fonts/hack-2.020  USE="X"
[ebuild  N     ] media-fonts/noto-20160531  USE="X -cjk"
[ebuild  N     ] app-dicts/myspell-de-2015.12.28
[ebuild  N     ] app-dicts/myspell-en-20170101
[ebuild   R    ] sys-libs/zlib-1.2.11  ABI_X86="32*"
[ebuild  N     ] media-libs/alsa-lib-1.1.2  USE="-alisp -debug -doc -python" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7"
[ebuild  N     ] media-libs/libdvdread-5.0.3  USE="css -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/a52dec-0.7.4-r7  USE="-djbfft -oss -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libdca-0.0.5-r3  USE="-debug -oss -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libmad-0.15.1b-r8  USE="-debug -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/jansson-2.9  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-util/ragel-6.7-r1  USE="-vim-syntax"
[ebuild  N     ] app-arch/snappy-1.1.3-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/boost-1.62.0-r1  USE="nls threads -context -debug -doc -icu -mpi -python -static-libs -tools" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5)"
[ebuild  N     ] dev-libs/leveldb-1.18-r1  USE="snappy tcmalloc -static-libs"
[ebuild  N     ] x11-base/xorg-drivers-1.19  INPUT_DEVICES="evdev -acecad -aiptek -elographics -fpit -hyperpen -joystick -keyboard -libinput -mouse -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="nvidia -amdgpu -apm -ark -ast -chips -cirrus -dummy -epson -fbdev (-fglrx) (-freedreno) (-geode) -glint -i128 (-i740) -i915 -i965 -intel -mach64 -mga -neomagic (-newport) -nouveau -nv (-omap) -qxl -r128 -radeon -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx (-tegra) -tga -trident -tseng (-vc4) -vesa -via -virtualbox -vmware (-voodoo)"
[ebuild  N     ] app-eselect/eselect-opencl-1.1.0-r1
[ebuild  N     ] app-eselect/eselect-ruby-20161226
[ebuild  N     ] app-eselect/eselect-lib-bin-symlink-0.1.1
[ebuild  N     ] app-eselect/eselect-notify-send-0.1
[ebuild  N     ] net-misc/socat-1.7.3.1  USE="ipv6 readline ssl tcpd"
[ebuild  N     ] virtual/linux-sources-3  USE="-firmware"
[ebuild  N     ] dev-lang/yasm-1.3.0  USE="nls -python" PYTHON_TARGETS="python2_7"
[ebuild  N     ] media-libs/x264-0.0.20160712  USE="interlaced threads -10bit (-altivec) -opencl -pic -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse"
[ebuild  N     ] app-text/hunspell-1.6.1-r1  USE="ncurses nls readline -static-libs" L10N="de en -af -bg -ca -cs -cy -da -de-1901 -el -eo -es -et -fo -fr -ga -gl -he -hr -hu -ia -id -is -it -km -ku -lt -lv -mi -mk -ms -nb -nl -nn -pl -pt -pt-BR -ro -ru -sk -sl -sq -sv -sw -tn -uk -zu"
[ebuild  N     ] app-text/iso-codes-3.74  LINGUAS="de en -af -am -ar -as -ast -az -be -bg -bn -bn_IN -br -bs -byn -ca -crh -cs -cy -da -dz -el -eo -es -et -eu -fa -fi -fo -fr -ga -gez -gl -gu -haw -he -hi -hr -hu -hy -ia -id -is -it -ja -ka -kk -km -kn -ko -kok -ku -lt -lv -mi -mk -ml -mn -mr -ms -mt -nb -ne -nl -nn -nso -oc -or -pa -pl -ps -pt -pt_BR -ro -ru -rw -si -sk -sl -so -sq -sr -sr@latin -sv -sw -ta -te -th -ti -tig -tk -tl -tr -tt -tt@iqtelif -ug -uk -ve -vi -wa -wal -wo -xh -zh_CN -zh_HK -zh_TW -zu"
[ebuild  N     ] dev-lang/swig-3.0.12  USE="pcre -ccache -doc"
[ebuild  N     ] sys-libs/slang-2.3.0  USE="pcre png readline zlib -cjk -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/newt-0.52.15  USE="gpm nls -tcl" PYTHON_TARGETS="python2_7"
[ebuild  N     ] media-libs/xvid-1.3.3  USE="threads -examples -pic" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-python/m2crypto-0.24.0  USE="(-libressl)" PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-lang/ruby-2.2.6  USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -jemalloc (-libressl) -rubytests -socks5 -tk -xemacs"
[ebuild  N     ] dev-lang/ruby-2.1.9  USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -xemacs"
[ebuild  N     ] dev-ruby/rubygems-2.5.2  USE="-server {-test}" RUBY_TARGETS="ruby21 ruby22 (-ruby23)"
[ebuild  N     ] virtual/rubygems-11  RUBY_TARGETS="ruby21 ruby22 (-rbx) (-ruby23)"
[ebuild  N     ] dev-ruby/power_assert-0.3.1  USE="-doc {-test}" RUBY_TARGETS="ruby21 ruby22 (-ruby23)"
[ebuild  N     ] dev-ruby/rake-10.5.0  USE="-doc {-test}" RUBY_TARGETS="ruby21 ruby22 (-ruby23)"
[ebuild  N     ] dev-ruby/json-1.8.3  USE="-doc {-test}" RUBY_TARGETS="ruby21 ruby22 (-ruby23)"
[ebuild  N     ] dev-ruby/minitest-5.8.4  USE="-doc {-test}" RUBY_TARGETS="ruby21 ruby22 (-ruby23)"
[ebuild  N     ] dev-ruby/test-unit-3.1.9  USE="-doc {-test}" RUBY_TARGETS="ruby21 ruby22 (-ruby23)"
[ebuild  N     ] dev-ruby/racc-1.4.11  USE="-doc {-test}" RUBY_TARGETS="ruby21 ruby22"
[ebuild  N     ] dev-ruby/rdoc-4.2.0  USE="-doc {-test}" RUBY_TARGETS="ruby21 ruby22"
[ebuild  N     ] dev-libs/libevdev-1.5.7  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] x11-proto/xproto-7.0.31  ABI_X86="32*"
[ebuild   R    ] x11-proto/xextproto-7.3.0  ABI_X86="32*"
[ebuild   R    ] x11-proto/kbproto-1.0.7  ABI_X86="32*"
[ebuild   R    ] dev-libs/libpthread-stubs-0.4  ABI_X86="32*"
[ebuild   R    ] x11-proto/xcb-proto-1.12-r2  ABI_X86="32*"
[ebuild   R    ] x11-proto/inputproto-2.3.2  ABI_X86="32*"
[ebuild   R    ] x11-proto/xf86bigfontproto-1.2.0-r1  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXdmcp-1.1.2-r1  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXau-1.0.8  ABI_X86="32*"
[ebuild   R    ] x11-libs/libxcb-1.12-r2  ABI_X86="32*"
[ebuild   R    ] x11-libs/libX11-1.6.5  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXext-1.3.3  ABI_X86="32*"
[ebuild  N     ] x11-libs/libvdpau-1.1.1  USE="dri -doc {-test}" ABI_X86="32 (64) (-x32)"
[ebuild  NS    ] dev-qt/qtsql-5.7.1 [4.8.7-r1] USE="mysql sqlite -debug -freetds -oci8 -odbc -postgres {-test}"
[ebuild  N     ] dev-qt/qtconcurrent-5.7.1  USE="-debug {-test}"
[ebuild  N     ] x11-libs/libxkbfile-1.0.9  USE="-static-libs"
[ebuild  N     ] media-libs/libsamplerate-0.1.9  USE="-sndfile -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libvorbis-1.3.5  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/flac-1.3.2-r1  USE="cxx ogg (-altivec) -debug -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse"
[ebuild  N     ] x11-proto/scrnsaverproto-1.2.2-r1  USE="-doc" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-libs/libXScrnSaver-1.2.2-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-proto/fontsproto-2.1.3  USE="-doc"
[ebuild  N     ] x11-proto/resourceproto-1.2.0
[ebuild  N     ] x11-misc/xkeyboard-config-2.20
[ebuild  N     ] x11-misc/xbitmaps-1.1.1-r1
[ebuild  N     ] x11-apps/xrdb-1.1.0
[ebuild  N     ] media-libs/glu-9.0.0-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] virtual/glu-9.0-r1  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-apps/vbetool-1.1
[ebuild  N     ] media-sound/alsa-utils-1.1.2  USE="libsamplerate ncurses nls -bat -doc (-selinux)"
[ebuild  N     ] media-libs/libdvdnav-5.0.3  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/audiofile-0.3.6-r3  USE="flac -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libsdl-1.2.15-r9  USE="X alsa joystick opengl sound video xinerama xv -aalib -custom-cflags -dga -fbcon -libcaca -nas -oss -pulseaudio -static-libs -tslib" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libmpeg2-0.5.1-r2  USE="X sdl -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-sound/lame-3.99.5-r1  USE="frontend -debug -mp3rtp -sndfile -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(-mmx)"
[ebuild  NS    ] app-text/docbook-xml-dtd-4.3-r1 [4.1.2-r6, 4.2-r2, 4.4-r2, 4.5-r1]
[ebuild  N     ] gnome-base/gsettings-desktop-schemas-3.22.0  USE="introspection"
[ebuild  N     ] x11-themes/gnome-themes-standard-3.22.3
[ebuild  N     ] dev-libs/libatasmart-0.19-r1  USE="-static-libs"
[ebuild  N     ] sys-block/parted-3.2  USE="debug nls readline -device-mapper (-selinux) -static-libs"
[ebuild  N     ] x11-apps/xinit-1.3.4-r1  USE="minimal -systemd"
[ebuild  N     ] x11-proto/xf86dgaproto-2.1-r2  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-proto/trapproto-3.4.3
[ebuild  N     ] x11-proto/xcmiscproto-1.2.2  USE="-doc"
[ebuild  N     ] x11-apps/xkbcomp-1.4.0
[ebuild  N     ] x11-proto/xf86rushproto-1.1.2-r1
[ebuild  N     ] x11-libs/libXfont2-2.0.1  USE="bzip2 ipv6 truetype -doc -static-libs"
[ebuild  N     ] x11-apps/rgb-1.0.6
[ebuild  N     ] x11-apps/iceauth-1.0.7
[ebuild  N     ] x11-proto/bigreqsproto-1.1.2  USE="-doc"
[ebuild  N     ] x11-base/xorg-server-1.19.3  USE="glamor ipv6 suid udev xorg -debug -dmx -doc -kdrive (-libressl) -minimal (-selinux) -static-libs -systemd -tslib -unwind -wayland -xcsecurity -xephyr -xnest -xvfb"
[ebuild  N     ] x11-drivers/xf86-input-evdev-2.10.5
[ebuild  N     ] x11-libs/libXres-1.0.7  USE="-static-libs"
[ebuild  N     ] x11-apps/setxkbmap-1.3.1
[ebuild  N     ] dev-libs/libinput-1.7.3  USE="{-test}" INPUT_DEVICES="-wacom"
[ebuild  N     ] x11-apps/xsetroot-1.1.1
[ebuild  N     ] dev-qt/qtpaths-5.7.1  USE="-debug {-test}"
[ebuild  N     ] dev-libs/libpwquality-1.3.0  USE="pam -python -static-libs" PYTHON_TARGETS="python2_7 python3_4 (-python3_5) (-python3_6)"
[ebuild  N     ] virtual/eject-0
[ebuild  N     ] dev-libs/libgudev-231  USE="introspection -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] virtual/libgudev-230  USE="introspection -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-libs/libndp-1.6-r1  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/nss-3.29.5  USE="nss-pem -cacert -utils" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-wireless/crda-3.18-r1  USE="-gcrypt (-libressl)"
[ebuild  N     ] net-libs/libmbim-1.14.0  USE="udev -static-libs"
[ebuild  N     ] net-libs/libqmi-1.16.2  USE="mbim -doc -static-libs"
[ebuild  N     ] x11-apps/xmessage-1.0.4
[ebuild  N     ] dev-libs/dbus-glib-0.108  USE="-debug -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-power/upower-0.99.4  USE="introspection -doc -ios (-selinux)"
[ebuild  N     ] sys-power/pm-utils-1.4.1-r7  USE="alsa -debug -ntp" VIDEO_CARDS="-intel -radeon"
[ebuild  N     ] media-libs/libsdl2-2.0.4  USE="X alsa dbus joystick opengl sound threads udev video xinerama xscreensaver (-altivec) (-custom-cflags) (-fusionsound) -gles -haptic -nas -oss -pulseaudio -static-libs -tslib -wayland" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx sse sse2 -3dnow"
[ebuild  N     ] media-video/ffmpeg-3.2.4  USE="X alsa bzip2 encode gpl hardcoded-tables iconv mp3 network opengl postproc sdl threads truetype vorbis x264 xcb xvid zlib (-altivec) -amr -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bluray -bs2b -cdio -celt -chromaprint -cpudetection -debug -doc -ebur128 -fdk -flite -fontconfig -frei0r -fribidi -gcrypt -gme -gmp -gnutls -gsm -iec61883 -ieee1394 -jack -jpeg2k -kvazaar -ladspa -libass -libcaca -libilbc -librtmp -libsoxr -libv4l -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) (-mmal) -modplug (-neon) -nvenc -openal -openh264 -openssl -opus -oss -pic -pulseaudio -rubberband -samba -schroedinger -snappy -speex -ssh -static-libs {-test} -theora -twolame -v4l -vaapi -vdpau -vpx -wavpack -webp -x265 -zimg -zvbi" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx mmxext sse sse2 -3dnow -3dnowext -aes -avx -avx2 -fma3 -fma4 -sse3 -sse4_1 -sse4_2 -ssse3 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher"
[ebuild  N     ] dev-qt/qdbus-5.7.1  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kservice-5.34.0  USE="man -debug {-test}"
[ebuild  N     ] kde-frameworks/kcompletion-5.34.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kglobalaccel-5.34.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kpackage-5.34.0  USE="-debug -man {-test}"
[ebuild  N     ] kde-frameworks/kjobwidgets-5.34.0  USE="X nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kidletime-5.34.0  USE="-debug"
[ebuild  N     ] dev-qt/qtprintsupport-5.7.1  USE="cups -debug -gles2 {-test}"
[ebuild  N     ] kde-frameworks/sonnet-5.34.0  USE="hunspell nls -aspell -debug {-test}"
[ebuild  N     ] dev-qt/designer-5.7.1  USE="declarative -debug {-test} -webkit"
[ebuild  N     ] kde-plasma/kdecoration-5.9.5  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kitemmodels-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kjs-5.34.0  USE="-debug {-test}"
[ebuild  N     ] dev-qt/qtgraphicaleffects-5.7.1  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kpty-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/bluez-qt-5.34.0-r1  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kunitconversion-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kemoticons-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/attica-5.34.0  USE="-debug {-test}"
[ebuild  N     ] dev-qt/qtquickcontrols-5.7.1  USE="widgets -debug {-test}"
[ebuild  N     ] media-gfx/exiv2-0.25-r2  USE="nls png xmp -doc -examples -webready" ABI_X86="(64) -32 (-x32)" LINGUAS="de -bs -es -fi -fr -gl -ms -pl -pt -ru -sk -sv -ug -uk -vi"
[ebuild  N     ] kde-frameworks/kdesu-5.34.0  USE="X -debug"
[ebuild  N     ] kde-plasma/kwallet-pam-5.9.5-r1  USE="-debug"
[ebuild  N     ] kde-plasma/breeze-gtk-5.9.5  USE="-debug"
[ebuild  N     ] kde-plasma/plasma-workspace-wallpapers-5.9.5
[ebuild  N     ] kde-frameworks/kdesignerplugin-5.34.0  USE="nls -debug -designer -webkit"
[ebuild  N     ] dev-libs/libdbusmenu-qt-0.9.3_pre20160218  USE="qt5 -debug -qt4 {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-qt/qtwayland-5.7.1  USE="egl xcomposite -debug {-test}"
[ebuild  N     ] kde-frameworks/kwayland-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/libkscreen-5.9.5  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/kwayland-integration-5.9.5  USE="-debug"
[ebuild  N     ] kde-frameworks/breeze-icons-5.34.0  USE="{-test}"
[ebuild  N     ] kde-frameworks/threadweaver-5.34.0  USE="-debug {-test}"
[ebuild  N     ] dev-libs/grantlee-5.1.0  USE="-debug -doc {-test}"
[ebuild  N     ] dev-qt/qtopengl-5.7.1  USE="-debug -gles2 {-test}"
[ebuild  N     ] dev-qt/qtwebkit-5.7.1  USE="jit opengl qml -debug -geolocation -gstreamer -gstreamer010 -multimedia -orientation -printsupport {-test} -webchannel -webp"
[ebuild  N     ] kde-frameworks/kpeople-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kjsembed-5.34.0  USE="-debug"
[ebuild  N     ] kde-apps/kholidays-16.12.3  USE="-debug {-test}"
[ebuild  N     ] net-libs/libssh-0.7.4  USE="sftp zlib -debug -doc -examples -gcrypt -gssapi (-libressl) -pcap -server -ssh1 -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] kde-frameworks/kdnssd-5.34.0  USE="nls -debug {-test} -zeroconf"
[ebuild  N     ] kde-frameworks/syntax-highlighting-5.34.0  USE="nls -debug {-test}"
[ebuild  N     ] net-wireless/wpa_supplicant-2.6-r1  USE="dbus hs2-0 qt5 readline ssl -ap -eap-sim -fasteap -gnutls (-libressl) -p2p (-ps3) (-selinux) -smartcard -tdls -uncommon-eap-types (-wimax) -wps"
[ebuild  N     ] net-libs/libproxy-0.4.13-r2  USE="kde -gnome -mono -networkmanager -perl -python -spidermonkey {-test} -webkit" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7"
[ebuild  N     ] net-libs/glib-networking-2.50.0  USE="libproxy ssl -gnome -smartcard {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-libs/libsoup-2.56.0  USE="introspection ssl -debug -gssapi -samba {-test} -vala" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/libical-2.0.0-r2  USE="-doc -examples -static-libs"
[ebuild  N     ] net-wireless/bluez-5.43-r1  USE="cups obex readline udev -debug -deprecated -doc -experimental -extra-tools (-selinux) -systemd {-test} -test-programs -user-session" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7"
[ebuild  NS    ] x11-libs/gtk+-2.24.31-r1 [3.22.16] USE="cups introspection xinerama (-aqua) -examples {-test} -vim-syntax" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-drivers/nvidia-drivers-381.22  USE="X acpi driver kms multilib tools -compat -gtk3 -pax_kernel -static-libs -uvm -wayland" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] x11-themes/gtk-engines-adwaita-3.22.3  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-dialup/ppp-2.4.7-r3  USE="gtk ipv6 pam -activefilter -atm -dhcp -eap-tls (-libressl) -radius"
[ebuild  N     ] kde-frameworks/kfilemetadata-5.34.0  USE="exif pdf -debug -epub -ffmpeg -libav -office -taglib {-test}"
[ebuild  N     ] media-libs/phonon-4.9.1-r1  USE="designer qt5 vlc (-aqua) -debug -gstreamer -pulseaudio -qt4 (-zeitgeist)" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] kde-frameworks/knotifications-5.34.0  USE="X dbus nls -debug (-speech)"
[ebuild  N     ] kde-plasma/kwrited-5.9.5  USE="-debug"
[ebuild  N     ] x11-libs/libnotify-0.7.7  USE="introspection {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-video/vlc-2.2.6  USE="X a52 alsa avcodec avformat cdda dbus dts dvbpsi dvd encode ffmpeg flac gcrypt jpeg kde libnotify libsamplerate mp3 mpeg ncurses ogg opengl png qt5 sdl svg swscale truetype udev vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -bidi -bluray -cddb -chromaprint -dc1394 -debug -directfb (-directx) -dvb (-dxva2) -faad -fdk -fluidsynth -fontconfig -gme -gnome -gnutls -growl -gstreamer -httpd -ieee1394 -jack -kate -libass -libav -libcaca -libtar -libtiger -linsys -lirc -live -lua (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) -matroska -modplug -mtp -musepack (-neon) -omxil -opencv -optimisememory -opus -postproc -projectm -pulseaudio -qt4 -rdp -rtsp -run-as-root -samba -schroedinger -sdl-image -sftp -shout -sid -skins -speex -taglib {-test} -theora -tremor -twolame -upnp -v4l -vaapi -vcdx -vdpau -vlm -vnc -vpx -wma-fixed -x265 -zeroconf -zvbi" CPU_FLAGS_X86="mmx sse"
[ebuild  N     ] media-libs/phonon-vlc-0.9.1-r1  USE="qt5 -debug -qt4"
[ebuild  N     ] x11-misc/sddm-0.14.0-r2  USE="consolekit pam -systemd"
[ebuild  N     ] sys-auth/polkit-pkla-compat-0.1
[ebuild  N     ] sys-fs/udisks-2.1.8  USE="acl gptfdisk introspection -cryptsetup -debug (-selinux) -systemd"
[ebuild  N     ] kde-frameworks/solid-5.34.0  USE="nls -debug {-test}"
[ebuild  N     ] sys-apps/accountsservice-0.6.43-r1  USE="introspection -doc (-elogind) (-selinux) -systemd"
[ebuild  N     ] net-misc/modemmanager-1.6.4  USE="introspection (policykit) qmi -mbim -systemd -vala"
[ebuild  N     ] net-misc/networkmanager-1.4.4-r1  USE="bluetooth consolekit dhclient introspection modemmanager ncurses nss ppp wext wifi -audit -connection-sharing -gnutls -json -ofono -resolvconf (-selinux) -systemd -teamd {-test} -vala" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] kde-frameworks/networkmanager-qt-5.34.0  USE="-debug -teamd {-test}"
[ebuild  N     ] kde-frameworks/ktextwidgets-5.34.0  USE="-debug (-speech) {-test}"
[ebuild  N     ] kde-frameworks/kxmlgui-5.34.0  USE="-attica -debug {-test}"
[ebuild  N     ] kde-frameworks/kbookmarks-5.34.0  USE="nls -debug {-test}"
[ebuild  N     ] kde-frameworks/kwallet-5.34.0-r1  USE="man -debug -gpg {-test}"
[ebuild  N     ] kde-plasma/kgamma-5.9.5  USE="handbook -debug"
[ebuild  N     ] kde-plasma/ksshaskpass-5.9.5  USE="-debug"
[ebuild  N     ] kde-frameworks/kio-5.34.0-r2  USE="X acl handbook kwallet -debug -kerberos {-test}"
[ebuild  N     ] kde-frameworks/kinit-5.34.0  USE="caps man -debug"
[ebuild  N     ] kde-frameworks/kded-5.34.0  USE="man -debug"
[ebuild  N     ] kde-frameworks/kdeclarative-5.34.0  USE="-debug"
[ebuild  N     ] kde-frameworks/kcmutils-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/kde-cli-tools-5.9.5-r1  USE="X handbook kdesu -debug {-test}"
[ebuild  N     ] kde-frameworks/knewstuff-5.34.0  USE="-debug"
[ebuild  N     ] kde-frameworks/kparts-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kdelibs4support-5.34.0  USE="X -debug (-libressl) {-test}"
[ebuild  N     ] kde-plasma/kscreenlocker-5.9.5  USE="pam -debug {-test}"
[ebuild  N     ] kde-frameworks/knotifyconfig-5.34.0  USE="phonon -debug"
[ebuild  N     ] kde-plasma/kde-gtk-config-5.9.5  USE="gtk3 -debug {-test}"
[ebuild  N     ] kde-plasma/kactivitymanagerd-5.9.5  USE="-debug"
[ebuild  N     ] kde-frameworks/kactivities-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/plasma-5.34.0  USE="X -debug -gles2 {-test} -wayland"
[ebuild  N     ] kde-frameworks/krunner-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/libksysguard-5.9.5  USE="X detailedmemory -debug -minimal {-test}"
[ebuild  N     ] kde-plasma/ksysguard-5.9.5  USE="handbook -debug -lm_sensors"
[ebuild  N     ] kde-plasma/milou-5.9.5  USE="-debug"
[ebuild  N     ] kde-frameworks/frameworkintegration-5.34.0  USE="X -appstream -debug {-test}"
[ebuild  N     ] kde-plasma/breeze-5.9.5  USE="-debug -qt4 -wayland"
[ebuild  N     ] kde-plasma/kwin-5.9.5  USE="handbook -debug -gles2 -multimedia {-test}"
[ebuild  N     ] kde-plasma/plasma-integration-5.9.5  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/oxygen-5.9.5-r1  USE="-debug -qt4 -wayland"
[ebuild  N     ] kde-frameworks/khtml-5.34.0  USE="X -debug (-libressl) {-test}"
[ebuild  N     ] kde-frameworks/baloo-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/kinfocenter-5.9.5  USE="handbook opengl pci -debug -gles2 -ieee1394 -wayland"
[ebuild  N     ] kde-plasma/user-manager-5.9.5  USE="-debug"
[ebuild  N     ] kde-plasma/kscreen-5.9.5  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/bluedevil-5.9.5  USE="-debug"
[ebuild  N     ] kde-apps/khelpcenter-16.12.3  USE="handbook -debug"
[ebuild  N     ] kde-plasma/sddm-kcm-5.9.5  USE="-debug"
[ebuild  N     ] kde-plasma/systemsettings-5.9.5  USE="gtk handbook -classic -debug"
[ebuild  N     ] kde-frameworks/kross-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kactivities-stats-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kxmlrpcclient-5.34.0  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/ktexteditor-5.34.0  USE="-debug -editorconfig -git {-test}"
[ebuild  N     ] kde-apps/kio-extras-16.12.3-r1  USE="exif handbook man phonon sftp -activities -debug -mtp -openexr -samba -slp {-test}"
[ebuild  N     ] kde-plasma/plasma-workspace-5.9.5.1-r2  USE="calendar handbook semantic-desktop -debug -geolocation -gps -prison -qalculate {-test}"
[ebuild  N     ] virtual/notification-daemon-0  USE="kde -gnome"
[ebuild  N     ] kde-plasma/khotkeys-5.9.5  USE="handbook -debug"
[ebuild  N     ] kde-plasma/plasma-desktop-5.9.5  USE="fontconfig handbook semantic-desktop -appstream -debug -gtk2 -gtk3 -ibus -legacy-systray -pulseaudio -qt4 -scim {-test}" INPUT_DEVICES="evdev -synaptics"
[ebuild  N     ] kde-plasma/kdeplasma-addons-5.9.5  USE="-debug -share"
[ebuild  N     ] kde-plasma/powerdevil-5.9.5  USE="consolekit handbook wireless -debug"
[ebuild  N     ] kde-plasma/kmenuedit-5.9.5  USE="handbook hotkeys -debug"
[ebuild  N     ] kde-plasma/plasma-meta-5.9.5  USE="bluetooth display-manager gtk handbook pam sddm wallpapers -grub -networkmanager -plymouth -pulseaudio -sdk"

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by x11-libs/libxcb-1.12-r2::gentoo
# required by kde-plasma/libkscreen-5.9.5::gentoo
# required by kde-plasma/kscreen-5.9.5::gentoo
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=x11-libs/libXau-1.0.8 abi_x86_32
# required by x11-libs/libX11-1.6.5::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo
# required by x11-drivers/nvidia-drivers-381.22::gentoo[X]
# required by x11-base/xorg-drivers-1.19::gentoo[video_cards_nvidia]
# required by x11-base/xorg-server-1.19.3::gentoo[xorg]
# required by x11-drivers/xf86-input-evdev-2.10.5::gentoo
# required by kde-plasma/plasma-desktop-5.9.5::gentoo[input_devices_evdev]
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=x11-proto/kbproto-1.0.7 abi_x86_32
# required by x11-libs/libxcb-1.12-r2::gentoo
# required by kde-plasma/libkscreen-5.9.5::gentoo
# required by kde-plasma/kscreen-5.9.5::gentoo
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=x11-libs/libXdmcp-1.1.2-r1 abi_x86_32
# required by x11-drivers/nvidia-drivers-381.22::gentoo[X]
# required by x11-base/xorg-drivers-1.19::gentoo[video_cards_nvidia]
# required by x11-base/xorg-server-1.19.3::gentoo[xorg]
# required by x11-drivers/xf86-input-evdev-2.10.5::gentoo
# required by kde-plasma/plasma-desktop-5.9.5::gentoo[input_devices_evdev]
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=x11-libs/libXext-1.3.3 abi_x86_32
# required by x11-libs/libXext-1.3.3::gentoo
# required by x11-drivers/nvidia-drivers-381.22::gentoo[tools]
# required by x11-base/xorg-drivers-1.19::gentoo[video_cards_nvidia]
# required by x11-base/xorg-server-1.19.3::gentoo[xorg]
# required by x11-drivers/xf86-input-evdev-2.10.5::gentoo
# required by kde-plasma/plasma-desktop-5.9.5::gentoo[input_devices_evdev]
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=x11-proto/xextproto-7.3.0 abi_x86_32
# required by x11-drivers/nvidia-drivers-381.22::gentoo[X]
# required by x11-base/xorg-drivers-1.19::gentoo[video_cards_nvidia]
# required by x11-base/xorg-server-1.19.3::gentoo[xorg]
# required by x11-drivers/xf86-input-evdev-2.10.5::gentoo
# required by kde-plasma/plasma-desktop-5.9.5::gentoo[input_devices_evdev]
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=sys-libs/zlib-1.2.11 abi_x86_32
# required by x11-libs/libX11-1.6.5::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo
# required by x11-drivers/nvidia-drivers-381.22::gentoo[X]
# required by x11-base/xorg-drivers-1.19::gentoo[video_cards_nvidia]
# required by x11-base/xorg-server-1.19.3::gentoo[xorg]
# required by x11-drivers/xf86-input-evdev-2.10.5::gentoo
# required by kde-plasma/plasma-desktop-5.9.5::gentoo[input_devices_evdev]
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=x11-libs/libxcb-1.12-r2 abi_x86_32
# required by x11-libs/libX11-1.6.5::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo
# required by x11-drivers/nvidia-drivers-381.22::gentoo[X]
# required by x11-base/xorg-drivers-1.19::gentoo[video_cards_nvidia]
# required by x11-base/xorg-server-1.19.3::gentoo[xorg]
# required by x11-drivers/xf86-input-evdev-2.10.5::gentoo
# required by kde-plasma/plasma-desktop-5.9.5::gentoo[input_devices_evdev]
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=x11-proto/inputproto-2.3.2 abi_x86_32
# required by x11-libs/libXau-1.0.8::gentoo
# required by x11-libs/libxcb-1.12-r2::gentoo
# required by kde-plasma/libkscreen-5.9.5::gentoo
# required by kde-plasma/kscreen-5.9.5::gentoo
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=x11-proto/xproto-7.0.31 abi_x86_32
# required by x11-libs/libxcb-1.12-r2::gentoo
# required by kde-plasma/libkscreen-5.9.5::gentoo
# required by kde-plasma/kscreen-5.9.5::gentoo
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=dev-libs/libpthread-stubs-0.4 abi_x86_32
# required by x11-libs/libxcb-1.12-r2::gentoo
# required by kde-plasma/libkscreen-5.9.5::gentoo
# required by kde-plasma/kscreen-5.9.5::gentoo
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=x11-proto/xcb-proto-1.12-r2 abi_x86_32
# required by x11-libs/libXext-1.3.3::gentoo
# required by x11-drivers/nvidia-drivers-381.22::gentoo[tools]
# required by x11-base/xorg-drivers-1.19::gentoo[video_cards_nvidia]
# required by x11-base/xorg-server-1.19.3::gentoo[xorg]
# required by x11-drivers/xf86-input-evdev-2.10.5::gentoo
# required by kde-plasma/plasma-desktop-5.9.5::gentoo[input_devices_evdev]
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=x11-libs/libX11-1.6.5 abi_x86_32
# required by x11-drivers/nvidia-drivers-381.22::gentoo[X]
# required by x11-base/xorg-drivers-1.19::gentoo[video_cards_nvidia]
# required by x11-base/xorg-server-1.19.3::gentoo[xorg]
# required by x11-drivers/xf86-input-evdev-2.10.5::gentoo
# required by kde-plasma/plasma-desktop-5.9.5::gentoo[input_devices_evdev]
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=x11-libs/libvdpau-1.1.1 abi_x86_32
# required by x11-libs/libX11-1.6.5::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo
# required by x11-drivers/nvidia-drivers-381.22::gentoo[X]
# required by x11-base/xorg-drivers-1.19::gentoo[video_cards_nvidia]
# required by x11-base/xorg-server-1.19.3::gentoo[xorg]
# required by x11-drivers/xf86-input-evdev-2.10.5::gentoo
# required by kde-plasma/plasma-desktop-5.9.5::gentoo[input_devices_evdev]
# required by kde-plasma/plasma-meta-5.9.5::gentoo
# required by kde-plasma/plasma-meta (argument)
>=x11-proto/xf86bigfontproto-1.2.0-r1 abi_x86_32

Would you like to add these changes to your config files? [Yes/No] n

!!! All ebuilds that could satisfy "sys-libs/zlib[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-libs/zlib-1.2.11::gentoo (masked by: )

(dependency required by "x11-drivers/nvidia-drivers-381.22::gentoo" [ebuild])
(dependency required by "x11-base/xorg-drivers-1.19::gentoo[video_cards_nvidia]" [ebuild])
(dependency required by "x11-base/xorg-server-1.19.3::gentoo[xorg]" [ebuild])
(dependency required by "x11-drivers/xf86-input-evdev-2.10.5::gentoo" [ebuild])
(dependency required by "kde-plasma/plasma-desktop-5.9.5::gentoo[input_devices_evdev]" [ebuild])
(dependency required by "kde-plasma/plasma-meta-5.9.5::gentoo" [ebuild])
(dependency required by "kde-plasma/plasma-meta" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

GentooX /mnt2/BACKUPs #



is that the right way to install KDE on fresh Gentoo install?

[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]


Last edited by Thunderfly on Tue Jul 18, 2017 1:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
genterminl
Guru
Guru


Joined: 12 Feb 2005
Posts: 482
Location: Connecticut, USA

PostPosted: Mon Jul 17, 2017 9:16 pm    Post subject: Reply with quote

What CPU are you actually using? (less /proc/cpuinfo) I'm not certain, but I think you need to add mmxext rather than remove sse, and those are part of CPU_FLAGS_X86 not just plain USE flags (although there are some that could be in both). As far as all those abi_x86_32 use flags, I belive that is normal for a multilib setup, althgough I've never tracked down what actually needs the 32 bit version. I also think the zlib problem will go away once you sort out the USE and CPU_FLAGS_X86 settings.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21345
Location: here

PostPosted: Tue Jul 18, 2017 5:50 am    Post subject: Reply with quote

For set correct CPU_FLAGS_X86 in make.conf use app-portage/cpuid2cpuflags program
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Thunderfly
n00b
n00b


Joined: 11 Jul 2017
Posts: 25

PostPosted: Tue Jul 18, 2017 5:53 am    Post subject: Reply with quote

Code:
GentooX /home/faruk # cpuinfo2cpuflags-x86
CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
GentooX /home/faruk #


Ive added mmxext to make.conf.


Code:
GentooX /home/faruk # cat /etc/portage/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe"
CXXFLAGS="${CFLAGS}"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"

# These are the USE and USE_EXPAND flags that were used for
# buidling in addition to what is provided by the profile.


USE="bindist bzip2 idm ipv6 mmx sse mmxext sse2 urandom gtk -gnome -qt4 qt5 kde dvd alsa cdr X"
#CPU_FLAGS_X86="mmx sse2"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"


MAKEOPTS="-j19"
ACCEPT_KEYWORDS="amd64"

GENTOO_MIRRORS="http://mirror.eu.oneandone.net/linux/distributions/gentoo/gentoo/"

#GENTOO_MIRRORS="http://gd.tuwien.ac.at/opsys/linux/gentoo/ ftp://gd.tuwien.ac.at/opsys/linux/gentoo/ rsync://mirror.eu.oneandone.net/gentoo/"

LINGUAS="de en"
L10N="de en"
VIDEO_CARDS="nvidia"
INPUT_DEVICES="evdev"

GRUB_PLATFORMS="efi-64"
GentooX
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21345
Location: here

PostPosted: Tue Jul 18, 2017 5:56 am    Post subject: Reply with quote

You need to add this line in make.conf
Code:
CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"

CPU_FLAGS_X86 is a USE_EXPAND, for more information read here
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Thunderfly
n00b
n00b


Joined: 11 Jul 2017
Posts: 25

PostPosted: Tue Jul 18, 2017 1:00 pm    Post subject: Reply with quote

thx !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum