Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Qingy DirectFB Mouse lagging
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
returnof Snekiepete
n00b
n00b


Joined: 22 Dec 2016
Posts: 29

PostPosted: Sat Jul 15, 2017 4:30 am    Post subject: Qingy DirectFB Mouse lagging Reply with quote

I have got Qingy and DirectFB working, except for the mouse. It is there, and moves, but soooo slow. Any ideas?
Back to top
View user's profile Send private message
returnof Snekiepete
n00b
n00b


Joined: 22 Dec 2016
Posts: 29

PostPosted: Sat Jul 15, 2017 11:44 pm    Post subject: Reply with quote

I've made some troubleshooting progress, but I am still stumped. I can fix the DirectFB/Qingy mouse issue by disabling inteldrmfb. So this slow mouse issue seems to be something going on with inteldrmfb/DirectFB. However, I cannot start X with this disabled. Is there any way to disable the inteldrmfb framebuffer at boot but have it accessible to start X?
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Sun Oct 01, 2017 2:43 pm    Post subject: Reply with quote

returnof Snekiepete wrote:
I've made some troubleshooting progress, but I am still stumped. I can fix the DirectFB/Qingy mouse issue by disabling inteldrmfb. So this slow mouse issue seems to be something going on with inteldrmfb/DirectFB. However, I cannot start X with this disabled. Is there any way to disable the inteldrmfb framebuffer at boot but have it accessible to start X?


I was searching for a solution to almost this same problem. I have an r600 class Radeon 6850 using the radeon KMS framebuffer. It required DirectFB to be compiled with the drmkms use flag. But now I'm experiencing the same symptoms you describe in this thread. I too am trying to set up qingy again, got it working, but the input lag is so bad. It must be something DirectFB related?
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Mon Oct 02, 2017 4:05 am    Post subject: Reply with quote

I just post an update on my progress.

So it's definitely a problem with DirectFB. Maybe not a problem, but definitely a mis-configuration somehow that I haven't solved yet. If I set in make.conf INPUT_DEVICES="mouse keyboard evdev libinput" Qingy has mouse movement sorta, but it's super laggy, same symptom with keyboard input. So I decided to emerge links with the directfb use flag. Launching it with "links -g -driver directfb" it has exactly the same symptoms qingy has to the letter.

Googe seaching various similar problems led me to believe removing evdev from INPUT_DEVICES would solve a similar problem so I tried that. Now both qingy and links have no input at all, no mouse or keyboard, and then I can't even cntl>alt>f2 to escape to a different terminal. Google searching some more led me to think the solution lies in some module for directfb called linux_input, but I am failing at finding any documentation about it. And in fact there is not even a /etc/directfbrc file created on emerge DirectFB, so I manually created one. But I am not even sure if the manually created config file is even being read. I just don't know.

So that is more or less the current status quo. If anybody knows more about DirectFB I could sure use some of your knowledge powers.
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Thu Oct 05, 2017 1:00 pm    Post subject: Reply with quote

Here's a progress update..

I got it sorta working. At least I definitely got the input problem fixed. So it was basically a combo of three things that needed to be in place. You must build world with INPUT_DEVICES="evdev", /etc/directfbrc needs a line module-disable=linux_input, and finally the linux kernel must be built with mouse interface psaux. Qingy is working and so is links.

But now a different problem. /etc/X11/Sessions is filled with *.desktop files, which qingy doesn't know how to read. So it doesn't actually have the ability to start x sessions. I'm not sure what the solution for that is yet.
Back to top
View user's profile Send private message
returnof Snekiepete
n00b
n00b


Joined: 22 Dec 2016
Posts: 29

PostPosted: Wed Oct 11, 2017 1:22 am    Post subject: Reply with quote

I can't wait to test this! (Working on another issue currently). For Qingy you use /etc/X11/Sessions without .desktop files. For example, below is what I have listed in my Cinnamon session (no .desktop extension)

Code:

exec ck-launch-session dbus-launch cinnamon-session
Back to top
View user's profile Send private message
returnof Snekiepete
n00b
n00b


Joined: 22 Dec 2016
Posts: 29

PostPosted: Thu Oct 12, 2017 3:38 am    Post subject: Reply with quote

Well, I followed your guidance and unfortunately for me the mouse is still lagging. I guess I'll just stick with MDM but really like Qingy...
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Thu Oct 12, 2017 1:45 pm    Post subject: Reply with quote

returnof Snekiepete wrote:
Well, I followed your guidance and unfortunately for me the mouse is still lagging. I guess I'll just stick with MDM but really like Qingy...


Here is my complete directfbrc, perhaps there is more you need to set?

Code:

system=fbdev
mode=1680x1050
directfbrc
no-banner
vt-switching
mouse-source=/dev/psaux
mouse-protocol=IMPS/2
#mouse-gpm-source
debug
log-file=/var/log/directfb.log
hardware
dma
curser
#linux-input-devices=/dev/tty0
disable-module=linux_input


I'm thinking you might need system, mouse-source, and mouse-protocol lines as well. It's definitely a DirectFB configuration problem. You just have to find the directfbrc configuration that works.
Back to top
View user's profile Send private message
returnof Snekiepete
n00b
n00b


Joined: 22 Dec 2016
Posts: 29

PostPosted: Sat Oct 28, 2017 12:35 am    Post subject: Reply with quote

I am closer. I have the mouse moving normally now, except when I touch the touchpad it resets the position of the mouse making movement difficult...

I am using the opposite of you below with mouse-gpm-source un-commented and the other options, /dev/psaux and IMPS/2 ignored.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum