Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Remove old gcc Versions
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
tomtom2017
n00b
n00b


Joined: 06 Jul 2017
Posts: 8

PostPosted: Fri Jul 14, 2017 3:16 pm    Post subject: Remove old gcc Versions Reply with quote

Hello again,

on my gentoo system I have several versions of gcc installed:
4.7.3
4.8.1-r1
4.9.2
6.3.0

I'd like to get rid of maybe 4.7 and 4.8 - but when I try to uninstall those using paludis, I get a conflict, no matter which version I choose.

Code:
I cannot proceed without being permitted to do the following:

X   dev-db/mysql 5.6.36:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon sys-devel/gcc-4.7.3:4.7.4::installed (DEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   sys-apps/paludis 2.6.0:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon sys-devel/gcc-4.7.3:4.7.4::installed (DEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   sys-libs/glibc 2.17:2.2::installed
    Will be broken by uninstalls:
    Reasons: dependent upon sys-devel/gcc-4.7.3:4.7.4::installed (DEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent


I don't understand why theses 3 are depending on all gcc-Verisons. Is there something to be done which I am not aware of?
To my understanding, I already switched to the latest gcc

Code:
webserver ~ # gcc --version
gcc (Gentoo 6.3.0 p1.0) 6.3.0
Copyright (C) 2016 Free Software Foundation, Inc.


Could someone please help me?
Thanks!

Tom
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10459
Location: Somewhere over Atlanta, Georgia

PostPosted: Fri Jul 14, 2017 3:23 pm    Post subject: Reply with quote

Sure. To fix,
  1. Make sure gcc-config selects a newer compiler (it probably already does).
  2. Run
    Code:
    source /etc/profile; source ~/.bash_profile

  3. Rebuild the packages Paludis is complaining about.
That should do it.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
tomtom2017
n00b
n00b


Joined: 06 Jul 2017
Posts: 8

PostPosted: Fri Jul 14, 2017 4:47 pm    Post subject: Reply with quote

Hi John,

thanks for your support.

1. Already did that
2. There is no bash_profile there.
3. Reinstalled all three packages

Paludis still doesn't want to uninstall old gcc-Versions.

This is from the mysql-ebuild:
Code:
DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"


Paludis ebuild says
Code:
DEPEND=">=sys-devel/gcc-4.7


glibc-ebuild tells us
Code:
DEPEND+=">=sys-devel/gcc-4.7


So everything should be fine if I uninstall 4.7 because there are still 3 newer versions of gcc installed.
Could this be a bug in paludis or something? I'm lost here.

Thanks again.

Regards,
Thomas[/quote]
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 552
Location: uk

PostPosted: Thu Aug 10, 2017 10:52 am    Post subject: Reply with quote

I am seeing a similar situation with gcc-5.4.0-r3 and app-text/pdftk

Uninstalling app-text/pdftk allows removal of gcc-5.4.0-r3 however after doing so and trying to re-install app-text/pdftk, I get the following

Code:
emerge -av pdftk                                         

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] sys-devel/gcc-5.4.0-r3:5.4.0::gentoo [6.4.0:6.4.0::gentoo] USE="cxx fortran gcj (multilib) nls nptl openmp sanitize vtv (-altivec) (-awt) -cilk -debug -doc (-fixed-point) -go -graphite (-hardened) (-jit) (-libssp) -mpx -nopie -nossp -objc -objc++ -objc-gc -regression-test -vanilla" 0 KiB
[ebuild  N     ] app-text/pdftk-2.02::gentoo  0 KiB

Total: 2 packages (1 new, 1 in new slot), Size of downloads: 0 KiB


and yet the pdftk ebuild does not depend on a specific version

Code:

="http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/"
SRC_URI="http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/${P}-src.zip"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux"

DEPEND="sys-devel/gcc[gcj]"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${P}-dist/${PN}"

src_prepare() {
        epatch "${FILESDIR}"/${P}-flags.patch
}

src_compile() {
        # Settings by java-config break compilation by gcj.
        unset CLASSPATH
        unset JAVA_HOME

        # Parallel make fails; confirmed, still not fixed in version 2.02.
        emake -j1 -f "${S}"/Makefile.Debian || die "Compilation failed."
}

src_install() {
        dobin pdftk
        doman ../pdftk.1
        dohtml ../pdftk.1.html
}

[/code]
current gcc version

Code:
gcc-config -l
 [1] x86_64-pc-linux-gnu-6.4.0 *
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3975
Location: Germany

PostPosted: Thu Aug 10, 2017 1:50 pm    Post subject: Reply with quote

@baaann,
for app-text/pdftk is sys-devel/gcc[gcj] required,
and gcc-5 is currently the last version with USE=gcj available.
(USE=gcj useflag is on gcc:6.4.0 masked).

Example:
Code:
# emerge -pv pdftk

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "sys-devel/gcc[gcj]".
!!! One of the following packages is required to complete your request:
- sys-devel/gcc-5.4.0-r3::gentoo (Change USE: +gcj)
(dependency required by "app-text/pdftk-2.02::gentoo" [ebuild])
(dependency required by "pdftk" [argument])
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 552
Location: uk

PostPosted: Thu Aug 10, 2017 3:45 pm    Post subject: Reply with quote

Josef.95 wrote:
@baaann,
for app-text/pdftk is sys-devel/gcc[gcj] required,
and gcc-5 is currently the last version with USE=gcj available.
(USE=gcj useflag is on gcc:6.4.0 masked).

Example:
Code:
# emerge -pv pdftk

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "sys-devel/gcc[gcj]".
!!! One of the following packages is required to complete your request:
- sys-devel/gcc-5.4.0-r3::gentoo (Change USE: +gcj)
(dependency required by "app-text/pdftk-2.02::gentoo" [ebuild])
(dependency required by "pdftk" [argument])


Many thanks Josef, I honestly thought I had checked that......but pretty obvious once you do :oops:
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2743
Location: Frankfurt, Germany

PostPosted: Thu Aug 10, 2017 4:13 pm    Post subject: Reply with quote

@tomtom2017: what does "emerge -p --depclean" show?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum