Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cantata missing fonts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
potuz
Guru
Guru


Joined: 30 Jan 2010
Posts: 378

PostPosted: Sun Jul 09, 2017 3:39 pm    Post subject: Cantata missing fonts Reply with quote

Hello, I posted this in https://github.com/CDrummond/cantata/issues/903 but I believe that this is an issue with Gentoo's build and not Cantata nor Qt's handling of fonts.

using cantata 2.0.1 on ~amd64 with qt 5.7.1 and I see missing icons. According to the issue report this is an issue with fontawesome, a ttf of which is installed with cantata under /usr/share/cantata/fonts. However, I believe my system is using the wrong font:

Code:

$ lsof -p 2072 | grep awesome
cantata 2072 user  mem       REG              259,2   173219  1449416 /usr/share/texmf-dist/fonts/type1/public/fontawesome/FontAwesome.pfb
$


And I get the errors:
Code:

Failed to compute left/right minimum bearings for "FontAwesome"



How can I make sure that cantata is loading the file under /usr/share/cantata/fonts and not the one provided by texmf?

UPDATE: if I move texmf's pfb file out of the way then cantata loads the right font file


Last edited by potuz on Sun Jul 09, 2017 4:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
potuz
Guru
Guru


Joined: 30 Jan 2010
Posts: 378

PostPosted: Sun Jul 09, 2017 4:24 pm    Post subject: Reply with quote

Ok so I must confess that I never understood how font configuration works, mostly cause I never cared, and eselect fontconfig enable/disable did the trick all of the time.

Now I copied the provided fontawesome-4.3.0.ttf to ~/.local/share/font and added it to the cache as
Code:

$ cp /usr/share/cantata/fonts/fontawesome-4.3.0.ttf .local/share/fonts/
$ cd .local/share/fonts/
$ mkfontscale
$ mkfontdir
$ fc-cache -fv ~/.local/share/font


I can see the font installed:
Code:

$ fc-list | grep awesome
/usr/share/texmf-dist/fonts/type1/public/fontawesome/FontAwesome.pfb: FontAwesome:style=Regular
/usr/share/texmf-dist/fonts/opentype/public/fontawesome/FontAwesome.otf: FontAwesome:style=Regular
/home/user/.local/share/fonts/fontawesome-4.3.0.ttf: FontAwesome:style=Regular
$

But fc-match does not give me what I want:
Code:

$ fc-match fontAwesome
FontAwesome.otf: "FontAwesome" "Regular"

And still the same Qt error above.
Back to top
View user's profile Send private message
mega_flow
n00b
n00b


Joined: 26 Jun 2016
Posts: 30
Location: Belgium, Maasmechelen

PostPosted: Sun Jul 09, 2017 6:23 pm    Post subject: Reply with quote

have no problem with fonts on canata or missing icon's
fc-match fontAwesome, show DejaVuSans.ttf: "DejaVu Sans" "Book"
maybe u need to install the media-fonts/dejavu
Back to top
View user's profile Send private message
potuz
Guru
Guru


Joined: 30 Jan 2010
Posts: 378

PostPosted: Sun Jul 09, 2017 6:33 pm    Post subject: Reply with quote

mega_flow wrote:
have no problem with fonts on canata or missing icon's
fc-match fontAwesome, show DejaVuSans.ttf: "DejaVu Sans" "Book"
maybe u need to install the media-fonts/dejavu

But do you have installed the texmf file mentioned in my post?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum