Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
merge conflict with qt 5.7.1-r3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
FrancoisVal
n00b
n00b


Joined: 12 May 2005
Posts: 71
Location: Namur, Belgique

PostPosted: Wed Jul 05, 2017 7:49 pm    Post subject: merge conflict with qt 5.7.1-r3 Reply with quote

Hello everybody,

I am getting plenty of merge conflicts since that qt 5.7.1-r3 packages have been stabilized. It first seems that it is not compatible with some kde packaged (like kwin). Therefore I added these to portackge.keywords, but it doesnt solve the problem.

Here is what I now get with emerge -aDvu world:

Code:
dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtdbus-5.7.1:5 required by (kde-plasma/breeze-5.10.3:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qdbus-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    (and 4 more with the same problems)

  (dev-qt/qtdbus-5.6.2:5/5.6::gentoo, installed) pulled in by
    >=dev-qt/qtdbus-5.6.1:5/5.6= required by (kde-frameworks/kauth-5.34.0:5/5.34::gentoo, installed)
                         ^^^^^^^
    ~dev-qt/qtdbus-5.6.2 required by (dev-qt/qtgui-5.6.2:5/5.6::gentoo, installed)


I get similar errors for all qt packages. I can't really understand why qtdbus-5.7.1:5/5.7 can conflict with itself.
Can somebody explains what is happening ?

Thanks in advance for your help,

François Valenduc

[Moderator edit: added [code] tags to preserve output layout. -Hu]
_________________
François Valenduc
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6827
Location: Austria

PostPosted: Wed Jul 05, 2017 8:26 pm    Post subject: Reply with quote

There is no conflict with KDE packages, remove those package.keywords entries again so that they do not distract from the real issue. Please pastebin the full output.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
FrancoisVal
n00b
n00b


Joined: 12 May 2005
Posts: 71
Location: Namur, Belgique

PostPosted: Wed Jul 05, 2017 8:42 pm    Post subject: Reply with quote

So you can find the emerge output here:

https://pastebin.com/LhtjP4fc

As you can see, there is also a problem with akonadi, which I need because I installed kgpg:5. If I add akonadi-17.04.2 like suggested, there is then a problem woth kde-l10n which is only available at version 16.
I really don't know how to get out of all these conflicts.
_________________
François Valenduc
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6827
Location: Austria

PostPosted: Wed Jul 05, 2017 8:55 pm    Post subject: Reply with quote

So Qt5 is not the problem at all here because you broke your dependencies with that single akonadi-17.04.2 entry.

It does not work like this, because KDE Applications 17.04.x packages are ultimately conflicting with kde*-l10n-16.12.3 packages.

So if you want to have kgpg-17.04.2, you've got to put *all* of kde-apps/*-17.04.2 into package.keywords.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
FrancoisVal
n00b
n00b


Joined: 12 May 2005
Posts: 71
Location: Namur, Belgique

PostPosted: Wed Jul 05, 2017 9:14 pm    Post subject: Reply with quote

It is not that I want kgpg 17.04. The problem is that it requires akonadi. Akonadi 17.04 has been added portage some days ago while version 16 has been removed (see https://packages.gentoo.org/packages/kde-apps/akonadi)
I think this is the real cause of my problem because as I sead akonadi then require kde-l10n 17.04 which doesn't exist (see http://packages.gentoo.org/packages/kde-apps/kde-l10n)
_________________
François Valenduc
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6827
Location: Austria

PostPosted: Wed Jul 05, 2017 9:17 pm    Post subject: Reply with quote

The real cause is that you are mixing ~arch (kgpg-16.12.3:5) and arch (other 16.12.3 packages).

FrancoisVal wrote:
I think this is the real cause of my problem because as I sead akonadi then require kde-l10n 17.04 which doesn't exist

No, unstable akonadi does not require stable kde-l10n, your stable packages require stable kde-l10n, which is blocked by the unstable 17.04.x packages.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
FrancoisVal
n00b
n00b


Joined: 12 May 2005
Posts: 71
Location: Namur, Belgique

PostPosted: Thu Jul 06, 2017 2:35 pm    Post subject: Reply with quote

The cause of the problem is kgpg:5. Installing kgpg:4 is no problem. But then there is no integration with dolphin:5.
If I add kgpg:5 to portage keywords, here is what I get:

Code:

16:33 francois@pc-francois ~% emerge -vp kgpg:5

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] kde-apps/kmime-17.04.2:5::gentoo  USE="-debug {-test}" 142 KiB
[ebuild  N    ~] kde-apps/kcontacts-17.04.2:5::gentoo  USE="-debug {-test}" 203 KiB
[ebuild  NS   ~] kde-apps/akonadi-17.04.2:5::gentoo [1.13.1_pre20160203-r1:4::gentoo] USE="mysql xml -debug -designer -postgres -sqlite {-test} -tools" 1273 KiB
[uninstall     ] kde-apps/akonadi-1.13.1_pre20160203-r1:4::gentoo  USE="mysql -postgres -sqlite {-test}"
[blocks b      ] kde-apps/akonadi:4 ("kde-apps/akonadi:4" is blocking kde-apps/akonadi-17.04.2)
[ebuild  N    ~] kde-apps/akonadi-mime-17.04.2:5::gentoo  USE="-debug {-test}" 128 KiB
[uninstall     ] kde-apps/kdepimlibs-4.14.11_pre20160611:4/4.14::gentoo  USE="handbook (-aqua) -debug -ldap -prison {-test}"
[blocks b      ] kde-apps/kdepimlibs ("kde-apps/kdepimlibs" is blocking kde-apps/akonadi-17.04.2)
[blocks b      ] kde-apps/kdepimlibs:4 ("kde-apps/kdepimlibs:4" is blocking kde-apps/akonadi-mime-17.04.2)
[ebuild  N    ~] kde-apps/akonadi-contacts-17.04.2:5::gentoo  USE="-debug -prison {-test}" 340 KiB
[ebuild  NS   ~] kde-apps/kgpg-17.04.2:5::gentoo [16.08.3:4/16.08::gentoo] USE="handbook -debug (-selinux)" 2756 KiB
[uninstall     ] kde-apps/kgpg-16.08.3:4/16.08::gentoo  USE="handbook (-aqua) -debug (-selinux)"
[blocks b      ] kde-apps/kgpg:4 ("kde-apps/kgpg:4" is blocking kde-apps/kgpg-17.04.2)
[blocks B      ] kde-apps/kde-l10n ("kde-apps/kde-l10n" is blocking kde-apps/akonadi-contacts-17.04.2, kde-apps/kmime-17.04.2, kde-apps/kgpg-17.04.2, kde-apps/kcontacts-17.04.2, kde-apps/akonadi-mime-17.04.2, kde-apps/akonadi-17.04.2)

Total: 6 packages (4 new, 2 in new slots, 3 uninstalls), Size of downloads: 4839 KiB
Conflict: 5 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kde-l10n-16.12.3:5/5::gentoo, installed) pulled in by
    >=kde-apps/kde-l10n-16.12.3 required by (kde-apps/kde4-l10n-16.12.3-r1:4/4::gentoo, installed)
    kde-apps/kde-l10n required by @selected

  (kde-apps/kgpg-17.04.2:5/5::gentoo, ebuild scheduled for merge) pulled in by
    kde-apps/kgpg required by @selected
    kgpg:5


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages



I am not going to explain for the third time that there is an incoherency between akonadi-17.04.2 and kde-l10n-16.12.3 which is the last version available at the moment in portage.
_________________
François Valenduc
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6827
Location: Austria

PostPosted: Thu Jul 06, 2017 2:59 pm    Post subject: Reply with quote

And I'm not going to explain to you a second time how to solve this situation. ;)

FrancoisVal wrote:
and kde-l10n-16.12.3 which is the last version available at the moment in portage.

It is the last version of kde-l10n you will ever see. We also have a wiki: https://wiki.gentoo.org/wiki/KDE#Localization
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
FrancoisVal
n00b
n00b


Joined: 12 May 2005
Posts: 71
Location: Namur, Belgique

PostPosted: Thu Jul 06, 2017 4:03 pm    Post subject: Reply with quote

Indeed, removing kde-l10n and upgrading kde4-l10n to version 17.04.2 was the solution. Difficult to guess... A news item about the deprecation of kde-l10n wouldn't have been bad...
_________________
François Valenduc
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6827
Location: Austria

PostPosted: Thu Jul 06, 2017 4:09 pm    Post subject: Reply with quote

kde4-l10n is no replacement to kde-l10n - your slot 5 16.12.3 packages are now without translations. You can also find that in the wiki.

We don't do news items to support all kinds of problems coming from mixing ~arch and arch - you are on your own there. arch is consistent, and ~arch is consistent.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum