Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
failed to set drm interface version on a ati card
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5270

PostPosted: Sat Jul 01, 2017 1:15 pm    Post subject: failed to set drm interface version on a ati card Reply with quote

Greetings All,

I have two gpus, on my system:
Code:
dagg@NCC-5001-D ~ $ lspci  | grep -i vga
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430]
06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV635 [Radeon HD 3650/3750/4570/4580]

the first one works well but the second one fails with the error mentioned in the title.
it doesn't have a screen attached to it not sure if it related but for now I just want to start X on it.

here are some outputs:
Code:

[   10.049918] [drm] Initialized radeon 2.49.0 20080528 for 0000:01:00.0 on minor 0
[   10.049957] radeon 0000:06:00.0: enabling device (0000 -> 0003)
[   10.050069] [drm] initializing kernel modesetting (RV635 0x1002:0x9598 0x174B:0xE540 0x00).
[   10.050074] [drm] register mmio base: 0xFBCE0000
[   10.050074] [drm] register mmio size: 65536
[   10.173135] ATOM BIOS: 11X
[   10.173149] [drm] GPU not posted. posting now...
[   10.175069] radeon 0000:06:00.0: VRAM: 512M 0x0000000000000000 - 0x000000001FFFFFFF (512M used)
[   10.175070] radeon 0000:06:00.0: GTT: 1024M 0x0000000020000000 - 0x000000005FFFFFFF
[   10.175075] [drm] Detected VRAM RAM=512M, BAR=256M
[   10.175075] [drm] RAM width 128bits DDR
[   10.175085] [drm] radeon: 512M of VRAM memory ready
[   10.175085] [drm] radeon: 1024M of GTT memory ready.
[   10.175089] [drm] Loading RV635 Microcode
[   10.175092] [drm] Internal thermal controller with fan control
[   10.175117] [drm] radeon: power management initialized
[   10.175126] [drm] GART: num cpu pages 262144, num gpu pages 262144
[   10.175535] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
[   10.178116] [drm] PCIE GART of 1024M enabled (table at 0x0000000000142000).
[   10.178147] radeon 0000:06:00.0: WB enabled
[   10.178149] radeon 0000:06:00.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0xffff8804143eec00
[   10.178858] radeon 0000:06:00.0: fence driver on ring 5 use gpu addr 0x00000000000521d0 and cpu addr 0xffffc900024121d0
[   10.178859] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   10.178859] [drm] Driver supports precise vblank timestamp query.
[   10.178860] radeon 0000:06:00.0: radeon: MSI limited to 32-bit
[   10.178895] radeon 0000:06:00.0: radeon: using MSI.
[   10.178920] [drm] radeon: irq initialized.
[   10.210370] [drm] ring test on 0 succeeded in 1 usecs
[   10.386481] [drm] ring test on 5 succeeded in 1 usecs
[   10.386490] [drm] UVD initialized successfully.
[   10.386630] [drm] ib test on ring 0 succeeded in 0 usecs
[   11.040890] [drm] ib test on ring 5 succeeded
[   11.041197] [drm] Radeon Display Connectors
[   11.041198] [drm] Connector 0:
[   11.041198] [drm]   DVI-I-2
[   11.041199] [drm]   HPD1
[   11.041200] [drm]   DDC: 0x7e50 0x7e50 0x7e54 0x7e54 0x7e58 0x7e58 0x7e5c 0x7e5c
[   11.041200] [drm]   Encoders:
[   11.041200] [drm]     DFP1: INTERNAL_UNIPHY
[   11.041201] [drm]     CRT2: INTERNAL_KLDSCP_DAC2
[   11.041201] [drm] Connector 1:
[   11.041201] [drm]   DVI-I-3
[   11.041202] [drm]   HPD2
[   11.041202] [drm]   DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
[   11.041203] [drm]   Encoders:
[   11.041203] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
[   11.041203] [drm]     DFP2: INTERNAL_KLDSCP_LVTMA
[   11.041204] [drm] Connector 2:
[   11.041204] [drm]   DIN-1
[   11.041204] [drm]   Encoders:
[   11.041204] [drm]     TV1: INTERNAL_KLDSCP_DAC2
[   11.081066] [drm] Cannot find any crtc or sizes - going 1024x768
[   11.083167] [drm] fb mappable at 0xE0343000
[   11.083168] [drm] vram apper at 0xE0000000
[   11.083168] [drm] size 3145728
[   11.083168] [drm] fb depth is 24
[   11.083169] [drm]    pitch is 4096
[   11.083198] radeon 0000:06:00.0: fb1: radeondrmfb frame buffer device
[   11.083204] [drm] Initialized radeon 2.49.0 20080528 for 0000:06:00.0 on minor 1

xorg log: https://paste.pound-python.org/show/lg0mOhQh7XMQT9ABKKln/
kernel config: https://paste.pound-python.org/show/8SRqMq0XXqc0bZGBO8uP/
emerge --info: https://paste.pound-python.org/show/TFGNVwuqD8OjtQR6QSEO/

any ideas why I cannot get it to start?

Thanks.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum