Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
packages.gentoo.org hardware issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message
leak
n00b
n00b


Joined: 06 Aug 2004
Posts: 16

PostPosted: Wed Dec 27, 2017 1:03 pm    Post subject: packages.gentoo.org hardware issues Reply with quote

Hi,

are there any news about the state of this https://infra-status.gentoo.org/notice/20171019-packages ?

packages.gentoo.org is my go-to site when i quickly want to educate myself about packages and as of late I found it completely unresponsive multiple times.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 17373
Location: here

PostPosted: Wed Dec 27, 2017 1:10 pm    Post subject: Reply with quote

No news also in related bug https://bugs.gentoo.org/634708

Alternatively you can use http://en.znurt.org/
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1440

PostPosted: Wed Dec 27, 2017 4:06 pm    Post subject: Reply with quote

I've also notice it's been screwy on working for a while. One thing that seems to work, is using google to search for the package, and it usually brings up the link to the page on packages.gentoo.org right away. Usually, I tend to see the search option for the packages from the site to be broken the most.
Back to top
View user's profile Send private message
pa4wdh
Apprentice
Apprentice


Joined: 16 Dec 2005
Posts: 281

PostPosted: Wed Jan 10, 2018 6:48 pm    Post subject: Something wrong with packages.gentoo.org ? Reply with quote

Hi All,

I'm using the packages.gentoo.org website in a script, and i noticed it doesn't work as expected. After some troubleshooting it seems packages.gentoo.org is misbehaving, I'd like to check if it's just me or that there's something wrong at packages.gentoo.org.

It's easy to see the issue with curl:
Code:

~ $ curl -i https://packages.gentoo.org/package/dev-libs/expat
HTTP/1.1 301 Moved Permanently
Server: nginx
Date: Wed, 10 Jan 2018 18:43:48 GMT
Content-Type: text/html
Content-Length: 178
Location: https://packages.gentoo.org/packages/dev-libs/expat
(more headers and content removed)

This is the expected response, if follow this redirect this happens:
Code:

~ $ curl -i https://packages.gentoo.org/packages/dev-libs/expat

There is actually no output at all, for most if the time. Sometimes, like 1 out of 10 or so, it works. Checking this with wireshark leans that the connection setup, tls negotiation and request submission actually work well, there is just no response at http level.
I also tried forcing the use of ipv4 and ipv6, and that didn't make a difference.
_________________
The gentoo way of bringing peace to the world:
USE="-war" emerge --newuse world

Free as in Freedom is not limited to software only:
Music: http://www.jamendo.com
Recipes: http://www.opensourcefood.com
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 17373
Location: here

PostPosted: Wed Jan 10, 2018 6:51 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-1072256-view-previous.html?sid=d2e2c07adffb1d712418235f85a93e79
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 9613
Location: Somewhere over Atlanta, Georgia

PostPosted: Wed Jan 10, 2018 6:53 pm    Post subject: Reply with quote

There's also Gentoo Infrastructure Status.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16825

PostPosted: Thu Jan 11, 2018 3:38 am    Post subject: Reply with quote

fedeliallalinea wrote:
https://forums.gentoo.org/viewtopic-t-1072256-view-previous.html
Thanks, merged.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1357
Location: United Kingdom

PostPosted: Thu Jan 11, 2018 9:57 am    Post subject: Waiting for packages.gentoo.org... Reply with quote

Someone mentioned this problem previously in these forums, but I can't find the thread.

I enter the package name in the Search box in https://packages.gentoo.org/ and press Enter. Usually the site does not display the resulting package and the browser sits there with "Waiting for packages.gentoo.org..." displayed. The same thing happens in Firefox and Chrome or Chromium on different machines running different OSs (Gentoo, Lubuntu, Windows). All the other Gentoo Web sites work fine.
_________________
Clevo W230SS: amd64, OpenRC, nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64, OpenRC, xf86-video-ati, dual booting with Win 7 Pro 64-bit.
KDE on both laptops.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7363
Location: ~Brussels - Belgique

PostPosted: Thu Jan 11, 2018 10:00 am    Post subject: Reply with quote

https://infra-status.gentoo.org/
Quote:
Maintenance and Outage Notices
packages.gentoo.org hardware issues

There are hardware problems on the host where packages.gentoo.org is hosted.

For the duration, updates may be delayed and/or the site may be unavailable.
Thu, 19 Oct 2017 00:00:00 GMT
No ETA for service recovery available.

_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 17373
Location: here

PostPosted: Thu Jan 11, 2018 10:13 am    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-1075236.html
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16825

PostPosted: Thu Jan 11, 2018 5:12 pm    Post subject: Re: Waiting for packages.gentoo.org... Reply with quote

Fitzcarraldo wrote:
Someone mentioned this problem previously in these forums, but I can't find the thread.
Currently "Other Things Gentoo" includes the thread "Moved: Something wrong with packages.gentoo.org ?" Merged with that destination topic, packages.gentoo.org hardware issues.
Back to top
View user's profile Send private message
skorefish
Apprentice
Apprentice


Joined: 21 Jun 2015
Posts: 216

PostPosted: Tue Jan 16, 2018 10:51 am    Post subject: packages.gentoo.org/packages/dev-qt/qtgui server down? Reply with quote

hello, part of the package database seems down?

Bad Gateway (502)

Something bad happened while trying to serve your request.

Don't worry, we're likely already working on it. Please try again later.

And yes, we'll be scolding the Gateway for being bad.

when surfing to https://packages.gentoo.org/packages/dev-qt/qtgui
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5784
Location: Austria

PostPosted: Tue Jan 16, 2018 11:01 am    Post subject: Reply with quote

There are hardware issues, afaik. But why not just use cli utils for that? equery should be able to tell you all the things you want to know about qtgui.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16825

PostPosted: Tue Jan 16, 2018 5:39 pm    Post subject: Re: packages.gentoo.org/packages/dev-qt/qtgui server down? Reply with quote

skorefish wrote:
hello, part of the package database seems down?
Merged.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum