Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
binutils reparieren [gelöst]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Tue Jun 13, 2017 5:52 pm    Post subject: binutils reparieren [gelöst] Reply with quote

Hallo,

nach einem world Update habe ich mit --depclean die vorherige binutils Version entfernt
Code:

Keywords for sys-devel/binutils:
           |                                 |   u        | 
           | a a         p s   a     n r     |   n        | 
           | l m   h i   p p   r m m i i s   | e u s      | r
           | p d a p a p c a x m i 6 o s 3   | a s l      | e
           | h 6 r p 6 p 6 r 8 6 p 8 s c 9 s | p e o      | p
           | a 4 m a 4 c 4 c 6 4 s k 2 v 0 h | i d t      | o
-----------+---------------------------------+------------+-------
 2.25.1-r1 | + + + + + + + + + + ~ + o o + + | 4 o 2.25.1 | gentoo
-----------+---------------------------------+------------+-------
 2.26.1    | + + + + + + + + + + ~ + o o + + | 5 o 2.26.1 | gentoo
-----------+---------------------------------+------------+-------
   2.27-r1 | ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ o o ~ ~ | 5 o 2.27   | gentoo
-----------+---------------------------------+------------+-------
[I]2.28-r2 | ~ + ~ ~ ~ ~ + ~ + ~ ~ ~ o o ~ ~ | 5 o 2.28   | gentoo
-----------+---------------------------------+------------+-------
   9999    | o o o o o o o o o o o o o o o o | 5 o git    | gentoo


Angeblich ist 2.28-r2 ja installiert, aber gcc meldet immer
Code:

C compiler cannot create executables

ld fehlt auch, also irgendwie scheint binutils defekt zu sein oder komplett zu fehlen.

Was ist die schnellste und sauberste Lösung um binutils zu reparieren?

Danke


Last edited by andi_s on Tue Jun 13, 2017 7:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3252
Location: Germany

PostPosted: Tue Jun 13, 2017 7:04 pm    Post subject: Reply with quote

Hm, schau mal via
Code:
binutils-config -l
(kleines L) ob die vorhandene Version gesetzt ist,
falls sie nicht gesetzt ist, setze sie bitte
Code:
binutils-config NUMMER
(NUMMER bitte passend ersetzen :)
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Tue Jun 13, 2017 7:34 pm    Post subject: Reply with quote

binutils-config ist scheinbar defekt

Code:

# binutils-config -l
/usr/bin/binutils-config: line 26: /lib/gentoo/functions.sh: No such file or directory
binutils-config: Could not source /lib/gentoo/functions.sh!
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Tue Jun 13, 2017 7:44 pm    Post subject: Reply with quote

@Josef.95

Nachdem ich lib64/functions.sh aus einem Backup wieder hergestellt habe funktionierte auch binutils-config wieder und ld ist somit auch wieder da!
Es lag wohl an der fehlenden functions.sh das nach dem Update nicht automatisch auf die neuere Version von binutils umgestellt werden konnte.

vielen Dank für die schnelle Hilfe!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum