Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Certbot broken after update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
sligo
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2011
Posts: 93

PostPosted: Sun Jun 11, 2017 10:24 pm    Post subject: [SOLVED] Certbot broken after update Reply with quote

Hello,

i am running my system with Python2.7 only and using Certbot to update my Letsencrypt certs. It worked well all the time but with the most recent update it broke and i wonder if it does need to be run with Python 3+ now.

Code:

Traceback (most recent call last):
  File "/usr/lib/python-exec/python2.7/certbot", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 3030, in <module>
    @_call_aside
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 3014, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 3043, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 654, in _build_master
    ws.require(__requires__)
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 968, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 854, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'future' distribution was not found and is required by parsedatetime


Anyone having similar problems? I kinda hesitate to install the whole Python3 just for one package.


Last edited by sligo on Sat Jun 17, 2017 2:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
leonarp
n00b
n00b


Joined: 22 Mar 2004
Posts: 35
Location: Kansas

PostPosted: Tue Jun 13, 2017 2:35 pm    Post subject: Reply with quote

I'm running python 3.4 and have the same problem.
Back to top
View user's profile Send private message
epig
n00b
n00b


Joined: 16 Feb 2005
Posts: 70

PostPosted: Thu Jun 15, 2017 1:13 pm    Post subject: Reply with quote

leonarp wrote:
I'm running python 3.4 and have the same problem.


+1

Watching this thread carefully
Back to top
View user's profile Send private message
Telemin
l33t
l33t


Joined: 25 Aug 2005
Posts: 734
Location: Glasgow, UK

PostPosted: Thu Jun 15, 2017 4:20 pm    Post subject: Reply with quote

Quote:

Code:

pkg_resources.DistributionNotFound: The 'future' distribution was not found and is required by parsedatetime



The dev-python/future package would appear to now be required, and for whatever reason the new dependency didn't get spotted.

Try merging that package and see if it fixes it.

-telemin-
_________________
The Geek formerly known as -Freestyling-
When you feel your problem has been solved please add [Solved] to the topic title.
Please adopt an unanswered post
Back to top
View user's profile Send private message
epig
n00b
n00b


Joined: 16 Feb 2005
Posts: 70

PostPosted: Thu Jun 15, 2017 6:07 pm    Post subject: Reply with quote

Ah, I dont have the same problem. Not exactly anyway

Code:


grond ~ # certbot
An unexpected error occurred:
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.4/certbot", line 11, in <module>
    load_entry_point('certbot==0.16.0.dev0', 'console_scripts', 'certbot')()
  File "/usr/lib64/python3.4/site-packages/certbot/main.py", line 723, in main
    plugins = plugins_disco.PluginsRegistry.find_all()
  File "/usr/lib64/python3.4/site-packages/certbot/plugins/disco.py", line 200, in find_all
    plugin_ep = PluginEntryPoint(entry_point)
  File "/usr/lib64/python3.4/site-packages/certbot/plugins/disco.py", line 47, in __init__
    self.plugin_cls = entry_point.load()
  File "/usr/lib64/python3.4/site-packages/pkg_resources/__init__.py", line 2295, in load
    self.require(*args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pkg_resources/__init__.py", line 2318, in require
    items = working_set.resolve(reqs, env, installer, extras=self.extras)
  File "/usr/lib64/python3.4/site-packages/pkg_resources/__init__.py", line 859, in resolve
   raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.VersionConflict: (certbot 0.16.0.dev0 (/usr/lib64/python3.4/site-packages), Requirement.parse('certbot==0.15.0.dev0'))



Seems to me that the last line in this input is key, but I am struggling to make sense of it...?
Back to top
View user's profile Send private message
sligo
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2011
Posts: 93

PostPosted: Sat Jun 17, 2017 2:16 pm    Post subject: Reply with quote

I'll put this to solved since the latest version (0.15.0) fixed any problem for me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum