Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
openimageio verweigert das Bauen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
diabolusUmarov
n00b
n00b


Joined: 17 Dec 2016
Posts: 17

PostPosted: Fri Jun 09, 2017 2:42 pm    Post subject: openimageio verweigert das Bauen Reply with quote

Mahlzeit!

Ich versuche nun schon seit längerem openimageio zu bauen, scheitere aber immer kläglich daran und suche Hilfe.

Falls also jemand einen Tipp hat, dann wäre ich sehr dankbar!

Hier ist das Buildlog -> https://pastebin.com/CG972ked
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3160
Location: Germany

PostPosted: Sat Jun 10, 2017 1:02 am    Post subject: Reply with quote

Auszug aus dem Pastebin wrote:
Code:
 * Package:    media-libs/openimageio-1.6.13
 * Repository: gentoo
 * Maintainer: graphics@gentoo.org
 * USE:        abi_x86_64 amd64 elibc_glibc ffmpeg gif kernel_linux opencv opengl python_single_target_python3_5 python_targets_python2_7 python_targets_python3_5 qt4 ssl truetype userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Source unpacked in /var/tmp/portage/media-libs/openimageio-1.6.13/work
>>> Preparing source in /var/tmp/portage/media-libs/openimageio-1.6.13/work/openimageio-1.6.13 ...
>>> Source prepared.

[...Snipp...]

In file included from /var/tmp/portage/media-libs/openimageio-1.6.13/work/openimageio-1.6.13/src/libOpenImageIO/imagebufalgo_opencv.cpp:45:0:
/var/tmp/portage/media-libs/openimageio-1.6.13/work/openimageio-1.6.13/src/include/OpenImageIO/imagebufalgo.h:51:8: error: using typedef-name ‘IplImage’ after ‘struct’
 struct IplImage;  // Forward declaration; used by Intel Image lib & OpenCV
        ^~~~~~~~
In file included from /usr/include/opencv2/core/core_c.h:48:0,
                 from /var/tmp/portage/media-libs/openimageio-1.6.13/work/openimageio-1.6.13/src/libOpenImageIO/imagebufalgo_opencv.cpp:37:
/usr/include/opencv2/core/types_c.h:338:1: note: ‘IplImage’ has a previous declaration here
 IplImage;
 ^~~~~~~~
make[2]: *** [src/libOpenImageIO/CMakeFiles/OpenImageIO.dir/build.make:519: src/libOpenImageIO/CMakeFiles/OpenImageIO.dir/imagebufalgo_opencv.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory '/var/tmp/portage/media-libs/openimageio-1.6.13/work/openimageio-1.6.13_build'
make[1]: *** [CMakeFiles/Makefile2:1037: src/libOpenImageIO/CMakeFiles/OpenImageIO.dir/all] Error 2
make[1]: Leaving directory '/var/tmp/portage/media-libs/openimageio-1.6.13/work/openimageio-1.6.13_build'
make: *** [Makefile:163: all] Error 2
 * ERROR: media-libs/openimageio-1.6.13::gentoo failed (compile phase):
[...]


Hi, klingt nach Bug 616090
Bug Comment 0 wrote:
Downgrading to opencv-3.1.0-r7 fixes the issue.
Teste mal ob der Workaround hilft.
Back to top
View user's profile Send private message
diabolusUmarov
n00b
n00b


Joined: 17 Dec 2016
Posts: 17

PostPosted: Sun Jun 11, 2017 12:35 am    Post subject: Reply with quote

Das habe ich versucht, aber diese Version von OpenCV streikt jetzt beim Bauen. Er würde die stdlib.h nicht finden. Vielleicht muss ich da aber auch nur auf eine frühere Version vom GCC schalten, dass muss ich noch ausprobieren.
Back to top
View user's profile Send private message
ZappeL
n00b
n00b


Joined: 27 Sep 2010
Posts: 5

PostPosted: Mon Jun 12, 2017 8:49 am    Post subject: [patch] media-libs/openimageio-1.6.13::gentoo Reply with quote

Selbes Problem...

Das Problem tritt im Zusammenhang mit der types_c.h aus opencv auf. Bei mir stimmte das "#ifndef" nicht.
Patch: http://dpaste.com/3SW94BQ

shell:
Code:
mkdir -p /etc/portage/patches/media-libs/openimageio-1.6.13/
wget -O /etc/portage/patches/media-libs/openimageio-1.6.13/imagebufalgo_h.patch http://dpaste.com/3SW94BQ.txt


Danach neubauen und es sollte klappen.

Viel Erfolg!
_________________
ZappeL@fuckup:~# dd if=/dev/zero of=/dev/brain
ZappeL@fuckup:~# echo "isn`t it good to be root?" >> lol.out
Back to top
View user's profile Send private message
diabolusUmarov
n00b
n00b


Joined: 17 Dec 2016
Posts: 17

PostPosted: Mon Jun 12, 2017 6:56 pm    Post subject: Reply with quote

Läuft deutlich besser, aber ist noch lange nicht am Ende des Bauens :(

https://pastebin.com/7XzrTNX6
Back to top
View user's profile Send private message
ZappeL
n00b
n00b


Joined: 27 Sep 2010
Posts: 5

PostPosted: Mon Jun 12, 2017 11:07 pm    Post subject: Reply with quote

Reemerge mal bitte dev-libs/boost

Code:
emerge -1O dev-libs/boost

_________________
ZappeL@fuckup:~# dd if=/dev/zero of=/dev/brain
ZappeL@fuckup:~# echo "isn`t it good to be root?" >> lol.out
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum