Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Blocks update plasma 5.10.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
brutico
Tux's lil' helper
Tux's lil' helper


Joined: 16 Feb 2014
Posts: 130

PostPosted: Thu Jun 08, 2017 9:52 am    Post subject: Blocks update plasma 5.10.1 Reply with quote

Hello! X11-misc / notification-daemon crashes plasma-workspace 5.10.1 and I can not update the system
Code:
 sudo emerge -auDN @world               

These are the packages that would be merged, in order:

Calculating dependencies  ...... ... done!
[ebuild     U  ] dev-libs/expat-2.2.0-r2 [2.2.0-r1]
[ebuild     U  ] sys-libs/binutils-libs-2.28-r1 [2.28]
[ebuild     U  ] sys-devel/binutils-2.28-r2 [2.28-r1]
[ebuild  NS    ] sys-kernel/gentoo-sources-4.11.4 [4.11.3] USE="-build -experimental -symlink"
[ebuild     U  ] dev-libs/nspr-4.15 [4.14]
[ebuild     U  ] net-libs/gnutls-3.5.13 [3.5.12]
[ebuild     U  ] app-portage/eix-0.32.9 [0.32.5-r1]
[ebuild  r  U  ] media-gfx/exiv2-0.26 [0.25-r2]
[ebuild     U  ] kde-plasma/plasma-workspace-wallpapers-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/breeze-grub-5.10.1 [5.9.5]
[ebuild  rR    ] media-libs/gexiv2-0.10.6
[ebuild     U  ] kde-plasma/breeze-plymouth-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/kwallet-pam-5.10.1 [5.9.5-r1]
[ebuild     U  ] kde-plasma/breeze-gtk-5.10.1 [5.9.5]
[ebuild  N     ] x11-misc/notification-daemon-3.20.0
[ebuild  N     ] virtual/notification-daemon-0  USE="-gnome -kde"
[ebuild  N     ] dev-qt/qtquickcontrols2-5.7.1  USE="-debug {-test}"
[ebuild     U  ] kde-plasma/libkscreen-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/kwayland-integration-5.10.1 [5.9.5]
[ebuild     U  ] sys-apps/openrc-0.27 [0.26.3]
[ebuild     U  ] kde-plasma/kgamma-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/polkit-kde-agent-5.10.1 [5.9.5]
[ebuild  rR    ] kde-frameworks/kfilemetadata-5.34.0
[ebuild     U  ] kde-plasma/kwrited-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/ksshaskpass-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/kactivitymanagerd-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/systemsettings-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/user-manager-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/oxygen-5.10.1 [5.9.5-r1]
[ebuild     U  ] kde-plasma/plasma-pa-5.10.1 [5.9.5]
[ebuild  rR    ] kde-apps/kio-extras-17.04.1
[ebuild     U  ] kde-plasma/kde-gtk-config-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/kscreen-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/kinfocenter-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/sddm-kcm-5.10.1 [5.9.5]
[ebuild  N     ] kde-plasma/plymouth-kcm-5.10.1  USE="-debug"
[ebuild     U  ] kde-plasma/bluedevil-5.10.1 [5.9.5]
[ebuild  NS    ] dev-libs/kirigami-2.1.0 [1.1.0] USE="plasma -debug -examples {-test}"
[ebuild     U  ] kde-plasma/plasma-sdk-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/khotkeys-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/plasma-desktop-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/kdeplasma-addons-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/powerdevil-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/plasma-nm-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/kmenuedit-5.10.1 [5.9.5]
[ebuild     U  ] kde-plasma/plasma-meta-5.10.1 [5.9.5]
[blocks B      ] x11-misc/notification-daemon ("x11-misc/notification-daemon" is blocking kde-plasma/plasma-workspace-5.10.1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-plasma/plasma-workspace-5.10.1:5/5::gentoo, installed) pulled in by
    >=kde-plasma/plasma-workspace-5.10.1:5 required by (kde-plasma/plasma-nm-5.10.1:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.10.1:5 required by (kde-plasma/plasma-desktop-5.10.1:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.10.1:5 required by (kde-plasma/plasma-meta-5.10.1:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.10.1:5 required by (kde-plasma/powerdevil-5.10.1:5/5::gentoo, ebuild scheduled for merge)
    kde-plasma/plasma-workspace required by @selected
    >=kde-plasma/plasma-workspace-5.10.1:5 required by (kde-plasma/kdeplasma-addons-5.10.1:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.10.1:5 required by (kde-plasma/khotkeys-5.10.1:5/5::gentoo, ebuild scheduled for merge)

  (x11-misc/notification-daemon-3.20.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    x11-misc/notification-daemon required by (virtual/notification-daemon-0:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following packages are causing rebuilds:

  (media-gfx/exiv2-0.26:0/26::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (kde-apps/kio-extras-17.04.1:5/5::gentoo, ebuild scheduled for merge)
    (media-libs/gexiv2-0.10.6:0/0::gentoo, ebuild scheduled for merge)
    (kde-frameworks/kfilemetadata-5.34.0:5/5.34::gentoo, ebuild scheduled for merge)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21335
Location: here

PostPosted: Thu Jun 08, 2017 9:55 am    Post subject: Reply with quote

You need to add kde use flag to virtual/notification-daemon (virtual not x11-misc)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
brutico
Tux's lil' helper
Tux's lil' helper


Joined: 16 Feb 2014
Posts: 130

PostPosted: Thu Jun 08, 2017 10:17 am    Post subject: Reply with quote

Impressive how quickly we help users.
Thank you!
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2858
Location: Bay Area, CA

PostPosted: Thu Jun 08, 2017 3:56 pm    Post subject: Reply with quote

Code:
[ebuild  N     ] virtual/notification-daemon-0::gentoo  USE="gnome kde" 0 KiB

I have that use flag and it still blocks the same way. What's up with that?
Code:
[ebuild     U  ] kde-plasma/plasma-meta-5.10.1:5::gentoo [5.9.5:5::gentoo] USE="bluetooth display-manager gtk pam pulseaudio sddm wallpapers -grub -handbook -networkmanager -plymouth -sdk" 0 KiB
[blocks B      ] x11-misc/notification-daemon ("x11-misc/notification-daemon" is blocking kde-plasma/plasma-workspace-5.10.1)

Total: 59 packages (46 upgrades, 2 new, 2 in new slots, 9 reinstalls), Size of downloads: 175021 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-plasma/plasma-workspace-5.10.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/plasma-workspace-5.10.1:5 required by (kde-plasma/powerdevil-5.10.1:5/5::gentoo, ebuild scheduled for merge)
    kde-plasma/plasma-workspace required by (virtual/notification-daemon-0:0/0::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.10.1:5 required by (kde-plasma/kdeplasma-addons-5.10.1:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.10.1:5 required by (kde-plasma/plasma-nm-5.10.1:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.10.1:5 required by (kde-plasma/plasma-meta-5.10.1:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.10.1:5 required by (kde-plasma/khotkeys-5.10.1:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/plasma-workspace-5.10.1:5 required by (kde-plasma/plasma-desktop-5.10.1:5/5::gentoo, ebuild scheduled for merge)

  (x11-misc/notification-daemon-3.20.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    x11-misc/notification-daemon required by (virtual/notification-daemon-0:0/0::gentoo, ebuild scheduled for merge)
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 772

PostPosted: Thu Jun 08, 2017 4:09 pm    Post subject: Reply with quote

USE="-gnome kde" for virtual/notification-daemon
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21335
Location: here

PostPosted: Thu Jun 08, 2017 4:20 pm    Post subject: Reply with quote

Perfect Gentleman wrote:
USE="-gnome kde" for virtual/notification-daemon

Maybe can be solved in ebuild with REQUIRED_USE="kde? ( !gnome )" (for a best message)?
It's a question for developer.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Jun 10, 2017 6:48 am    Post subject: Reply with quote

The blocker has been in plasma-workspace itself, but was dropped since upstream apparently fixed the colliding file name before release.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum