Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Xorg segmentation fault
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
radeczek
n00b
n00b


Joined: 21 Oct 2006
Posts: 16

PostPosted: Wed Jun 07, 2017 6:42 am    Post subject: [SOLVED] Xorg segmentation fault Reply with quote

Hi,
since yesterdays big (~120 packages) update I have troubles with running Xorg (ends with segmentation fault). xorg-server was upgraded to 1.19.3. Log:
Code:
[  3586.938] (--) Log file renamed from "/var/log/Xorg.pid-4127.log" to "/var/log/Xorg.0.log"
[  3586.938]
X.Org X Server 1.19.2
Release Date: 2017-03-02
[  3586.938] X Protocol Version 11, Revision 0
[  3586.938] Build Operating System: Linux 4.9.16-gentoo x86_64 Gentoo
[  3586.938] Current Operating System: Linux radeczek 4.9.16-gentoo #1 SMP Mon May 15 16:40:49 CEST 2017 x86_64
[  3586.938] Kernel command line: BOOT_IMAGE=Gentoo ro root=802 video=vesafb:1024x768-32@85,mttr,ywrap,splash=silent,fadein,theme:natural_gentoo quiet CONSOLE=/dev/tty1 nouveau.modeset=1
[  3586.938] Build Date: 07 June 2017  07:17:11AM
[  3586.938] 
[  3586.938] Current version of pixman: 0.34.0
[  3586.938]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  3586.938] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  3586.938] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun  7 08:01:32 2017
[  3586.939] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  3586.939] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  3586.939] (==) No Layout section.  Using the first Screen section.
[  3586.939] (==) No screen section available. Using defaults.
[  3586.939] (**) |-->Screen "Default Screen Section" (0)
[  3586.939] (**) |   |-->Monitor "<default monitor>"
[  3586.939] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[  3586.939] (==) Automatically adding devices
[  3586.939] (==) Automatically enabling devices
[  3586.939] (==) Automatically adding GPU devices
[  3586.939] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  3586.939] (==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[  3586.939] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  3586.939] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  3586.939] (II) Loader magic: 0x813cc0
[  3586.939] (II) Module ABI versions:
[  3586.939]    X.Org ANSI C Emulation: 0.4
[  3586.939]    X.Org Video Driver: 23.0
[  3586.939]    X.Org XInput driver : 24.1
[  3586.939]    X.Org Server Extension : 10.0
[  3586.940] (II) xfree86: Adding drm device (/dev/dri/card0)
[  3586.940] (EE)
[  3586.940] (EE) Backtrace:
[  3586.940] (EE) 0: /usr/bin/X (xorg_backtrace+0x56) [0x58a076]
[  3586.940] (EE) 1: /usr/bin/X (0x400000+0x18dd29) [0x58dd29]
[  3586.940] (EE) 2: /lib64/libpthread.so.0 (0x7f43eb5a4000+0x10f90) [0x7f43eb5b4f90]
[  3586.940] (EE) 3: /lib64/libc.so.6 (strlen+0x26) [0x7f43eb2892b6]
[  3586.941] (EE) 4: /lib64/libc.so.6 (__strdup+0xe) [0x7f43eb288fde]
[  3586.941] (EE) 5: /usr/lib64/libdrm.so.2 (drmGetVersion+0xde) [0x7f43ec5aef4e]
[  3586.941] (EE) 6: /usr/bin/X (0x400000+0x98791) [0x498791]
[  3586.941] (EE) 7: /usr/bin/X (0x400000+0x989e3) [0x4989e3]
[  3586.941] (EE) 8: /usr/bin/X (0x400000+0x959b3) [0x4959b3]
[  3586.941] (EE) 9: /usr/bin/X (0x400000+0x92ebe) [0x492ebe]
[  3586.941] (EE) 10: /usr/bin/X (xf86BusProbe+0x9) [0x46acd9]
[  3586.941] (EE) 11: /usr/bin/X (InitOutput+0x71d) [0x4796dd]
[  3586.941] (EE) 12: /usr/bin/X (0x400000+0x39606) [0x439606]
[  3586.941] (EE) 13: /lib64/libc.so.6 (__libc_start_main+0xf0) [0x7f43eb22b790]
[  3586.941] (EE) 14: /usr/bin/X (_start+0x29) [0x4238a9]
[  3586.941] (EE)
[  3586.941] (EE) Segmentation fault at address 0x7
[  3586.941] (EE)
Fatal server error:
[  3586.941] (EE) Caught signal 11 (Segmentation fault). Server aborting
[  3586.941] (EE)
[  3586.941] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  3586.941] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  3586.941] (EE)
[  3586.941] (EE) Server terminated with error (1). Closing log file.



Emerge info:
Code:
Portage 2.3.5 (python 2.7.12-final-0, default/linux/amd64/13.0, gcc-4.9.4, glibc-2.23-r3, 4.9.16-gentoo x86_64)
=================================================================
System uname: Linux-4.9.16-gentoo-x86_64-Intel-R-_Core-TM-_i5_CPU_M_450_@_2.40GHz-with-gentoo-2.3
KiB Mem:     8036396 total,   7223396 free
KiB Swap:    2987424 total,   2987424 free
Timestamp of repository gentoo: Wed, 07 Jun 2017 04:00:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.26.1 p1.0) 2.26.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.2.5-r6::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.26.3::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.9.6-r3::gentoo, 1.11.6-r1::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.26.1::gentoo
sys-devel/gcc:            4.9.4::gentoo, 5.4.0-r3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

dotnet
    location: /var/lib/layman/dotnet
    masters: gentoo
    priority: 50

kde
    location: /var/lib/layman/kde
    masters: gentoo
    priority: 50

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 50

ssnb
    location: /var/lib/layman/ssnb
    masters: gentoo
    priority: 50

steam-overlay
    location: /var/lib/layman/steam-overlay
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-11.x skype-eula skype-4.0.0.7-copyright dlj-1.1 Oracle-BCLA-JavaSE PUEL RAR"
CBUILD="x86_64-pc-linux-gnu"
CC="gcc"
CFLAGS="-march=core2 -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-2.2/conf /usr/share/maven-bin-3.0/conf /usr/share/maven-bin-3.1/conf /usr/share/maven-bin-3.2/conf /usr/share/maven-bin-3.3/conf /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php5.6/ext-active/ /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LC_ALL="cs_CZ.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="64bit X \ aac acl acpi alsa amd64 apache2 apm berkdb bzip2 cairo cdda cli connection-sharing consolekit cracklib crypt cuda cups cxx dbus dhclient dhcpcd dri dvdr faac ffmpeg firefox fortran g3dvl gd gdbm git gnutls gtk2 iconv icq icu ipv6 jabber jack java jpeg kde legacy-systray mmx mng modules mp3 mplayer mtp multilib mysql mysqli ncurses net45 networkmanager nls nptl ntfs nvidia ogg opengl openmp oscar pam pcre pdf pdo png qt3support qt4 readline samba seccomp session spell sql sqlite sse sse2 ssl suhosin svg tcpd theora unicode vdpau vnc vorbis webkit x264 xattr xinerama zip zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_core authn_dbm authn_file authz_core authz_dbm authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir env expires ext_filter file_cache filter headers include info log_config logio mime mime_magic negotiation rewrite setenvif socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias access_compat" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="mouse keyboard evdev synaptics" KERNEL="linux" L10N="cs" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="cs" NETBEANS_MODULES="nb cnd php dlight harness ide websvccommon java" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


I have tryed reinstall libdrm, downgrade xorg-server and libdrm. But nothing helped.

Any suggestions what is wrong?
Thank you.
Back to top
View user's profile Send private message
radeczek
n00b
n00b


Joined: 21 Oct 2006
Posts: 16

PostPosted: Wed Jun 07, 2017 9:55 am    Post subject: Reply with quote

That was really weird. After about 2hours of trying different combinations of versions of xorg-server. libdrm, xorg drivers etc. I desperatelly tryed upgrade/re-emerge glibc. After that everything is working with current versions (xorg-server-1.19.3, libdrm-2.4.80).
So, my problem is solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum