Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo und Ryzen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 374
Location: 09xxx

PostPosted: Mon Jun 05, 2017 4:16 pm    Post subject: Gentoo und Ryzen Reply with quote

Hallo,

ich plane für den Spätsommer einen neuen PC mit einer Ryzen-CPU. Nun irritiert mich ein wenig die Meldung bei fefe im Blog.
https://community.amd.com/message/2796982
https://forums.gentoo.org/viewtopic-t-1061546-postdays-0-postorder-asc-start-0.html

Hat hier schon jemand eine Ryzen-CPU im Einsatz und kann etwas dazu sagen und wie sieht es perspektivisch aus mit den Problemen (im gentoo forum)?
_________________
Linux ryzen 4.12.5-gentoo #25 SMP Sat Sep 16 12:38:21 CEST 2017 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1426
Location: Schweiz

PostPosted: Wed Jun 07, 2017 5:58 am    Post subject: Reply with quote

So weit ich weiß (es gab dazu mal einen Artikel auf Heise) hatte der AM4-Microcode, welcher vom BIOS in die CPU geladen wird, einen Fehler den AMD inzwischen korrigiert hat. Wenn also das BIOS/UEFI den aktuellen Microcode für die neuen CPU's enthält sollte es wohl keine Probleme mehr geben.

EDIT:
Mein Spielerechner ist inzwischen eine solche AM4-Kiste und bis jetzt ist zumindest unter Windows noch nichts abgestürzt. Für die Installation von Linux hatte ich noch keine Zeit.
_________________
GPG: B5114B6154A19454
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 374
Location: 09xxx

PostPosted: Fri Jun 09, 2017 7:35 am    Post subject: Reply with quote

Hallo,
schmidicom wrote:
So weit ich weiß (es gab dazu mal einen Artikel auf Heise) hatte der AM4-Microcode, welcher vom BIOS in die CPU geladen wird, einen Fehler den AMD inzwischen korrigiert hat. Wenn also das BIOS/UEFI den aktuellen Microcode für die neuen CPU's enthält sollte es wohl keine Probleme mehr geben.

Ich kenne bzw. verfolge Heise zu dem Thema. AMD fixt imho derzeit mit den AGESA Updates so einiges. Aber scheinbar ist da das Ende der Fahnenstange noch lange nicht erreicht, wenn man die erwähnten Threads verfolgt. :evil:
Neuer Thread dazu: https://www.phoronix.com/forums/forum/hardware/processors-memory/955368-some-ryzen-linux-users-are-facing-issues-with-heavy-compilation-loads

Quote:

Mein Spielerechner ist inzwischen eine solche AM4-Kiste und bis jetzt ist zumindest unter Windows noch nichts abgestürzt. Für die Installation von Linux hatte ich noch keine Zeit.

Gerade unter Linux scheint es ja Probleme zu geben, warum auch immer (ich schätze Gentoo reizt da aus, was technisch geht).
_________________
Linux ryzen 4.12.5-gentoo #25 SMP Sat Sep 16 12:38:21 CEST 2017 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 59

PostPosted: Sat Jun 10, 2017 4:37 am    Post subject: edit 22.06. Reply with quote

Als eigene Platform-Erfahrung (siehe unten) 4 Wochen in Betrieb ohne Übertakten mit win10 und Gentoo (monolithischer Kernel). Vorgängerplattform war ein AMD Phenom(tm) II X4 965 auf einem GA-890GPA-UD3H.
Das X370 Mainboard hat noch eine kleine Hängepartie mit dem Kernel 4.11. https://forums.gentoo.org/viewtopic-t-1063214.html - liegt aber an der Ausstattung mit zwei 1220 Chips. Auf dem alten System einen 4.11 Kernel mit den Ergänzungen für die neue Hardware vom Motherboard gebaut und dann auf das neue Equipment gewechselt, Laufwerke angeschlossen und alles lief.

Das BIOS war noch bei AGESA 1004. Damit gibt es noch RAM-Probleme. Ich hatte mich bewusst nur für 2400-er Module entschieden, die vom BIOS automatisch nur auf 2133 gestartet wurden. Mit Auswahl des XMP-Profil 1 liefen Sie mit 2400. Allerdings dann auch gelegentlich mit Segfault Abbrüchen beim Compilieren. Ein zweiter Anlauf für das gleiche Programm lief dann meist durch. Mit 2133 gab es nie Probleme. Es gibt jetzt ein Beta Bios mit AGESA 1006, das ich aber noch nicht getestet habe. In einschlägigen Foren bei Gigabyte wird von einer deutlichen Verbesserung der RAM-Erkennung berichtet, insbesondere von den Modulen für hohe Taktraten, die auch ohne Auswahl XMP-Profil automatisch für den hohen Takt erkannt werden und nicht nur mit 2133 gestartet werden.

In der make.conf hatte ich mit cpuid2cpuflags die CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" aktualisiert, -j17 eingestellt und bei CFLAGS -mtune-native stehen lassen. Damit war erstmal die Grundlage für ein lauffähiges und compilierfähiges System gegeben.

Das Beta BIOS habe ich noch nicht ausprobiert, da ich das MoBo gestern wieder eingeschickt habe. Es verlor nach dem Runterfahren nicht reproduzierbar die Netzteilspannung und ließ sich nach dem 3. Auftreten zwar wiederbeleben aber nicht mehr booten.

P.S. Win 10 startete ohne Neuinstallation und benötigte nur einige Treiberaktualisierungen.

Insgesamt gesehen also lauffähig mit einigen Early Bird Unzulänglichkeiten.

edit:
MoBo ist wieder zurück und läuft inzwischen mit BIOS F4e mit AGESA 1.0.0.6. Segfaults hatte ich mit allen Standardeinstellungen (RAM mit xmp1 Profil) keine mehr. Allerdings war mesa-17.1.3 mit gcc-5.4.0 nicht zu bauen. Mittendrin gab es eine Reihe emake Fehler mit Abbruch. Ich habe gcc-6.3.0 demaskiert, den Upgradeprozess durchgeführt und versucht Mesa zu bauen. Abbruch an der gleichen Stelle beim Bauen von mesa. gcc-6.3.0 mit "sich selbst" noch mal gebaut(ob so was Sinn macht weiß ich nicht) libtool und llvm auch noch mit dem "erneuerten" gcc-6.3.0 neugebaut. Jetzt funktionierte der Bau von mesa. Ich habe mal eine Schleife von 20 x mesa bauen laufen lassen - alles ohne Aussteiger.
_________________
Kernel 4.13.xx-gentoo
GCC 6.4.0
Profile amd64/13.0/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F7a
ATI 270X
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 374
Location: 09xxx

PostPosted: Wed Aug 09, 2017 4:29 pm    Post subject: Reply with quote

Und ein neues Problem taucht auf: https://www.heise.de/newsticker/meldung/SegFault-Bug-AMD-bestaetigt-Ryzen-Fehler-beim-Kompilieren-unter-Linux-3796688.html

Nun frage ich mich gerade, bei Gentoo erlebt man ja teilweise ganze Compiler-Orgien (firefox, libreoffice, etc.). Da sind solche segfaults nicht hilfreich, oder? Anders gefragt, gibt es bei den Ryzen-Usern solche segfaults aktuell beim compilieren (so ala emerge -auvDN world)?
_________________
Linux ryzen 4.12.5-gentoo #25 SMP Sat Sep 16 12:38:21 CEST 2017 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 59

PostPosted: Wed Aug 09, 2017 8:34 pm    Post subject: Ryzen und Gentoo Reply with quote

https://community.amd.com/thread/215773?start=690&tstart=0 ist die Seite im Thread mit der Info von AMDMatt. Wenn Du das Thema über die Posts etwas verfolgst, sind die Segfaults erzeugbar, aber nicht immer reproduzierbar an der gleichen Stelle. Das macht eine dedizierte Fehlerbestimmung m.E. schwierig.

Mein Ryzen 1700 murkst da auch etwas, allerdings nur bei mesa. Ich benötige dann manchmal einen 2. oder 3. Anlauf. BIOS mit AGESA1.0.0.6a ist mindestens Pflicht, gcc-6.4 sicher nicht von Nachteil. Außer mesa habe ich bei keinem weiteren Paket Segfaults. emerge -uD -newuse world läuft bis jetzt klaglos durch, wenn kein mesa dabei ist. Also heute brauchte ich für mesa-17.2.0-rc3 einen 2. Anlauf. Der Abbruch erfolgte allerdings schon mit einem emake Error
und das log lieferte
sh[29145] general protection ip:7fd461765620 sp:7ffd943006c8 error:0 in libc-2.23.so[7fd461646000+18c000]

Ich vermag nicht einzuschätzen, ob ein Microcodeupdate das verbessern wird oder wir alle noch RMAs an AMD schicken werden, um verbessertes Silizium zu bekommen. Mit einem Ryzen für Gentoo würde ich momentan jedenfalls noch warten.
_________________
Kernel 4.13.xx-gentoo
GCC 6.4.0
Profile amd64/13.0/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F7a
ATI 270X
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 374
Location: 09xxx

PostPosted: Fri Aug 11, 2017 9:19 am    Post subject: Reply with quote

Hallo,

könntest Du mal das Stepping Deiner CPU posten!? Es scheint so, als wäre der Fehler in den neuen Steppings (Zeppelin B2) nicht mehr enthalten (siehe Kommentare bei Heise).
_________________
Linux ryzen 4.12.5-gentoo #25 SMP Sat Sep 16 12:38:21 CEST 2017 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 59

PostPosted: Fri Aug 11, 2017 4:55 pm    Post subject: Stepping Reply with quote

Wird noch ein wenig dauern. Ich habe erst nächstes WE Gelegenheit die Kiste wieder auseinander zu pflücken. Ich will dann auch Anlauf über AMD Customer care nehmen.

Gruß
demiurg
_________________
Kernel 4.13.xx-gentoo
GCC 6.4.0
Profile amd64/13.0/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F7a
ATI 270X
Back to top
View user's profile Send private message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 59

PostPosted: Sat Aug 26, 2017 4:04 pm    Post subject: Ryzen und Gentoo Reply with quote

Ich habe mir das mit dem Stepping und der Herstellungswoche mal gespart und den Kühler drauf gelassen. Dafür den Weg über AMD customer care angestoßen. Es lauft jetzt mal die Standardprozedur, Bildschirmfotos vom BIOS, Temperaturüberwachung unter Last (Spaßvögel - geben noch kein Spezifikationen zum real-time Ermitteln der Chiptemperatur durch den Kernel raus) Für das Gerümpel wie https://linuxconfig.org/monitor-amd-ryzen-temperatures-in-linux-with-latest-kernel-modules fehlt mir im Moment auch die Zeit. Im Bios konnte ich wenigstens die Alarmtemperatur auf 60°C setzen und da gab es keinen Alarm wegen Temp >60°C dafür aber weiter segfaults.

Schauen wir mal, wie es weitergeht. Jedenfalls gibt es in diversen Foren Hinweise und aktuelle RMA Abwicklungen, dass die Produktion ab KW 27/2017 stabil läuft.

Gruß
demiurg
_________________
Kernel 4.13.xx-gentoo
GCC 6.4.0
Profile amd64/13.0/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F7a
ATI 270X
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3217
Location: Germany

PostPosted: Tue Sep 05, 2017 1:29 pm    Post subject: Reply with quote

Jo, ist wohl nun auch halbwegs offiziell, und betroffene CPUs sollten ohne viel Aufwand ausgetauscht werden
laut https://www.golem.de/news/performance-marginality-amd-ersetzt-fehlerhafte-ryzen-7-prozessoren-1709-129873.html
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1426
Location: Schweiz

PostPosted: Tue Sep 05, 2017 2:00 pm    Post subject: Reply with quote

Besser wäre ein offizielles kleines Programm, meinetwegen auch eines für Windows, das einem anzeigt ob der eigene Prozessor von dem Fehler betroffen ist oder nicht. Denn das Testprogramm aus dem Artikel braucht ja stellenweise bis zu mehrere Stunden um den Fehler aufzudecken.
_________________
GPG: B5114B6154A19454
Back to top
View user's profile Send private message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 59

PostPosted: Mon Sep 18, 2017 4:15 pm    Post subject: Ryzen und Gentoo Reply with quote

Es gab eine kleine Urlaubspause.
Unter dem Strich ist alles ausgeschlossen worden, was helfen könnte bzw. Ursache sein könnte. Selbst das Beta-BIOS für das Board mit AGESA 1.0.0.6b , was ich gestern nach dem Urlaub ausprobiert habe, bringt nichts. Vom AMD Kundendienst habe ich einen Link für ein RMA Ticket bekommen, den Antrag gestern ausgefüllt und erst mal eine automatisierte Registrierung bekommen. Versandhinweise gibt es dann per Mail und wenn das Teil auf dem Weg ist, Info an den Kundenservice, damit der Ersatz sozusagen parallel auf den Weg gebracht wird. Ich gehe mal davon aus, dass es so auch wird.

Merkwürdigerweise ist das compilieren von mesa bei mir die beste Variante Segfaults zu produzieren. Das klappt sowohl ohne weitere "Grundlast" als auch mit "Grundlast" wie emerge gcc und emerge libreoffice in jeweils einer weiteren Konsole, die für sich auch schon mal über lange Strecken 100% CPU verursachen. Mesa verabschiedet sich dann zu völlig willkürlichen Zeitpunkten sicher mit einem Segfault. GCC verabschiedet sich selten und libreoffice nie.

Ich halte Euch auf dem Laufenden.

Edit 25.09. : Die CPU (Produziert KW 13 2017) ist auf dem Weg zum Austausch.

Gruß
demiurg
_________________
Kernel 4.13.xx-gentoo
GCC 6.4.0
Profile amd64/13.0/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F7a
ATI 270X


Last edited by demiurg on Mon Sep 25, 2017 5:12 pm; edited 3 times in total
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 374
Location: 09xxx

PostPosted: Mon Sep 18, 2017 4:21 pm    Post subject: Reply with quote

Hallo allerseits,

ich hatte mir ja einen 1800X gegönnt. Leider hat er scheinbar auch das Problem. Wie schon berichtet, bei mir ist es auch mesa, was segfaults erzeugt (beim compilieren). Ich habe aber auch das kill-ryzen.sh Script benutzt, ebenfalls mit segfaults. Ich hatte ja gehofft, das ich mit dem etwas späteren Kauf eine später gefertigte CPU bekomme, leider war dem wohl nicht so. :(

Nunja, ich habe die CPU bei AMD reklamiert, mal schauen wie das weiter geht.
_________________
Linux ryzen 4.12.5-gentoo #25 SMP Sat Sep 16 12:38:21 CEST 2017 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 59

PostPosted: Wed Oct 04, 2017 7:58 pm    Post subject: Ryzen und Gentoo Reply with quote

So, eben habe ich den PC mit einem neuen Ryzen aus KW 33 hochgefahren. RMA Abwicklung hat funktioniert. AMD hat einen DHL Express Account für mein RMA angelegt, damit ich keine Versandkosten nach Holland tragen muss. Die alte CPU ist dann durch die Sichtkontrolle wegen mech. Unversehrtheit gelaufen und es gab eine Info, dass die o.k. war, allerdings das Lager mit Ersatz-CPU aufgefüllt werden muss, was zum 02.10. erwartet wurde. Insofern passt die Zustellung für nach dem Feiertag in D. Allerdings gab es keine Info mehr, dass die CPU in die Post gegangen ist, sondern sie war dann einfach da.

Ich lasse mal emerge -uD --newuse world laufen, da ist dann mesa-17.2.2 mit dabei.

edit: 5x mesa ohne Fehler compiliert - sieht gut aus.

Gruß
demiurg
_________________
Kernel 4.13.xx-gentoo
GCC 6.4.0
Profile amd64/13.0/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F7a
ATI 270X
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum