Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE Frameworks 5.34 stabilisation & (old) KWallet migration
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6829
Location: Austria

PostPosted: Mon Jun 05, 2017 9:01 am    Post subject: KDE Frameworks 5.34 stabilisation & (old) KWallet migrat Reply with quote

KDE Frameworks 5.34.0 is right now in the process of being stabilised. For people using stable KDE PIM 4 (which is our only stable PIM to this date) this likely represents a major change wrt passwords management. Had so far kde-apps/kwalletd:4 been necessary to run alongside kde-frameworks/kwallet for these old applications to be able to store their passwords, this is now completely taken over by kde-frameworks/kwallet-5.34.0, making the old kde-apps/kwalletd obsolete.

Now, migration does not always work fine, unfortunately, and the KDE Wiki is covering that: https://wiki.gentoo.org/wiki/KDE#KWallet

You can take a shortcut to the possible manual workaround though, by using kde-apps/kwalletmanager:4 to export your old passwords as XML before you upgrade to Frameworks 5.34.0, then import them via kde-apps/kwalletmanager:5 after the upgrade just in case the migration has not worked.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1575
Location: /mnt/Gentoo/Europe

PostPosted: Mon Jun 05, 2017 1:13 pm    Post subject: Reply with quote

Hi,

I did a system update Today, and kmail start says:
You are asked here because the walled password storage is disabled.
Kwallet works fine eg. for Chrome.

What shoud I do now? Dwongrade the system as before Today's update or I could do different steps?
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1469
Location: KUUSANKOSKI, Finland

PostPosted: Mon Jun 05, 2017 1:18 pm    Post subject: Reply with quote

I think this should be in the news -subforum to get more attention at the top of the forums main page.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6829
Location: Austria

PostPosted: Mon Jun 05, 2017 1:33 pm    Post subject: Reply with quote

Xywa wrote:
I did a system update Today, and kmail start says:
You are asked here because the walled password storage is disabled.

Do you have kde-frameworks/kwallet installed? Did you disable kwallet:5 for some reason?

Code:
grep Enabled ~/.config/kwalletrc

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Drittelhacker
n00b
n00b


Joined: 29 Aug 2006
Posts: 3

PostPosted: Thu Jun 08, 2017 6:56 am    Post subject: Re: KDE Frameworks 5.34 stabilisation & (old) KWallet mi Reply with quote

asturm wrote:
KDE Frameworks 5.34.0 is right now in the process of being stabilised. For people using stable KDE PIM 4 (which is our only stable PIM to this date) this likely represents a major change wrt passwords management. Had so far kde-apps/kwalletd:4 been necessary to run alongside kde-frameworks/kwallet for these old applications to be able to store their passwords, this is now completely taken over by kde-frameworks/kwallet-5.34.0, making the old kde-apps/kwalletd obsolete.


This is only partially true. While it is true for KDE itself, there might be non-KDE applications that rely on the kde-apps/kwalletd package. In my case for example dev-vcs/subversion, due to the kwallet flag enabled, pulls in the old wallet. So it is not entirely obsolete. I have not checked whether in principle subversion would work with the new wallet as well, but the ebuild is rather strick here:
Code:
dev-vcs/subversion-1.9.5 (kwallet ? kde-apps/kwalletd:4)
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1575
Location: /mnt/Gentoo/Europe

PostPosted: Thu Jun 08, 2017 8:21 am    Post subject: Reply with quote

asturm wrote:
Xywa wrote:
I did a system update Today, and kmail start says:
You are asked here because the walled password storage is disabled.

Do you have kde-frameworks/kwallet installed? Did you disable kwallet:5 for some reason?

Code:
grep Enabled ~/.config/kwalletrc


I think I have kwallet:5, but inside I have 2 wallets.
1 - for everything
kdewallet - created automaticly by kmail (after migration)

The problem is, when I open kmail, I should have automaticly a question about password for wallet for kmail, but is not like used to be. So I have to manually start kwalletmanager, open "kdewallet" there, so then I could use kmail normally.

When I open Opera or Firefox, it ask me automaticly for password for kwallet, only kmail not.
Code:
$ cat .config/kwalletrc
[Wallet]
Default Wallet=1
First Use=false[/
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6829
Location: Austria

PostPosted: Thu Jun 08, 2017 12:01 pm    Post subject: Reply with quote

Then may be you had not allowed wallet access to kmail. There are per-application access settings in kwalletmanager as well.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
sokhapkin
n00b
n00b


Joined: 13 Jan 2005
Posts: 33
Location: N Ft Myers, FL

PostPosted: Mon Jun 12, 2017 10:15 pm    Post subject: Re: KDE Frameworks 5.34 stabilisation & (old) KWallet mi Reply with quote

asturm wrote:
KDE Frameworks 5.34.0 is right now in the process of being stabilised. For people using stable KDE PIM 4 (which is our only stable PIM to this date)


What is blocking KDE PIM 5 from stabilisation? PIM 4 is pretty unusable on plasma 5 because of missed reminder agent. I run kdepim-meta 17.04 (korganaser and kmail) without issues.
_________________
Sergey Okhapkin
http://www.callwithus.com
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6829
Location: Austria

PostPosted: Tue Jun 13, 2017 6:44 am    Post subject: Reply with quote

This is not a thread for discussing KDE PIM.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum