Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Localization in Plasma: how to fix backets
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Jackie Lin
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2017
Posts: 89

PostPosted: Sat Jun 03, 2017 9:32 am    Post subject: Localization in Plasma: how to fix backets Reply with quote

Hello, threre.
I am making localization in Plasma, I followed this guide https://wiki.gentoo.org/wiki/Localization/Guide and https://wiki.gentoo.org/wiki/KDE#Localization.
I added "nls" in USE flag and LINGUAS="en zh" L10N="en zh" in make.conf.
I emerged kde-l10n.Finally I emerge --update --newuse --deep --with-bdeps=y @world, nothing is done. But after I rebooted the system, the menus and panels of Plasma display brackets like [][].
Should I reemerge kde-plasma/plasma-meta?
What should I do to fix this problem? Could anyone help me? Thanks!
_________________
peace, focus.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Jun 03, 2017 11:23 am    Post subject: Reply with quote

There is no need to add the nls flag manually as it is enabled on linux profiles by default - as the wiki says. That's why you found nothing to rebuild. KDE Localisation guide only covers the installation of translations for applications, Frameworks and Plasma come with translations shipped already, so it seems something must have gone wrong following the regular Localisation guide.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Jackie Lin
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2017
Posts: 89

PostPosted: Sat Jun 03, 2017 12:10 pm    Post subject: Reply with quote

Thanks, asturm. I installed some opensource Chinese fonts such as wqy-zenhei and wqy-microhei. and everything is displayed correctly. :D
_________________
peace, focus.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum