Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Issues with Xwayland with nvidia proprietary
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
white_tiger
n00b
n00b


Joined: 04 Oct 2011
Posts: 40

PostPosted: Fri Jun 02, 2017 6:06 pm    Post subject: Issues with Xwayland with nvidia proprietary Reply with quote

Hello,

I have compiled sway to see if it is to my liking and in a way I must say that I like it. Oke there are a few things that still need to be implied compared to others, but it is nice to play with and I play with it allot.
There lays my problem. The howto for wayland on gentoo is almost non existing and the one on the arch website does consider options I cannot seem to find in gentoo.

What I did is set wayland and xwayland in my make.conf, did an emerge world update newuse. I did set nvidia-drm.modeset=1 to tjhe kernel parameters, did make an inframfs to see if I could also add nvidia, nvidia_modeset, nvidia_uvm and nvidia_drm to my initramfs MODULES. (nope could not find it nor how to do that in gentoo). But after a restart I tried sway and wow it worked :) Happy me.

Mhh according to the website of sway I could also run glxgears, do i tried but no it does not run. It gives me an error:
Code:

Error: couldn't get an RGB, Double-buffered visual


mhh oke so what about glxinfo? also nothing

Code:

name of display: :1
Error: couldn't find RGB GLX visual or fbconfig


OKe problem, searching on the internet but al I could find was to reinstall Libgl and remove xorg.conf. Oke I did removed the autogenerated xorg.conf and reinstalled Mesa (as far as I know libgl is part of mesa), restarted and tried again. Still the same errors. This made me think if there was even an xwayland session running

Code:

  0.7  0.3 351348 47832 tty2     Sl+  19:33   0:11 Xwayland :1 -rootless -terminate -listen 57 -listen 58 -wm 62


OKe just see if sway is also running on tty2 (read about the gnome bug)

Code:

0.0  0.0 140252  1196 tty2     S+   19:33   0:00 sway


Yes it is.

So I have wayland running, I can use sway normaly but I cannot use any X programs like a test with glxinfo or glxgears, so what can I do the make this working?

Please help

//

Oke did set nouveau as driver for wayland sessions and now it all works, but how to manage it with the proprietary drivers is still not clear. Maybe in the future sometimes.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum