Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] wlan - no ip
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
michi-monster
Apprentice
Apprentice


Joined: 16 Aug 2016
Posts: 175
Location: Germany

PostPosted: Fri May 19, 2017 5:08 pm    Post subject: [solved] wlan - no ip Reply with quote

Hello,
i have configuried the wlan. But i dont get an ip. Network with LAN is ok. i have recherched to many informations. I dont find an error. Please help.

Code:

#less /etc/wpa_supplicant.conf
usage: wpa_passphrase <ssid> [passphrase]

If passphrase is left out, it will be read from stdin
# Allow users in the 'wheel' group to control wpa_supplicant
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=wheel

# Make this file writable for wpa_gui / wpa_cli
update_config=1
network={
        ssid="SysNummer800"
        #psk="/etc/init.d/apache2start"
        psk=79eeb4639e68a5f33d9a467a1035b9fa9f1167731a8f68e4778b7d4876e53ecb
}


>>> Installing (1 of 1) net-misc/dhcpcd-6.11.3::gentoo
 * checking 19 files for package collisions
>>> Merging net-misc/dhcpcd-6.11.3 to /
--- /lib64/
>>> /lib64/dhcpcd/
>>> /lib64/dhcpcd/dev/
>>> /lib64/dhcpcd/dev/udev.so
--- /etc/
--- /etc/init.d/
>>> /etc/init.d/dhcpcd
>>> /etc/dhcpcd.conf
--- /var/
--- /var/lib/
>>> /var/lib/dhcpcd/
--- /lib/
--- /lib/dhcpcd/
>>> /lib/dhcpcd/dhcpcd-hooks/
>>> /lib/dhcpcd/dhcpcd-hooks/20-resolv.conf
>>> /lib/dhcpcd/dhcpcd-hooks/50-yp.conf
>>> /lib/dhcpcd/dhcpcd-hooks/01-test
>>> /lib/dhcpcd/dhcpcd-hooks/50-ntp.conf
>>> /lib/dhcpcd/dhcpcd-hooks/02-dump
>>> /lib/dhcpcd/dhcpcd-hooks/30-hostname
>>> /lib/dhcpcd/dhcpcd-run-hooks
--- /sbin/
>>> /sbin/dhcpcd
--- /usr/
--- /usr/share/
--- /usr/share/doc/
>>> /usr/share/doc/dhcpcd-6.11.3/
>>> /usr/share/doc/dhcpcd-6.11.3/README.bz2
--- /usr/share/man/
--- /usr/share/man/man5/
>>> /usr/share/man/man5/dhcpcd.conf.5.bz2
--- /usr/share/man/man8/
>>> /usr/share/man/man8/dhcpcd-run-hooks.8.bz2
>>> /usr/share/man/man8/dhcpcd.8.bz2
>>> /usr/share/dhcpcd/
>>> /usr/share/dhcpcd/hooks/
>>> /usr/share/dhcpcd/hooks/10-wpa_supplicant
>>> /usr/share/dhcpcd/hooks/29-lookup-hostname
>>> /usr/share/dhcpcd/hooks/15-timezone
--- /usr/lib/
--- /usr/lib/systemd/
--- /usr/lib/systemd/system/
>>> /usr/lib/systemd/system/dhcpcd.service
 *
 * dhcpcd has zeroconf support active by default.
 * This means it will always obtain an IP address even if no
 * DHCP server can be contacted, which will break any existing
 * failover support you may have configured in your net configuration.
 * This behaviour can be controlled with the noipv4ll configuration
 * file option or the -L command line switch.
 * See the dhcpcd and dhcpcd.conf man pages for more details.
 *
 * Dhcpcd has duid enabled by default, and this may cause issues
 * with some dhcp servers. For more information, see
 * https://bugs.gentoo.org/show_bug.cgi?id=477356
 *
 * If you activate the lookup-hostname hook to look up your hostname
 * using the dns, you need to install net-dns/bind-tools.
>>> net-misc/dhcpcd-6.11.3 merged.
>>> Regenerating /etc/ld.so.cache...

>>> Recording net-misc/dhcpcd in "world" favorites file...

 * Messages for package net-misc/dhcpcd-6.11.3:

 *
 * If you activate the lookup-hostname hook to look up your hostname
 * using the dns, you need to install net-dns/bind-tools.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

sysvorOrt michi # /etc/init.d/dhcpcd stop
 * WARNING: dhcpcd is already stopped
sysvorOrt michi # killall wpa_supplicant
sysvorOrt michi # dhcpcd -dB
dhcpcd-6.11.3 starting
dev: loaded udev
enp4s0: disabling kernel IPv6 RA support
bond0: disabling kernel IPv6 RA support
wlp2s0: disabling kernel IPv6 RA support
enp4s0: executing `/lib/dhcpcd/dhcpcd-run-hooks' PREINIT
enp4s0: executing `/lib/dhcpcd/dhcpcd-run-hooks' CARRIER
bond0: executing `/lib/dhcpcd/dhcpcd-run-hooks' PREINIT
bond0: executing `/lib/dhcpcd/dhcpcd-run-hooks' NOCARRIER
wlp2s0: executing `/lib/dhcpcd/dhcpcd-run-hooks' PREINIT
wlp2s0: executing `/lib/dhcpcd/dhcpcd-run-hooks' NOCARRIER
DUID 00:01:00:01:20:b1:dd:43:70:8b:cd:a4:7a:93
enp4s0: IAID cd:a4:7a:93
enp4s0: delaying IPv6 router solicitation for 0.1 seconds
enp4s0: delaying IPv4 for 1.0 seconds
bond0: waiting for carrier
wlp2s0: waiting for carrier
enp4s0: soliciting an IPv6 router
enp4s0: sending Router Solicitation
enp4s0: Router Advertisement from fe80::ca0e:14ff:fe95:8cef
enp4s0: adding address 2a02:8108:1bf:c6f8:5843:8811:bb98:cfa3/64
enp4s0: pltime 2006 seconds, vltime 4706 seconds
enp4s0: adding route to 2a02:8108:1bf:c6f8::/64
enp4s0: adding default route via fe80::ca0e:14ff:fe95:8cef
enp4s0: waiting for Router Advertisement DAD to complete
enp4s0: requesting DHCPv6 information
enp4s0: delaying INFORM6 (xid 0xe4c1d4), next in 0.8 seconds
enp4s0: soliciting a DHCP lease
enp4s0: sending DISCOVER (xid 0xc9175f0f), next in 3.4 seconds
enp4s0: broadcasting INFORM6 (xid 0xe4c1d4), next in 1.0 seconds
enp4s0: REPLY6 received from fe80::ca0e:14ff:fe95:8cef
enp4s0: refresh in 86400 seconds
enp4s0: writing lease `/var/lib/dhcpcd/dhcpcd-enp4s0.lease6'
enp4s0: executing `/lib/dhcpcd/dhcpcd-run-hooks' INFORM6
enp4s0: offered 192.168.178.23 from 192.168.178.1
enp4s0: sending REQUEST (xid 0xc9175f0f), next in 3.6 seconds
enp4s0: acknowledged 192.168.178.23 from 192.168.178.1
enp4s0: probing address 192.168.178.23/24
enp4s0: probing for 192.168.178.23
enp4s0: ARP probing 192.168.178.23 (1 of 3), next in 1.7 seconds
enp4s0: Router Advertisement DAD completed
enp4s0: executing `/lib/dhcpcd/dhcpcd-run-hooks' ROUTERADVERT
enp4s0: ARP probing 192.168.178.23 (2 of 3), next in 1.1 seconds
enp4s0: ARP probing 192.168.178.23 (3 of 3), next in 2.0 seconds
enp4s0: DAD completed for 192.168.178.23
enp4s0: leased 192.168.178.23 for 864000 seconds
enp4s0: renew in 432000 seconds, rebind in 756000 seconds
enp4s0: writing lease `/var/lib/dhcpcd/dhcpcd-enp4s0.lease'
enp4s0: adding IP address 192.168.178.23/24 broadcast 192.168.178.255
enp4s0: adding route to 192.168.178.0/24
enp4s0: adding default route via 192.168.178.1
enp4s0: ARP announcing 192.168.178.23 (1 of 2), next in 2.0 seconds
enp4s0: executing `/lib/dhcpcd/dhcpcd-run-hooks' BOUND
enp4s0: ARP announcing 192.168.178.23 (2 of 2)
^Creceived SIGINT, stopping
wlp2s0: removing interface
wlp2s0: executing `/lib/dhcpcd/dhcpcd-run-hooks' STOPPED
bond0: removing interface
bond0: executing `/lib/dhcpcd/dhcpcd-run-hooks' STOPPED
enp4s0: removing interface
enp4s0: executing `/lib/dhcpcd/dhcpcd-run-hooks' STOPPED
dev: unloaded udev
dhcpcd exited
sysvorOrt michi # iw list
Wiphy phy0
   max # scan SSIDs: 4
   max scan IEs length: 2257 bytes
   RTS threshold: 2347
   Retry short limit: 7
   Retry long limit: 4
   Coverage class: 0 (up to 0m)
   Device supports RSN-IBSS.
   Supported Ciphers:
      * WEP40 (00-0f-ac:1)
      * WEP104 (00-0f-ac:5)
      * TKIP (00-0f-ac:2)
      * CCMP (00-0f-ac:4)
      * 00-0f-ac:10
      * GCMP (00-0f-ac:8)
      * 00-0f-ac:9
      * CMAC (00-0f-ac:6)
      * 00-0f-ac:13
      * 00-0f-ac:11
      * 00-0f-ac:12
   Available Antennas: TX 0 RX 0
   Supported interface modes:
       * IBSS
       * managed
       * AP
       * AP/VLAN
       * monitor
       * mesh point
       * P2P-client
       * P2P-GO
   Band 1:
      Capabilities: 0x1862
         HT20/HT40
         Static SM Power Save
         RX HT20 SGI
         RX HT40 SGI
         No RX STBC
         Max AMSDU length: 7935 bytes
         DSSS/CCK HT40
      Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
      Minimum RX AMPDU time spacing: 16 usec (0x07)
      HT TX/RX MCS rate indexes supported: 0-15, 32
      Bitrates (non-HT):
         * 1.0 Mbps
         * 2.0 Mbps
         * 5.5 Mbps
         * 11.0 Mbps
         * 6.0 Mbps
         * 9.0 Mbps
         * 12.0 Mbps
         * 18.0 Mbps
         * 24.0 Mbps
         * 36.0 Mbps
         * 48.0 Mbps
         * 54.0 Mbps
      Frequencies:
         * 2412 MHz [1] (20.0 dBm)
         * 2417 MHz [2] (20.0 dBm)
         * 2422 MHz [3] (20.0 dBm)
         * 2427 MHz [4] (20.0 dBm)
         * 2432 MHz [5] (20.0 dBm)
         * 2437 MHz [6] (20.0 dBm)
         * 2442 MHz [7] (20.0 dBm)
         * 2447 MHz [8] (20.0 dBm)
         * 2452 MHz [9] (20.0 dBm)
         * 2457 MHz [10] (20.0 dBm)
         * 2462 MHz [11] (20.0 dBm)
         * 2467 MHz [12] (20.0 dBm)
         * 2472 MHz [13] (20.0 dBm)
   
sysvorOrt michi # ifconfig
bond0: flags=5123<UP,BROADCAST,MASTER,MULTICAST>  mtu 1500
        ether fe:d7:63:47:dd:66  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.178.22  netmask 255.255.255.0  broadcast 192.168.178.255
        inet6 2a02:8108:1bf:c6f8:728b:cdff:fea4:7a93  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::728b:cdff:fea4:7a93  prefixlen 64  scopeid 0x20<link>
        inet6 2a02:8108:1bf:c6f8:5843:8811:bb98:cfa3  prefixlen 64  scopeid 0x0<global>
        ether 70:8b:cd:a4:7a:93  txqueuelen 1000  (Ethernet)
        RX packets 4653  bytes 3514410 (3.3 MiB)
        RX errors 0  dropped 8  overruns 0  frame 0
        TX packets 4025  bytes 416149 (406.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Lokale Schleife)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether e4:be:ed:1f:7c:f9  txqueuelen 1000  (Ethernet)
        RX packets 2943  bytes 1832116 (1.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2875  bytes 685835 (669.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


sysvorOrt michi # /etc/init.d/dhcpcd start
 * Starting DHCP Client Daemon ...                                              [ ok ]


sysvorOrt michi # rc-config list | grep 'wpa_supplicant\|dhcpcd\|net.'
  dhcpcd
  net-online
  net.enp4s0                default
  net.lo
  netmount
  wpa_supplicant            default
sysvorOrt michi # rc-update add dhcpcd
 * service dhcpcd added to runlevel default
sysvorOrt michi #

_________________
www.edv-bildung.de


Last edited by michi-monster on Sat May 20, 2017 4:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Fri May 19, 2017 5:31 pm    Post subject: Re: wlan - no ip Reply with quote

michi-monster wrote:
Code:
sysvorOrt michi # rc-config list | grep 'wpa_supplicant\|dhcpcd\|net.'
  dhcpcd
  net-online
  net.enp4s0                default
  net.lo
  netmount
  wpa_supplicant            default
sysvorOrt michi # rc-update add dhcpcd
 * service dhcpcd added to runlevel default
sysvorOrt michi #

Mixtura mirabilis. You should not start dhcpcd as a service when netifrc ( net.enp4s0 ) is in use. Use either this setup or standard from Gentoo handbook.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5594

PostPosted: Fri May 19, 2017 8:06 pm    Post subject: Reply with quote

It should be /etc/wpa_supplicant/wpa_supplicant.conf, not /etc/wpa_supplicant.conf.
Back to top
View user's profile Send private message
michi-monster
Apprentice
Apprentice


Joined: 16 Aug 2016
Posts: 175
Location: Germany

PostPosted: Sat May 20, 2017 9:00 am    Post subject: Reply with quote

OK thank you. Now I am already a step further. It was temporarily assigned an IP for the WLAN. Unfortunately, I still get no connection. In the #dmesg there is an error of the firmware.

Code:

A part of #dmesg:
[    5.118646] Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)
[    5.136825] tulip: Linux Tulip driver version 1.1.15-NAPI (Feb 27, 2007)
[    5.142062] ixgbe: Intel(R) 10 Gigabit PCI Express Network Driver - version 4.4.0-k
[    5.142108] ixgbe: Copyright (c) 1999-2016 Intel Corporation.
[    5.144612] ixgb: Intel(R) PRO/10GbE Network Driver - version 1.0.135-k2-NAPI
[    5.144658] ixgb: Copyright (c) 1999-2008 Intel Corporation.
[    5.148434] Loading iSCSI transport class v2.0-870.
[    5.826007] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[    9.266362] piix4_smbus 0000:00:14.0: SMBus Host Controller at 0xb00, revision 0
[    9.266364] piix4_smbus 0000:00:14.0: Using register 0x2e for SMBus port selection
[    9.266470] piix4_smbus 0000:00:14.0: Auxiliary SMBus Host Controller at 0xb20
[    9.275319] ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
[    9.275350] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[    9.275432] ACPI Error: [AFN7] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
[    9.275437] ACPI Error: Method parse/execution failed [\_SB.PCI0.VGA.LCD._BCM] (Node ffff880312430aa0), AE_NOT_FOUND (20160831/psparse-543)
[    9.275442] ACPI Error: Evaluating _BCM failed (20160831/video-354)
[    9.275500] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input9
[    9.283387] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[    9.357329] snd_hda_intel 0000:00:01.1: Force to non-snoop mode
[    9.366948] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.1/sound/card0/input10
[    9.389511] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input11
[    9.389623] ACPI: Power Button [PWRB]

Code:

sysvorOrt michi # wpa_cli
wpa_cli v2.6
Copyright (c) 2004-2016, Jouni Malinen <j@w1.fi> and contributors

This software may be distributed under the terms of the BSD license.
See README for more details.


Selected interface 'wlp2s0'

Interactive mode

> scan
OK
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>CTRL-EVENT-DISCONNECTED bssid=c8:0e:14:95:8c:f1 reason=4 locally_generated=1
<3>CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>SME: Trying to authenticate with c8:0e:14:95:8c:f1 (SSID='SysNummer800' freq=2412 MHz)
<3>Trying to associate with c8:0e:14:95:8c:f1 (SSID='SysNummer800' freq=2412 MHz)
<3>Associated with c8:0e:14:95:8c:f1
<3>CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
<3>CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=DE
<3>WPA: Key negotiation completed with c8:0e:14:95:8c:f1 [PTK=CCMP GTK=CCMP]
<3>CTRL-EVENT-CONNECTED - Connection to c8:0e:14:95:8c:f1 completed [id=0 id_str=]
> scan_results
bssid / frequency / signal level / flags / ssid
f4:06:8d:99:be:f4   2437   -88   [WPA2-PSK-CCMP][ESS]   devolo-f4068d99bef4
c8:0e:14:95:8c:f1   2412   -64   [WPA2-PSK-CCMP][ESS]   SysNummer800
24:65:11:94:c9:92   2412   -88   [WPA-PSK-TKIP][WPA2-PSK-CCMP][ESS]   TNGBOX1051933
90:5c:44:08:2b:fe   2412   -90   [WPA2-PSK-CCMP][ESS]   KabelBox-B6B0
> add_network
1
<3>CTRL-EVENT-DISCONNECTED bssid=c8:0e:14:95:8c:f1 reason=4 locally_generated=1
<3>CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>SME: Trying to authenticate with c8:0e:14:95:8c:f1 (SSID='SysNummer800' freq=2462 MHz)
<3>Trying to associate with c8:0e:14:95:8c:f1 (SSID='SysNummer800' freq=2462 MHz)
<3>Associated with c8:0e:14:95:8c:f1
<3>CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
<3>CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=DE
<3>WPA: Key negotiation completed with c8:0e:14:95:8c:f1 [PTK=CCMP GTK=CCMP]
<3>CTRL-EVENT-CONNECTED - Connection to c8:0e:14:95:8c:f1 completed [id=0 id_str=]
<3>CTRL-EVENT-DISCONNECTED bssid=c8:0e:14:95:8c:f1 reason=4 locally_generated=1
<3>CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>SME: Trying to authenticate with c8:0e:14:95:8c:f1 (SSID='SysNummer800' freq=2437 MHz)
<3>Trying to associate with c8:0e:14:95:8c:f1 (SSID='SysNummer800' freq=2437 MHz)
<3>Associated with c8:0e:14:95:8c:f1
<3>CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
<3>CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=DE
<3>WPA: Key negotiation completed with c8:0e:14:95:8c:f1 [PTK=CCMP GTK=CCMP]
<3>CTRL-EVENT-CONNECTED - Connection to c8:0e:14:95:8c:f1 completed [id=0 id_str=]
<3>CTRL-EVENT-DISCONNECTED bssid=c8:0e:14:95:8c:f1 reason=4 locally_generated=1
<3>CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>SME: Trying to authenticate with c8:0e:14:95:8c:f1 (SSID='SysNummer800' freq=2412 MHz)
<3>Trying to associate with c8:0e:14:95:8c:f1 (SSID='SysNummer800' freq=2412 MHz)
<3>Associated with c8:0e:14:95:8c:f1
<3>CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
<3>CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=DE
<3>WPA: Key negotiation completed with c8:0e:14:95:8c:f1 [PTK=CCMP GTK=CCMP]
<3>CTRL-EVENT-CONNECTED - Connection to c8:0e:14:95:8c:f1 completed [id=0 id_str=]
> CTRL-EVENT-Scan-results
Unknown command 'CTRL-EVENT-Scan-results'
> CTRL-EVENT-SCAN_RESULTS
Unknown command 'CTRL-EVENT-SCAN_RESULTS'
<3>CTRL-EVENT-DISCONNECTED bssid=c8:0e:14:95:8c:f1 reason=4 locally_generated=1
<3>CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>SME: Trying to authenticate with c8:0e:14:95:8c:f1 (SSID='SysNummer800' freq=2437 MHz)
<3>Trying to associate with c8:0e:14:95:8c:f1 (SSID='SysNummer800' freq=2437 MHz)
<3>Associated with c8:0e:14:95:8c:f1
<3>CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
<3>CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=DE
<3>WPA: Key negotiation completed with c8:0e:14:95:8c:f1 [PTK=CCMP GTK=CCMP]
<3>CTRL-EVENT-CONNECTED - Connection to c8:0e:14:95:8c:f1 completed [id=0 id_str=]
<3>CTRL-EVENT-DISCONNECTED bssid=c8:0e:14:95:8c:f1 reason=4 locally_generated=1
<3>CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>SME: Trying to authenticate with c8:0e:14:95:8c:f1 (SSID='SysNummer800' freq=2462 MHz)
<3>Trying to associate with c8:0e:14:95:8c:f1 (SSID='SysNummer800' freq=2462 MHz)
<3>Associated with c8:0e:14:95:8c:f1
<3>CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
<3>CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=DE
<3>WPA: Key negotiation completed with c8:0e:14:95:8c:f1 [PTK=CCMP GTK=CCMP]
<3>CTRL-EVENT-CONNECTED - Connection to c8:0e:14:95:8c:f1 completed [id=0 id_str=]
> quit


Code:

sysvorOrt michi # /etc/init.d/wlp2s0 restart
 * Bringing up interface wlp2s0
 *   Starting wpa_supplicant on wlp2s0 ...
Successfully initialized wpa_supplicant
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlp2s0' manually if it is not used anymore
Failed to initialize control interface 'DIR=/var/run/wpa_supplicant GROUP=wheel'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

nl80211: deinit ifname=wlp2s0 disabled_11b_rates=0
 *   start-stop-daemon: failed to start `/usr/sbin/wpa_supplicant'                                                                                                                 [ !! ]
 * ERROR: wlp2s0 failed to start
[/code}
[code]#less /etc/wpa_supplicant/wpa_supplicant.conf[/code]
update_config=1
network={
        ssid="SysNummer800"
        #psk="/etc/init.d/apache2start"
        psk=79eeb4639e68a5f33d9a467a1035b9fa9f1167731a8f68e4778b7d4876e53ecb
}
Code:

sysvorOrt michi # ifconfig
bond0: flags=5123<UP,BROADCAST,MASTER,MULTICAST>  mtu 1500
        ether be:35:f0:36:1c:85  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp4s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 70:8b:cd:a4:7a:93  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Lokale Schleife)
        RX packets 98  bytes 11162 (10.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 98  bytes 11162 (10.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.178.24  netmask 255.255.255.0  broadcast 192.168.178.255
        inet6 2a02:8108:1bf:c6f8:ec85:faf3:ea19:1e3e  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::7c4f:920d:7656:2fdb  prefixlen 64  scopeid 0x20<link>
        ether e4:be:ed:1f:7c:f9  txqueuelen 1000  (Ethernet)
        RX packets 9557  bytes 6055985 (5.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 10315  bytes 1594992 (1.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Sorry - one information only ...


Code:
a part of dmesg now:
[ 3171.010429] rtlwifi:rtl_watchdog_wq_callback [rtlwifi]:<0-0> AP off, try to reconnect now
[ 3171.010497] wlp2s0: Connection to AP c8:0e:14:95:8c:f1 lost
[ 3172.487798] wlp2s0: authenticate with c8:0e:14:95:8c:f1
[ 3172.507813] wlp2s0: send auth to c8:0e:14:95:8c:f1 (try 1/3)
[ 3172.509997] wlp2s0: authenticated
[ 3172.517492] wlp2s0: associate with c8:0e:14:95:8c:f1 (try 1/3)
[ 3172.521873] wlp2s0: RX AssocResp from c8:0e:14:95:8c:f1 (capab=0x31 status=0 aid=1)
[ 3172.522278] wlp2s0: associated
[ 3283.333879] rtlwifi:rtl_watchdog_wq_callback [rtlwifi]:<0-0> AP off, try to reconnect now
[ 3283.333896] wlp2s0: Connection to AP c8:0e:14:95:8c:f1 lost
[ 3297.774942] wlp2s0: authenticate with c8:0e:14:95:8c:f1
[ 3297.795012] wlp2s0: send auth to c8:0e:14:95:8c:f1 (try 1/3)
[ 3297.797328] wlp2s0: authenticated
[ 3297.804656] wlp2s0: associate with c8:0e:14:95:8c:f1 (try 1/3)
[ 3297.813289] wlp2s0: RX AssocResp from c8:0e:14:95:8c:f1 (capab=0x31 status=0 aid=1)
[ 3297.814133] wlp2s0: associated
[ 3301.824381] wlp2s0: disassociated from c8:0e:14:95:8c:f1 (Reason: 2)
[ 3303.325234] wlp2s0: authenticate with c8:0e:14:95:8c:f1
[ 3303.345319] wlp2s0: send auth to c8:0e:14:95:8c:f1 (try 1/3)
[ 3303.454986] wlp2s0: send auth to c8:0e:14:95:8c:f1 (try 2/3)
[ 3303.564986] wlp2s0: send auth to c8:0e:14:95:8c:f1 (try 3/3)
[ 3303.674984] wlp2s0: authentication with c8:0e:14:95:8c:f1 timed out
[ 3311.575766] wlp2s0: authenticate with c8:0e:14:95:8c:f1
[ 3311.595781] wlp2s0: send auth to c8:0e:14:95:8c:f1 (try 1/3)
[ 3311.599962] wlp2s0: authenticated
[ 3311.605439] wlp2s0: associate with c8:0e:14:95:8c:f1 (try 1/3)
[ 3311.627458] wlp2s0: RX AssocResp from c8:0e:14:95:8c:f1 (capab=0x31 status=0 aid=1)
[ 3311.627839] wlp2s0: associated
[ 3373.498943] rtlwifi:rtl_watchdog_wq_callback [rtlwifi]:<0-0> AP off, try to reconnect now
[ 3373.499021] wlp2s0: Connection to AP c8:0e:14:95:8c:f1 lost
[ 3374.969315] wlp2s0: authenticate with c8:0e:14:95:8c:f1
[ 3374.989414] wlp2s0: send auth to c8:0e:14:95:8c:f1 (try 1/3)
[ 3374.992585] wlp2s0: authenticated
[ 3374.999025] wlp2s0: associate with c8:0e:14:95:8c:f1 (try 1/3)
[ 3375.003593] wlp2s0: RX AssocResp from c8:0e:14:95:8c:f1 (capab=0x31 status=0 aid=1)
[ 3375.003953] wlp2s0: associated
[ 3525.347419] rtlwifi:rtl_watchdog_wq_callback [rtlwifi]:<0-0> AP off, try to reconnect now
[ 3525.347433] wlp2s0: Connection to AP c8:0e:14:95:8c:f1 lost
[ 3526.907921] wlp2s0: authenticate with c8:0e:14:95:8c:f1
[ 3526.927957] wlp2s0: send auth to c8:0e:14:95:8c:f1 (try 1/3)
[ 3526.930636] wlp2s0: authenticated
[ 3526.937614] wlp2s0: associate with c8:0e:14:95:8c:f1 (try 1/3)
[ 3526.942258] wlp2s0: RX AssocResp from c8:0e:14:95:8c:f1 (capab=0x31 status=0 aid=1)

[/code]



[code]
_________________
www.edv-bildung.de
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Sat May 20, 2017 9:54 am    Post subject: Reply with quote

michi-monster wrote:
Code:
sysvorOrt michi # /etc/init.d/wlp2s0 restart
 * Bringing up interface wlp2s0
 *   Starting wpa_supplicant on wlp2s0 ...
Successfully initialized wpa_supplicant
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlp2s0' manually if it is not used anymore
Failed to initialize control interface 'DIR=/var/run/wpa_supplicant GROUP=wheel'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.
...
...
For netifrc you should have removed wpa_supplicant from the runlevels.

You could boil down your dmesg output to the important part by using grep: https://wiki.gentoo.org/wiki/Wifi#dmesg
Back to top
View user's profile Send private message
michi-monster
Apprentice
Apprentice


Joined: 16 Aug 2016
Posts: 175
Location: Germany

PostPosted: Sat May 20, 2017 10:57 am    Post subject: Reply with quote

I dont understand. I cant find a wpa in a runlevel.
What can / shuld i do?
Code:
sysvorOrt michi # rc-update
              apache2 |      default                           
               binfmt | boot                                   
             bootmisc | boot                                   
                devfs |                                 sysinit
               dhcpcd |      default                           
                dmesg |                                 sysinit
                 fsck | boot                                   
             hostname | boot                                   
              hwclock | boot                                   
              keymaps | boot                                   
            killprocs |                        shutdown       
    kmod-static-nodes |                                 sysinit
                local |      default nonetwork                 
           localmount | boot                                   
             loopback | boot                                   
              modules | boot                                   
             mount-ro |                        shutdown       
                 mtab | boot                                   
               procfs | boot                                   
                 root | boot                                   
            savecache |                        shutdown       
                 swap | boot                                   
               sysctl | boot                                   
                sysfs |                                 sysinit
         termencoding | boot                                   
                 udev |                                 sysinit
         udev-trigger |                                 sysinit
              urandom | boot                                   

Code:
sysvorOrt michi # /etc/init.d/wlp2s0 restart
 * Bringing up interface wlp2s0
 *   Caching network module dependencies
need dbus
 *   Starting wpa_supplicant on wlp2s0 ...
Successfully initialized wpa_supplicant                                   [ ok ]
 *   Starting wpa_cli on wlp2s0 ...                                       [ ok ]
 *   Backgrounding ... ...
 * WARNING: wlp2s0 has started, but is inactive
Code:

sysvorOrt michi # dmesg | grep -i -E 'xx:xx.x|wlan|iwl|80211'
[    2.796401] usb 1-4: Product: FRITZ!WLAN AC 430
[   10.639465] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[   10.839463] rtl8192ce 0000:02:00.0 wlp2s0: renamed from wlan0

_________________
www.edv-bildung.de
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Sat May 20, 2017 3:20 pm    Post subject: Reply with quote

michi-monster wrote:
I dont understand. I cant find a wpa in a runlevel.

I was referring to your post 8070102, reading
Code:
sysvorOrt michi # rc-config list | grep 'wpa_supplicant\|dhcpcd\|net.'
  dhcpcd
  net-online
  net.enp4s0                default
  net.lo
  netmount
  wpa_supplicant            default
sysvorOrt michi # rc-update add dhcpcd
 * service dhcpcd added to runlevel default
sysvorOrt michi #
It seems you already removed services net.enp4s0 and wpa_supplicant from the runlevels?

michi-monster wrote:
What can / shuld i do?
Code:
sysvorOrt michi # rc-update
              apache2 |      default                           
               binfmt | boot                                   
             bootmisc | boot                                   
                devfs |                                 sysinit
               dhcpcd |      default                           
                dmesg |                                 sysinit
                 fsck | boot                                   
             hostname | boot                                   
              hwclock | boot                                   
              keymaps | boot                                   
            killprocs |                        shutdown       
    kmod-static-nodes |                                 sysinit
                local |      default nonetwork                 
           localmount | boot                                   
             loopback | boot                                   
              modules | boot                                   
             mount-ro |                        shutdown       
                 mtab | boot                                   
               procfs | boot                                   
                 root | boot                                   
            savecache |                        shutdown       
                 swap | boot                                   
               sysctl | boot                                   
                sysfs |                                 sysinit
         termencoding | boot                                   
                 udev |                                 sysinit
         udev-trigger |                                 sysinit
              urandom | boot                                   
Here you have dhcpcd in runlevel default. Are you going to set up dhcpcd as your network manager?

Then do not try anything with net.wlp2s0 as you did here:
michi-monster wrote:
Code:
sysvorOrt michi # /etc/init.d/wlp2s0 restart
 * Bringing up interface wlp2s0
 *   Caching network module dependencies
need dbus
 *   Starting wpa_supplicant on wlp2s0 ...
Successfully initialized wpa_supplicant                                   [ ok ]
 *   Starting wpa_cli on wlp2s0 ...                                       [ ok ]
 *   Backgrounding ... ...
 * WARNING: wlp2s0 has started, but is inactive
Code:

sysvorOrt michi # dmesg | grep -i -E 'xx:xx.x|wlan|iwl|80211'
[    2.796401] usb 1-4: Product: FRITZ!WLAN AC 430
[   10.639465] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[   10.839463] rtl8192ce 0000:02:00.0 wlp2s0: renamed from wlan0
Your 'xx:xx.x' should read '02:00.0' and 'iwl' be replaced by 'rtlwifi', ok?

Correct set up of wpa_supplicant for usage with dhcpcd is here.
Back to top
View user's profile Send private message
michi-monster
Apprentice
Apprentice


Joined: 16 Aug 2016
Posts: 175
Location: Germany

PostPosted: Sat May 20, 2017 4:52 pm    Post subject: Reply with quote

Many thanks. It works. I have checked the options. What was the hard error i dont know. But it is not important (at this time) :-)
_________________
www.edv-bildung.de
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum