Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Failed X11 Install
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6957
Location: Saint Amant, Acadiana

PostPosted: Fri May 19, 2017 5:19 am    Post subject: Reply with quote

I do not run Gentoo with GUI in a VM, but here is the option:
Code:
│ Symbol: DRM_VIRTIO_GPU [=n]                                                                             
 │ Type  : tristate                                                                                         
 │ Prompt: Virtio GPU driver                                                                             
 │   Location:                                                                                             
 │     -> Device Drivers                                                                                 
 │       -> Graphics support                                                                               
 │   Defined at drivers/gpu/drm/virtio/Kconfig:1                                                           
 │   Depends on: HAS_IOMEM [=y] && DRM [=y] && VIRTIO [=n] && MMU [=y]                                   
 │   Selects: DRM_KMS_HELPER [=y] && DRM_TTM [=n]                                                           

_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
EugeneTheJeep
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2017
Posts: 101

PostPosted: Sat May 20, 2017 11:57 pm    Post subject: Reply with quote

X now runs after installing app-emulations/virtualbox-guest-additions

Had to do the following to successfully emerge guest additions:

1. Resolve package conflicts:
mask x11-base/xorg-drivers to resolve blocked package in virtualbox-guest-additions:
https://forums.gentoo.org/viewtopic-p-8067272.html?sid=68cfc9ebf9858bcbb648ba3ef7639e8b

Code:
touch /etc/portage/package.mask/x11
nano -w /etc/portage/package.mask/x11
=x11-base/xorg-drivers-1.19:0/0


2. Downgrade to kernel 4.4 because guest-additions 5.0.32 fails to compile with kernel 4.9:
https://forums.gentoo.org/viewtopic-p-8031894.html#8031894
https://bugs.gentoo.org/show_bug.cgi?id=603472
Alternatively you can patch kernel 4.9

Also, to compile Virtio GPU driver I had to manually edit /usr/src/linux/.config:

Code:
CONFIG_VIRTIO_PCI=y
CONFIG_VIRTIO_MMIO=y


Only after doing that would the option for Virtio GPU show up in make menuconfig. This was true for both 4.4 and 4.9
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6957
Location: Saint Amant, Acadiana

PostPosted: Sun May 21, 2017 12:23 am    Post subject: Reply with quote

You need to enable options it depends on, editing .config manually is not a good idea.
Code:
Depends on: HAS_IOMEM [=y] && DRM [=y] && VIRTIO [=y] && MMU [=y] 

_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
EugeneTheJeep
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2017
Posts: 101

PostPosted: Sun May 21, 2017 9:34 pm    Post subject: Reply with quote

Ok good to know- I double checked to make sure those dependencies were enable in the kernel and thankfully they already were.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum