Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba root mount woes: smbclient works, mount not
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
jesnow
Guru
Guru


Joined: 26 Apr 2006
Posts: 581

PostPosted: Mon May 15, 2017 2:14 pm    Post subject: Samba root mount woes: smbclient works, mount not Reply with quote

I'm trying to mount the root partition on my RPi with samba. Why is
another matter. I need help from someone with better samba skills than mine.

Here is my share from smb.conf:
Quote:

[root]
comment = root access
path = /
valid users = root
force user root
forge group root
writeable = yes
create mask = 0755


When I browse it with smbclient it works:
Quote:

armstrong jesnow # smbclient -L //192.168.1.240/
Enter root's password:
Domain=[GEOSC] OS=[Windows 6.1] Server=[Samba 4.2.14]

Sharename Type Comment
--------- ---- -------
root Disk root access
IPC$ IPC IPC Service (SnowPi1)
Domain=[GEOSC] OS=[Windows 6.1] Server=[Samba 4.2.14]

Server Comment
--------- -------
ARMSTRONG Armstrong
LOCALHOST SnowPi1

Workgroup Master
--------- -------
GEOSC ARMSTRONG


When I log in with smbclient it works:
Code:

smbclient  //192.168.1.240/root
Enter root's password:
Domain=[GEOSC] OS=[Windows 6.1] Server=[Samba 4.2.14]
smb: \> dir
  .                                   D        0  Thu Mar 16 19:06:09 2017
  ..                                  D        0  Thu Mar 16 19:06:09 2017
  usr                                 D        0  Tue Dec  6 03:54:24 2016
  sys                                DR        0  Wed Dec 31 18:00:17 1969
  etc                                 D        0  Mon May 15 06:43:51 2017
  lost+found                          D        0  Thu Mar 16 17:59:28 2017
  run                                 D        0  Sun May 14 18:04:59 2017
  lib                                 D        0  Sat May 13 20:42:57 2017
  proc                               DR        0  Wed Dec 31 18:00:00 1969
  0 sd card for Raspi.txt             N        0  Thu Mar 16 19:05:11 2017
  dev                                 D        0  Wed Dec 31 18:00:35 1969
  sbin                                D        0  Sat May 13 20:42:57 2017
  bin                                 D        0  Sat May 13 20:42:57 2017
  boot                                D        0  Thu Mar 16 19:56:05 2017
  var                                 D        0  Thu Jan 28 10:56:37 2016
  opt                                 D        0  Thu Jan 28 10:56:37 2016
  tmp                                 D        0  Mon May 15 07:13:21 2017
  home                                D        0  Wed Dec 31 18:30:35 1969
  root                                D        0  Wed Dec 31 18:45:03 1969
  mnt                                 D        0  Thu Jan 28 10:56:37 2016
  media                               D        0  Thu Jan 28 10:56:37 2016

                3041408 blocks of size 1024. 791428 blocks available
smb: \> exit


But when I try to mount it, barf:

Quote:

armstrong jesnow # mount -t cifs //192.168.1.240/ /mnt/test
mount: wrong fs type, bad option, bad superblock on //192.168.1.240/,
missing codepage or helper program, or other error
(for several filesystems (e.g. nfs, cifs) you might
need a /sbin/mount.<type> helper program)

In some cases useful info is found in syslog - try
dmesg | tail or so.


Thanks for Samba's supremely ambiguous error messaging I'm left with 5 possible error cases to think about, all of which I can rule out because smbclient connects. So I'm kind of at a loss. Any help would be greatly appreciated. Nothing interesting in dmesg on either machine.

Jon.
Back to top
View user's profile Send private message
DawgG
l33t
l33t


Joined: 17 Sep 2003
Posts: 808

PostPosted: Tue May 16, 2017 12:18 pm    Post subject: Reply with quote

i think because the share is named [root] in smb.conf the mount-cmd must be
Code:
mount -t cifs //192.168.1.240/root /mnt/test
mount -t cifs //<host>/<share> /mount/point/
analogous to
Code:
smbclient  -L //192.168.1.240/root

the share-name root and linux / are not the same :wink:
GOOD LUCK!
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum