Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Window frames flashing {compositing issue} [HIATUS]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dufeu
l33t
l33t


Joined: 30 Aug 2002
Posts: 896
Location: US-FL-EST

PostPosted: Sun May 14, 2017 4:24 pm    Post subject: Window frames flashing {compositing issue} [HIATUS] Reply with quote

I've been using Xrender as the compositor but I'd like to start using OpenGL.

The problem I'm having is that under either OpenGL 2.0 or OpenGL 3.1, when I open an independent sub dialog box, the frames of all the other windows start flashing. Clicking on an other window stops the flashing. One of the odd things is that I must click on an unrelated window to stop the flashing. Clicking on the desktop itself does not stop the flashing.

Nearly all desktop effects are turned off. The only effects turned on are: "Login", "Translucency" and "Present Windows". AFAIK, none of these has anything to do with flashing window frames.

I'd like some suggestions on possible settings I could change or what I can look for as specific causes.

Window Manager: KDE
Widget style: Breeze
Decorations: Oxygen
Look and Feel: Breeze
Theme: Elegance

This is a dual UDF monitor configuration.

Setup:
Code:
Linux pyrogyro 4.10.15-gentoo #1 SMP PREEMPT Mon May 8 20:21:57 EDT 2017 x86_64 AMD A10-7850K Radeon R7, 12 Compute Cores 4C+8G AuthenticAMD GNU/Linux

[I] kde-apps/kde-meta
     Installed versions:  17.04.1(5){tbz2}(11:38:39 PM 05/12/2017)

[I] media-libs/mesa
     Installed versions:  17.1.0_rc4^d{tbz2}(02:37:25 PM 05/12/2017)(classic dri3 egl gallium gbm gles2 llvm nptl opencl vaapi vdpau wayland xvmc -bindist -d3d9 -debug -gles1 -openmax -osmesa -pax_kernel -pic -selinux -valgrind -vulkan -xa ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32" VIDEO_CARDS="r600 radeon radeonsi -freedreno -i915 -i965 -imx -intel -nouveau -r100 -r200 -r300 -vc4 -vivante -vmware")

[I] x11-base/xorg-server
     Installed versions:  1.19.3{tbz2}(08:30:10 PM 05/08/2017)(glamor ipv6 suid udev xorg -debug -dmx -doc -kdrive -libressl -minimal -selinux -static-libs -systemd -tslib -unwind -wayland -xephyr -xnest -xvfb)

[I] x11-drivers/xf86-video-amdgpu
     Installed versions:  9999{tbz2}(08:32:17 PM 05/08/2017)(glamor)

[I] x11-drivers/xf86-video-ati
     Installed versions:  7.9.0{tbz2}(08:30:56 PM 05/08/2017)(glamor udev)

# cat 20-radeon.conf
Section "Device"
   Identifier  "Radeon"
   Driver      "radeon"
   Option      "DRI3"   "on"

# cat 30-multihead.conf
Section "Monitor"
    Identifier  "DisplayPort-0"
    Option      "Primary" "true"
EndSection

Section "Monitor"
    Identifier  "HDMI-0"
    Option      "RightOf" "DisplayPort-0"
EndSection

Thoughts, tips, suggestions will be much appreciated!
_________________
People whom think M$ is mediocre, don't know the half of it.


Last edited by dufeu on Thu May 18, 2017 10:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5588

PostPosted: Sun May 14, 2017 5:18 pm    Post subject: Reply with quote

I have 「Option "AccelMethod" "glamor"」 and 「Option "TearFree"」 in my xorg.conf, maybe one or both of those will help?

I'm running compton, not KDE, but it seems slightly more reliable with these regardless.
Back to top
View user's profile Send private message
mrbassie
Guru
Guru


Joined: 31 May 2013
Posts: 525

PostPosted: Mon May 15, 2017 6:13 pm    Post subject: Reply with quote

Try disabling the "blur" effect in system settings --> desktop behaviour --> desktop effects and then restarting or stopping/starting X.

EDIT: In the options for that effect there is "save intermediate rendering results", disabling that may be all that is required (assuming you've run into the same thing I did).
EDIT2: Oops! Didn't read your post properly, I missed the line about effects. Nevermind.
Back to top
View user's profile Send private message
dufeu
l33t
l33t


Joined: 30 Aug 2002
Posts: 896
Location: US-FL-EST

PostPosted: Thu May 18, 2017 10:17 pm    Post subject: Reply with quote

Ant P. wrote:
I have 「Option "AccelMethod" "glamor"」 and 「Option "TearFree"」 in my xorg.conf, maybe one or both of those will help?

I'm running compton, not KDE, but it seems slightly more reliable with these regardless.

I appreciate the tips. :) They reminded me of a few other things which then prompted me to go back and re-review X-org's Radeon Feature page. I also found Arch Linux' ATI Performance Tuning article to be of interest.

For "Kaveri", the AccelMethod "glamor" is enabled by default. As described under the VSYNC section of the above linked page, "Tearfree" enables hardware pageflipping instead of blitting. However, this only applies to full screen GL applications. This doesn't really apply to me because I rarely have anything running full screen. Not even movies.

Of more interest though I haven't yet had a change to is the SwapBuffersWait parameter. The EXAVsync parameter applies to older GPUs.

I also reviewed free.desktop.org's commit log pages for mesa and xf86-video-amdgpu.

In particular, I'd like to note the "radeonsi" module in mesa had apparently been undergoing very active development for the four weeks I reviewed the log. At this point, it's probably just best if I just continue to use xrender and check back with opengl after each mesa update.

I'm not set up to collect and provide meaningful debugging information. {sigh}

Thanks everyone. If anything changes, I'll note it here.
_________________
People whom think M$ is mediocre, don't know the half of it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum