Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Sway 0.13.0 does not start (segmentation fault)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
hariskar
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jan 2017
Posts: 104
Location: Greece/Kavala

PostPosted: Fri May 12, 2017 4:15 pm    Post subject: [SOLVED] Sway 0.13.0 does not start (segmentation fault) Reply with quote

Any help on this?
No problem with Sway-0.12.2. Is it a bug?
Thank you!

Code:
$ sway -dV
05/12/17 19:11:58 - [main.c:185] Linux gentoo 4.11.0-gentoo #7 SMP Wed May 10 18:31:37 EEST 2017 x86_64 Intel(R) Core(TM) i3-4330 CPU @ 3.50GHz GenuineIntel GNU/Linux
05/12/17 19:11:58 - [main.c:157] Contents of /etc/lsb-release:
05/12/17 19:11:58 - [main.c:164] DISTRIB_ID="Gentoo"
05/12/17 19:11:58 - [main.c:157] Contents of /etc/os-release:
05/12/17 19:11:58 - [main.c:164] NAME=Gentoo
05/12/17 19:11:58 - [main.c:164] ID=gentoo
05/12/17 19:11:58 - [main.c:164] PRETTY_NAME="Gentoo/Linux"
05/12/17 19:11:58 - [main.c:164] ANSI_COLOR="1;32"
05/12/17 19:11:58 - [main.c:164] HOME_URL="https://www.gentoo.org/"
05/12/17 19:11:58 - [main.c:164] SUPPORT_URL="https://www.gentoo.org/support/"
05/12/17 19:11:58 - [main.c:164] BUG_REPORT_URL="https://bugs.gentoo.org/"
05/12/17 19:11:58 - [main.c:157] Contents of /etc/gentoo-release:
05/12/17 19:11:58 - [main.c:164] Gentoo Base System release 2.3
05/12/17 19:11:58 - [main.c:142] PATH=/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/6.3.0:/usr/lib/llvm/4/bin:/sbin
05/12/17 19:11:58 - [main.c:142] LD_LOAD_PATH=(null)
05/12/17 19:11:58 - [main.c:142] LD_PRELOAD_PATH=(null)
05/12/17 19:11:58 - [main.c:142] LD_LIBRARY_PATH=(null)
05/12/17 19:11:58 - [main.c:142] SWAY_CURSOR_THEME=(null)
05/12/17 19:11:58 - [main.c:142] SWAY_CURSOR_SIZE=(null)
05/12/17 19:11:58 - [main.c:142] SWAYSOCK=(null)
05/12/17 19:11:58 - [main.c:142] WLC_DRM_DEVICE=(null)
05/12/17 19:11:58 - [main.c:142] WLC_SHM=(null)
05/12/17 19:11:58 - [main.c:142] WLC_OUTPUTS=(null)
05/12/17 19:11:58 - [main.c:142] WLC_XWAYLAND=(null)
05/12/17 19:11:58 - [main.c:142] WLC_LIBINPUT=(null)
05/12/17 19:11:58 - [main.c:142] WLC_REPEAT_DELAY=(null)
05/12/17 19:11:58 - [main.c:142] WLC_REPEAT_RATE=(null)
05/12/17 19:11:58 - [main.c:142] XKB_DEFAULT_RULES=(null)
05/12/17 19:11:58 - [main.c:142] XKB_DEFAULT_MODEL=(null)
05/12/17 19:11:58 - [main.c:142] XKB_DEFAULT_LAYOUT=(null)
05/12/17 19:11:58 - [main.c:142] XKB_DEFAULT_VARIANT=(null)
05/12/17 19:11:58 - [main.c:142] XKB_DEFAULT_OPTIONS=(null)
05/12/17 19:11:58 - [main.c:51] [wlc] Doing work on SUID/SGID side and dropping permissions
05/12/17 19:11:58 - [main.c:51] [wlc] Work done, dropping permissions and checking communication
05/12/17 19:11:58 - [main.c:362] Dropping extra capabilities
05/12/17 19:11:58 - [main.c:377] Starting sway version 0.13.0

05/12/17 19:11:58 - [config.c:438] Set XDG_CONFIG_HOME to /home/hk/.config
05/12/17 19:11:58 - [config.c:463] Loading config from /etc/sway/security.d/00-defaults
05/12/17 19:11:58 - [commands.c:509] handling config command 'permit * fullscreen keyboard mouse'
05/12/17 19:11:58 - [commands.c:338] find_handler(permit) 0
05/12/17 19:11:58 - [security.c:14] Validating IPC target '*'
05/12/17 19:11:58 - [permit.c:72] Permissions granted to * for features 112
05/12/17 19:11:58 - [commands.c:509] handling config command 'permit /usr/bin/swaylock lock'
05/12/17 19:11:58 - [commands.c:338] find_handler(permit) 0
05/12/17 19:11:58 - [permit.c:62] cmd_permit:Unable to resolve IPC permit target '/usr/bin/swaylock'. will issue empty policy
05/12/17 19:11:58 - [security.c:14] Validating IPC target '/usr/bin/swaylock'
05/12/17 19:11:58 - [security.c:156] Unable to allocate security policy
05/12/17 19:11:58 - [main.c:51] [wlc] Terminating wlc...
05/12/17 19:11:58 - [main.c:51] [wlc] Terminating compositor...
05/12/17 19:11:58 - [main.c:51] [wlc] Compositor terminated...
Segmentation fault
05/12/17 19:11:58 - [main.c:51] [wlc] Parent exit (2862)


Code:

$sudo emerge --info
Password:
Portage 2.3.5 (python 3.4.6-final-0, default/linux/amd64/13.0/desktop, gcc-6.3.0, glibc-2.24-r1, 4.11.0-gentoo x86_64)
=================================================================
System uname: Linux-4.11.0-gentoo-x86_64-Intel-R-_Core-TM-_i3-4330_CPU_@_3.50GHz-with-gentoo-2.3
KiB Mem:     8101100 total,   7254124 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Fri, 12 May 2017 13:00:01 +0000
sh bash 4.4_p12
ld GNU ld (Gentoo 2.27 p1.0) 2.27
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r1::gentoo
dev-lang/python:          2.7.13::gentoo, 3.4.6::gentoo
dev-util/cmake:           3.8.1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.26::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r3::gentoo
sys-devel/automake:       1.13.4-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo
sys-devel/gcc:            6.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.ntua.gr/pub/linux/gentoo/ http://ftp.ntua.gr/pub/linux/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr encode exif firefox flac gdbm gif glamor gpm gtk
iconv jpeg lcms ldap libnotify mad mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds readline sdl seccomp session spell ssl svg tcpd tiff truetype udev udisks unicode upower usb vorbis x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd
actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid
dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load
memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18
garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="en en-GB el en-US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US en_GB el" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Last edited by hariskar on Fri Jun 16, 2017 4:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
zenmetsu
n00b
n00b


Joined: 30 Nov 2010
Posts: 16

PostPosted: Tue Jun 13, 2017 9:05 pm    Post subject: Reply with quote

Surprised that no one chimed in yet,

Add the swaylock use flag to sway and re-emerge it.
Back to top
View user's profile Send private message
hariskar
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jan 2017
Posts: 104
Location: Greece/Kavala

PostPosted: Fri Jun 16, 2017 4:33 pm    Post subject: Reply with quote

Thanks a lot!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum