Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kmail1 no stable package?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tomtom69
Apprentice
Apprentice


Joined: 09 Nov 2010
Posts: 204
Location: Bavaria

PostPosted: Tue May 09, 2017 2:07 pm    Post subject: kmail1 no stable package? Reply with quote

Since last sync there is no stable kmail1 package.
I have installed kde-apps/kmail-4.4.2016.01-r1 which is now marked as unavailable.
The successor (?) kmail-4.4.2017.04 is not yet stable on amd64.
Is this because the 2017.04 version is still testing and not stable?
If "yes" does it help the maintainers if I unmask and install and test it and report anywhere whether it works or not?

tom
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7138
Location: Austria

PostPosted: Tue May 09, 2017 5:45 pm    Post subject: Reply with quote

Please upgrade to 4.4.2017.04, thanks to Arfrever's huge patchset it removes a blocker against gpgme-1.8.0[cxx,qt5] and thus enables us to go forward with new stabilisations of Frameworks and Applications. The new kdepim-meta-4.4.2017.04 meta package locks down its dependencies to =4.4.2017* so the only package.mask that you need from there on is probably '>=kde-apps/kdepimlibs-4.14.11_pre20160211'.

Note that there is no developer left using KDE PIM 4.4 (aka 'veryoldpim') at this point, and another stabilisation is just not realistic. Currently several packages from it fail to build against GCC-6.3.0 (fine with GCC 5.4.0) and patches will be accepted, but it is probably the last ever iteration of 4.4. At some point this year the inevitable will happen and it is going to be moved to kde-sunset overlay.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
tomtom69
Apprentice
Apprentice


Joined: 09 Nov 2010
Posts: 204
Location: Bavaria

PostPosted: Wed May 10, 2017 6:54 pm    Post subject: Reply with quote

Upgrade to 4.4.2017.04 worked.
Thank you and thanks to Arfrever. :-)

So it looks like kmail1 gets abandoned. I am looking for a mail client replacement for a while now, but (as always) changing of a program used for >10 years is not that eay. My wishlist is:
- several identities with separate accounts (IMAP, POP3/SMTP)
- DE integration in a way that mail attachments can be easily opened by the associated program (at least common file types like pdf, jpg)
- Possibility to view (simple) HTML mails without using an external browser (which opens all links, other included spam crap, and executes everything inside the mail)
- support for encryption
- only mail client, not included web browser, organizer, office suite and other funny stuff that blows the client up
- long term solutuion using gentoo ;-)
At the moment I am trying claws-mail, which looks not too bad. Any other options that I should try?

I also noticed that knode will disappear soon. Is that really true? (knode is my _alltime favorite_ usenet group reader for a very long time now, since KDE2). Is there any good replacement?
Checked Thunderbird but this is way too big (looks like it includes a web browser, news, mail, .... in one program).

tom
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum