Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emacs is ignoring .Xmodmap
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1036
Location: Tujunga, CA

PostPosted: Sat Jun 20, 2009 5:49 pm    Post subject: emacs is ignoring .Xmodmap Reply with quote

I want a bunch of keys treated as "meta" in emacs. At present only the alt key works for this. My .Xmodmap contains
Code:
keycode 116 = Alt_R
keycode 117 = Alt_R
keycode 115 = Alt_L
Until recently all these keys were treated as "meta" in emacs. When trying them in xev, all map to Alt_L or Alt_R as they should. But in emacs if I try the key with the window symbol on it, together with w, I get "A-w" is undefined. And a key with what looks like a small PDA in it together with a w, gives A-M-w is undefined. I want these key pushes to give M-w, but to also give meta for all keys. Is there a solution? Thanks,
Fred

P.S. I thought I'd see what would happen if I tried these keys in a tty window and discovered that <ctrl-alt-F1> does nothing. What is going on??
Back to top
View user's profile Send private message
xavier10
Guru
Guru


Joined: 19 Jan 2004
Posts: 456
Location: Paris, France

PostPosted: Wed Jun 30, 2010 10:17 am    Post subject: Reply with quote

I also have issues with emacs ignoring xmodmap right now.
I am typing a lot of latex on a latin keyboard (fr) and remapped my Alt_gr so as to reduce stress on my right wrist, using xmodmap. The command line sees my modification just fine, but emacs just ignores it.
How is it working ? How can emacs bypass the xmodmap, while ran under X ???
Back to top
View user's profile Send private message
ohnobinki
n00b
n00b


Joined: 04 Nov 2004
Posts: 9
Location: Michigan, United States

PostPosted: Mon Oct 15, 2012 5:15 am    Post subject: Re: Reply with quote

I'm having this same issue. In my ~/.xinitrc, I have:
Code:
# Have left Windows key be alt gr key
echo 'keycode 133 = Multi_key' | xmodmap - &

but emacs still interprets that key as “s-” instead of seeing the composed character I attempt to type.

It seems like this must be some “feature” of emacs: how do I turn it off? ;-)
Back to top
View user's profile Send private message
ohnobinki
n00b
n00b


Joined: 04 Nov 2004
Posts: 9
Location: Michigan, United States

PostPosted: Wed May 10, 2017 3:12 am    Post subject: Reply with quote

I read somewhere else, I can’t remember, that somehow launching Emacs with XMODIFIERS cleared gets it to respect modifiers. I think I had XMODIFIERS set to something for other programs but somehow the Emacs doesn’t require XMODIFIERS to be set to use the feature that setting XMODIFIERS adds to other programs—but I don’t remember as my setup is broken in other ways now. So if you have XMODIFIERS set, this might be a work around for launching Emacs itself:

Code:
XMODIFIERS= emacs &
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum